1. Are you ready for the Galaxy S20? Here is everything we know so far!

I cannot run root commands on android 9 on lg51k

Discussion in 'Android Lounge' started by David665, Oct 30, 2020.

  1. David665

    David665 Lurker
    Thread Starter

    Ok, so my "LG Connectivity Service" app turned on my bluetooth last night, with all bluetooth settings turned off. I cannot gain root access, run su or sudo commands.
    So I run a simple 'mount' command and get the output shown in my attached picture.
    MY QUESTION: Is this normal ??? And why cant i run su or sudo commands?

     


  2. Best Answer:
    Post #7 by MrJavi, Oct 30, 2020 (4 points)
  3. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    is the phone rooted?
     
    Xavier Black and MrJavi like this.
  4. David665

    David665 Lurker
    Thread Starter

    Umm, I'm not sure. I have tried to root it with several apps... When I checkroot it says it is not rooted. All apps fail.
    I installed the kingoroot app on the phone, and then on my pc. It quickly goes to 100% on the progress bar, then gives an error. Ill have to start writing those numbers down haha.
    I have tried with at least 5 apps so far. Zero success.
     
  5. David665

    David665 Lurker
    Thread Starter

    I apologize for not being too savvy with my very limited experience with post-internet computer languages, I programmed a game in 1989 using Pascal 5.0 OOP, made an actual working game that I used a year later for 2.0 units of college credit. Haven't programmed anything significant since then... Except a pixel-generating fractal screensaver using "Scratch" building-block app.

    I originally began this message intending to apologize for lagging in my response time. I shouldn't have smoked those gonnabeenoids.

    Anyways, I have included screenshots of the "ls -l" command output. I am certain that everything is all ****ed up, especially in my socially-hacked life.
     

    Attached Files:

    #4 David665, Oct 30, 2020
    Last edited: Oct 30, 2020
    MrJavi likes this.
  6. David665

    David665 Lurker
    Thread Starter

    THE APP IN THE SCREENSHOT is "Terminal Emulator" made by KSHARK

    I also have these screenshots when I ran the
    "ls -l" command under the /system/bin directory.

    Is this abnormal output, or am I just trippin? If I am trippin, then can somebody, for the love of Christ, please help me to gain root access to my phone? Jesus please forgive me and my enemies. Oct 29, 2020 at 11:24 PM[/GALLERY]
     
    #5 David665, Oct 30, 2020
    Last edited: Oct 30, 2020
    MrJavi likes this.
  7. MrJavi

    MrJavi Android Expert

    #6 MrJavi, Oct 30, 2020
    Last edited: Oct 30, 2020
    Xavier Black likes this.
  8. MrJavi

    MrJavi Android Expert

    If your Lg is on Api 23 or higher (Marshmallow 6.0 and above) that would explain why using an app to root didn't work. It would also explain why the terminal emulator failed to grant root access.

    To my knowledge there currently isn't a root method for the Lg 51k . :(
     
    #7 MrJavi, Oct 30, 2020
    Last edited: Oct 30, 2020
    Xavier Black, David665 and ocnbrze like this.
  9. bcrichster

    bcrichster ROMinator
    Moderator

    As @MrJavi says, there's likely no current Root capability for that device. Very few Carriers have Rootable LG devices as almost ALL of them have locked bootloaders, which is what's used to gain Root access on Android 7.0+ by modifying the boot.img and/or changing stock recovery.img to a working custom recovery (like TWRP, and via PC) made for that specific device and then flashing Magisk (which also modifies said boot.img). Tbh, most ppl have basically given up Rooting LG devices nowadays and just go buy Motorola's and Samsungs, so long as it isn't a Verizon branded device because they're just basically guaranteed locked down (No hate, just informative FYI). :thumbsupdroid:
     
  10. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    also i would like to add that never use apps to root a device. it is always better to learn to root the device the hard way. and if you plan on rooting the device do you research first over at https://forum.xda-developers.com/. it is a developers forum. but if there is a way to root the device, the method will be posted there. if you do not see your device in the forums there, then your device does not have the backing of the development community.

    just remember no devs=no fun
     
    Xavier Black, David665 and MrJavi like this.
  11. David665

    David665 Lurker
    Thread Starter

    Ok, that explains a lot. Thanks everyone, I truly appreciate your help.
     
    Xavier Black, ocnbrze and MrJavi like this.
  12. Alexenferman

    Alexenferman Member

    Is your phone from the US? If so did you buy it from a carrier? If you did buy it from Verizon, Sprint etc.. you cannot root it.
     
    ocnbrze likes this.
Loading...

Share This Page

Loading...