1. Are you ready for the Galaxy S20? Here is everything we know so far!

I can't download google play services.

Discussion in 'Android Help' started by Google Play Services, Feb 19, 2016.

  1. Google Play Services

    Thread Starter

    So I know there are many forums about this problem, but the don't help. I've tried basically everything. I don't want to tell my parents because they would just yell at me because I got the phone just 5 months ago. If there's anything I can do without totally killing the phone or any important files on it please help.
     


  2. chanchan05

    chanchan05 The Doctor

    How did you lose it in the first place anyway?
    And what phone model do you have?
     
  3. Jalynn

    Jalynn Lurker

    Hi I made the original post and I have a droid mini. I didn't lose anything it just won't let me update Google play services. (Google +, Hangouts, Motorola Connect, VZ Navigator) I've even tried updating them separately but it just doesn't work
     
  4. chanchan05

    chanchan05 The Doctor

    Google Play Services are updated via Play Store. What happens when you try to update?
     
  5. Stiles Joram

    Stiles Joram Lurker

    I had the same issue with my phone too by I resolve.
    I figured out I had so many apps downloading and updated at the same time.
    Go to play store >> My account >> My apps and games.
    Stop all the downloads. I think this should work. It worked on mine
     
  6. Parayilhussain

    Parayilhussain Android Enthusiast

    connect WIFI,go to settings>storage>apps scroll down for google play services tap on this and tap on uninstall updates.
    Finishing this open G+ app or google map it will prompt to update play services,tap to update.other option is tap to uninstall updates.
    finishing this open chrome browser and type in google search box "google play services update" hit and see
    in next page google play services icon tap here and in next page tap in play store icon,see notification for play services
    update,tap to update.if not updating > uninstall updates,
    finishing this open chrome browser, in google search box type "www.apkmirror.com/apk/google-inc/google/
    play/services/ " hit and see in next page latest version of play services tap on this then tap on play
    store icon,see notification for play services update,tap to update.
     
  7. Yea I having the same Problem too. I'm using a blackberry z30 please help. With me though it says I need this app to run let's say snapchat
    Or clash of clans
     
    #8 johnathansmit10, Feb 20, 2016
    Last edited: Feb 20, 2016
  8. i'm having slightly the same problem however i'm not having a problem updating, only installing apps and games. The error message i receive is: "Game Name" can't be installed on USB storage or SD card. Try again, and if the problem continues, get help troubleshooting. (Error code: -18)
     
  9. davidywise

    davidywise Newbie

    I think you need to update your time maybe your phone is out of date. Usually it does error because of out of date.
     
  10. i had that issue with phone last week, already fixed....still can't install games, however i WAS able to install TurboTax
     
  11. davidywise

    davidywise Newbie

    Well i'm gonna ask some help from my friends about this. Maybe they could help.
     
Loading...
Similar Threads - can't download google
  1. justinedwardfayer
    Replies:
    1
    Views:
    155
  2. Tatjana_Buta
    Replies:
    1
    Views:
    198
  3. Phyllis Hedding
    Replies:
    9
    Views:
    310
  4. Lauris
    Replies:
    2
    Views:
    252
  5. kenhitokiri
    Replies:
    10
    Views:
    639
  6. ShalomxPeace
    Replies:
    0
    Views:
    240
  7. Asapphire541
    Replies:
    12
    Views:
    921
  8. dorlow
    Replies:
    6
    Views:
    631
  9. TheRealLiam
    Replies:
    12
    Views:
    1,216
  10. rdoty
    Replies:
    4
    Views:
    8,798

Share This Page

Loading...