1. Are you ready for the Galaxy S20? Here is everything we know so far!

I destroyed my phone?

Discussion in 'Android Devices' started by aslabs, May 18, 2011.

  1. aslabs

    aslabs Lurker
    Thread Starter

    Hi guys, yesterday I was in the bus and the battery of my phone finished up. No problem I have 2 extra batteris always charged and with me (originals, from ebay).

    When I switched the battery the phone got stocked on the flashing "S" screen.

    As soon as I got at home I charged and switched the battery to the original one, and my phone stopped to load even the welcome.

    I tried all other batteries and the same happens.

    I read on internet that this may be a hardware failure...

    Finally I tried to connect it to ODin and do what ever do you call it "flash" "reset" "etc"

    I actually installed the latest firmware ROM.

    Since then I cant do anything with the phone. it can't boot, it can't "Vol UP + Pwr + Home",
    only "Vol Dwn + Home + Pwr" that connect it to ODin.

    In this moment I'm tring to download an older ROM (april 2011) to see if it goes better.

    Can Anyone help me with this, what exactly happened to my phone? Is there a chance to have it back :( :( :(

    PS: does this sound to you like some hardware burned up?
    ps 2: HEEEEEEEEEEEEEEEEEEEEEEEEEEEEELP!!!!!
     



    1. Download the Forums for Android™ app!


      Download

       
  2. robogo

    robogo Android Enthusiast

    If you can't start the phone up properly, try with a JIG, it might force your phone into download mode.
     
  3. shaahinjjj

    shaahinjjj Well-Known Member

    is your phone from Bell by any chance? if yes, it could be the internal memory card that failed, which happened to me a few times.
     

Samsung Galaxy S Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...

Share This Page

Loading...