1. Are you ready for the Galaxy S20? Here is everything we know so far!

i have a rooted phone and im trying to use repetitouch

Discussion in 'Android Help' started by willsp28, Jan 15, 2020.

  1. willsp28

    willsp28 Member
    Thread Starter

    everything seems to be set up correctly, but when i hit play it stays playing but doesn't do any touch inputs
     

    Advertisement

  2. MoodyBlues

    MoodyBlues Compassion is cool!
    VIP Member

    Disclaimer: I have no experience with RepetiTouch, and I haven't rooted a device since 2013. :eek:

    With that said, I looked at its description and noted the following:

    "But beware, replaying touch events can fail or cause unwanted effects for many reasons, e.g., if replay is started at a different device state than during the recording or if during replay a popup is shown or something else is different than during recording. Thus, always monitor your device during replay! Replay automatically stops if you're touching the screen, pressing the power button or on a phone call."

    Are you sure none of that applies?

    If so, I'd do the standard troubleshooting procedure; after each step, open the app and see if the problem is solved:

    - reboot your device
    - close the app, then delete its cache
    - close the app, then delete its cache and data
    - close the app, then delete its cache and data, then 'force stop'
    - close the app, then delete its cache and data, then 'force stop', then uninstall and reinstall the app

    Post your results!
     
    MrJavi and ocnbrze like this.
  3. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    also it would help to know what phone you have and what rom you are on.
     
    MoodyBlues and MrJavi like this.
  4. MrJavi

    MrJavi Android Expert

    I'd just like to add to the above

    1. Phone Settings= app info = make sure permission are granted.

    2. Phone setting = apps that can appear on top and enable

    3. Phone settings = app manager= (apps that can) change system settings , scroll to app and alow.

    Reboot or force stop the app then launch the app.

    If it still fails, It may need a BusyBox app to install the proper binaries (applets). Many rooted apps require BusyBox to function as expected.

    Finally, What OS are you currently on?
    The latest update of repetitouch was Feb 2017 Its possibility the app isn't compatible with newer versions of Android OS.
     
    #4 MrJavi, Jan 16, 2020
    Last edited: Jan 16, 2020
    MoodyBlues and ocnbrze like this.
  5. willsp28

    willsp28 Member
    Thread Starter

    im installing busybox, and have tryd most of the steps listed, wifh my phone being android 5.0 the permissions is a bit different then im used to, on minit seems there is no ability to turn or off specific permissions you just go to app info and it lists its required permissions
     
    MrJavi likes this.
  6. MrJavi

    MrJavi Android Expert

    1. Is the repetitouch app to internal or external sd?
    2. What system environment path did you choose to install the BusyBox binaries/applets ? For example /sbin/ , /system/xbin/, /sysyem/ bin/, ........ Although, you should know that I can trll you witch one to choose. It depends on your rom , root method and type or kernel you have installed. If your only lollipop 5.0 ,I believe your have system root. If I had to guess (key word GUESS), Id say /system/xbin/, but I can be certain.
    3. If all else fails, You have to consider its a poorly written app. If you hit @MoodyBlues play store repetitouch link
    Start reading customer reviews, it seems you not the only one having issues running the app.
     
    ocnbrze and MoodyBlues like this.
  7. willsp28

    willsp28 Member
    Thread Starter

    ok. my root method, kingroot failed, Kingo root succeeded, then installed repetitouch no replay action, factory reset, installed kingroot Said it was rooted, installed repetitouch still no replay action, i have this working on lots of Android 5.0 devices before so im a little lost as to what is stopping this frrom working, under kingroot it says repetitouch has root permissions
     
    MrJavi likes this.
  8. willsp28

    willsp28 Member
    Thread Starter

    well i just bricked it, i installed tasker and set it up, so i wanted to test to see if could function correctly, so i made it reboot, it turned off and the first logo pops up but nothing after that, tryd all common inputs to reach the recovery menu but nothing whatsoever, tryd several reboots, removing the battery and power on again, holding power on with battery out and plugged in, and got the missing battery icon, but still nothing helped, i think this phone was just too old and not capable of running correctly, i have another identical phone that runs repetitouch all the time, i really would like to be able to root newer devices, but android 5 are fairly cheap to buy so im not super concerned about it, but if anyone can think of anything i haven't tryd please let me know, another thing id like to learn how to do is to hook it to to a pc and reinstall software with adb im guessing
     
  9. MrJavi

    MrJavi Android Expert

    Its a pleasure to me you @willsp28. I have a rooted Samsung Galexy Note 4 n910p (Sprint) on 6.0.1 MM.

    Were your previous device from a different manufacturer that the one you have now?

    The repetitouch app that worked on your other devices the same version or a lower version?

    internal storage have enough space left for the application to function as intended?
     
    ocnbrze likes this.
  10. MrJavi

    MrJavi Android Expert

    Ouch!!! can you boot into download mode?
     
    ocnbrze likes this.
  11. MrJavi

    MrJavi Android Expert

    What phone do you have?
     
    ocnbrze likes this.
  12. MrJavi

    MrJavi Android Expert

    Did you have usb debugging enabled in developer options ?
     
    ocnbrze likes this.
  13. willsp28

    willsp28 Member
    Thread Starter

    no i don't believe So
     
  14. MrJavi

    MrJavi Android Expert

    Any chance its a bad battery?
    As for not having usb debugging enabled and how to flash official firmware with a pc? I honestly haven't got a clue. The fist time I rooted was with an app. I Immediately noticed, the app had root control and I was secondary to the app. I found it to be unacceptable. Thatbwas the first and only time I ever used an ap yo root a device. I was positive, I need to root with a pc and I had to learn how the hell to do that :) as I didnt have experience with pc, the programs I didn't even know what drivers where.
    I was determined to haveva rooted phone come hell or high water. Adding to my resolve way when Id open an rooted app on my non-rooted phone it would instantly popup a message "root required" and close. I felt like the app was telling me "VIP only, no peasants allowed, peon!". I chuck about it now but back then I took it as an insult. :) Open it again and kick out again. :)
    Anyway , to make a long story short, I learn how to flash via pc and I have always had to enable usb debugging.
    I have no idea how to use a pc to flash with usb disabled. Sorry
     
    ocnbrze likes this.
Loading...

Share This Page

Loading...