1. Are you ready for the Galaxy S20? Here is everything we know so far!

I need a pendopad backup

Discussion in 'Android Devices' started by jazzalee, May 15, 2011.

  1. jazzalee

    jazzalee Lurker
    Thread Starter

    I need a pendo pad backup/update.img or compatible firmware from any body who has a pendo.It bricked itself before I could get a backup I can flash it but I cant find the firmware anywhere online.

    1. Download the Forums for Android™ app!


  2. brucedungey

    brucedungey Lurker

    Have you had any success finding an image yet as I am in need of it as well?
  3. jazzalee

    jazzalee Lurker
    Thread Starter

    no not as yet. I don't know why pendo don't have a firmware update in their support section!! would make life a whole lot easier.
  4. brucedungey

    brucedungey Lurker

    As I have bricked mine, I have been game enough to try a few compatible ROMS. Got one for a Apad 710 to work no back button, a small text size and screen out of alignment sadly as else working including Market. Able to use the device again while hunting down original.

    Email me brucedungey@gmail.com for link if useful to you.

    Any further yet on a genuine?
  5. razzze10

    razzze10 Lurker

    I'm in the same sinking boat, trying to find a pendo pad backup is impossible....

    Any news on a backup rom :thinking:
  6. jazzalee

    jazzalee Lurker
    Thread Starter

    no nothing yet will post it if i find but I too am finding this impossible to find pendopad firmware online. Doesn't anyone own one??
  7. kingfox1

    kingfox1 Lurker

    to reset disconect batteries - reconect
    i have a working pendo. andriod 2.1
  8. richie01

    richie01 Lurker

    Tell me how to root it and back it up and install a custom rom for this tablet and ill upload a backup of it for you.
  9. ag011090ag

    ag011090ag Newbie

    This is only for windows users.
    Also only for rockchip 2818 not for other ones!!!

    What do you need
    Winrar < Not included in package!
    Android drivers
    Rockchip drivers
    Rockchip flash program
    SD card or internal memory on the device self (150mb atleast)
    USB Cable

    Programs can be downloaded in this package.
    So al the progams you need are in the rar file.

    1. Preparing the device
    First install Z4Root and SU on you're device.

    Then start Z4Root and click on ''Temporary Root" he will root the device for you and after reboot you will loose the root access so don't reboot!

    After that connect you're device to an windows machine he will ask you to install drivers.

    Install the drivers and then start CMD
    (Windows XP: Start > run > CMD > Enter)
    (Windows vista and 7 Start > Type CMD > Enter)

    now locate to the ADB.exe folder i recommended to place it in the C: root.
    so type this in CMD
    cd C:

    when you are there type this command.
    adb push rkdump /data/

    After that type adb shell
    this command bring you to a terminal like command line for you device.

    Ok now watch you're device and type su in cmd.
    A popup will show up to get SU access for terminal press "allow"
    Now we can backup the FS.

    type this in cmd
    cat /proc/mtd
    a list will popup like this one

    mtd0: 00002000 00000010 "misc"
    mtd1: 00004000 00000010 "kernel"
    mtd2: 00002000 00000010 "boot"
    mtd3: 00004000 00000010 "recovery"
    mtd4: 00030000 00000010 "system"
    mtd5: 0003a000 00000010 "backup"
    mtd6: 0003a000 00000010 "cache"
    mtd7: 00100000 00000010 "userdata"
    mtd8: 00cbc000 00000010 "user"
    mtd9: 00020000 00000010 "pagecache"
    mtd10: 00020000 00000010 "swap"

    i made one red because that the line we need.

    NOTE: we need backup partition so look always to mtd number not every device have backup as mtd5 it might also be 6 or 1 or some other random number!

    Now it is time to backup!
    type this
    /data/rkdump /dev/block/mtdblock? /!!!/update.img

    place the number of the mtd on the ''?''
    if example your number is 6 use it like this

    place the destination backup folder on the !!!
    flash for the tablet internal memory
    sdcard for to backup on the sdcard

    if you did this good it will say this
    update.img found (116115456 bytes) < File size may be difference depends on device.

    after it is done it will say this
    crc found (4 bytes, 0x0709e735) < Also this could be difference

    Gongrats you backup you're FS now you can destroy you're device with custom roms!

    2. Restore you're FS

    Sometime you will see you destroy you're device what now!
    Good thing you made a backup of you're FS!
    First Hold back/ecs button on you're device just hold it and put the usb cable in it.
    (From pc to the tablet ofcourse)
    you're pc will give you a driver notice install them (included from the package)
    After that start RKAndroidBatchUpgrade.exe
    Then choose in settings you're backup and press ''Upgrade''
    Wait a few seconds or minutes and you are done.
    congrats you can use youre device again!
  10. ag011090ag

    ag011090ag Newbie

    I need someone to do a backup for me as i am on public pcs and cannot install packages, if someone does a backup for me i will recompile a cyanogen cm5 or cm7 2.2+ rom and upload for everyone to use.. im using tpc7slv model pendo pad
  11. beneschk

    beneschk Lurker

    OK guys you have obviously tried to root your pendo pad and failed or attempted to flash. either way you do not need an update.img file for it. Here is a quick tutorial how to factory reset your pendo pad. This will only work on windows since that is the only way i know how, but it should be basically the same for windows and mac.

    First you are going to need Android SDK which you can just google android SDK should be first link

    When installing it install it to an easy path E.G C:\ would be easier.

    now once this is installed you now need to find where you installed it to and open SDK manager

    you will then need to download Android SDK platform tools and android sdk tools also android 2.1 SDK platform in the android 2.1 drop down menu.

    Once all of those components are installed and ready to use you need to set your environmental variables.
    (windows 7 & vista) Go to computer and click system properties in the top tool bar, then click advanced system settings then a window will pop up and click environmental variables.
    now in the bottom half where it says system variables find where it says PATH and change the path of it to where ever you downloaded the android SDK tools. for example if you installed it in c:\ change the path to "C:\android-sdk\platform-tools\adb.exe"
    Once you have completed this you will need super1click rooting software which you can just google super 1 click download. try get the latest version 2.3.1 i think its by shortfuse or something

    once downloaded extract where ever desktop would be easiest. then open up superoneclick application plug in your pendo pad via usb and turn on, hopefully you havent screwed the ADB drivers. now once plugged in and turned on open up super one click and click on Shell root. once completed, (it may crash upon completion) if so just close it hopefully it worked.
    now for the final and easy step, open up your command prompt by clicking start and typing CMD into the search bar and pressing enter or for Windows XP press start click run and type CMD.
    In the command prompt you need to type in adb shell
    it will now say something about a daemon server starting or adb server stopping just let it go, once it finishes it should have a # symbol there, if it has a $ symbol do the super one click step again. if it did work and you have a # symbol simpily type "wipe data" without quotation marks, your pendo pad should reboot into factory default mode. (this may take a while to boot up). and enjoy :D
  12. ag011090ag

    ag011090ag Newbie

    thanks for the posts but they dont help those who have bricked device with custom roms, iam looking for somebody to rom dump so i can compile usable custom roms, and host STOCK firmwares
  13. Esotericizm

    Esotericizm Lurker

    I saw your post on the whirlpool forums and had tried to do the same thing your doing (fairly computer savvy) but I could not for the life of me get a working update.img. Tried again after reading your post and still failed. ADB wont let me push the file to data nor even though I have mounted it as read/write.

    What I have done though is make a working dump file that you could then extract the update.img file from, As to how to do this I am stumped again but I have followed the steps listed Dump your Home Tablet rom and create a custom rom - Wiki.ArchosFans.com

    I have the backup.Dump file which I will upload to mediafire soon, Maybe you will have better luck or maybe you can explain to me what I need to do (I believe its listed under Additional Info But do I need a hex editor and if so what am I looking for?).

    Will edit post with link for Backup.dump soon.

    And here it is http://www.mediafire.com/?qy73cgaaq11gb3a
  14. Esotericizm

    Esotericizm Lurker

    Been up all night and starting to think this aint gonna happen :/ Got Rkdump on the pendo pad but and dumped everything EXCEPT update.img...Here's where i go wrong.

    # cat /proc/mtd
    cat /proc/mtd
    dev: size erasesize name
    mtd0: 00002000 00000010 "misc"
    mtd1: 00004000 00000010 "kernel"
    mtd2: 00002000 00000010 "boot"
    mtd3: 00004000 00000010 "recovery"
    mtd4: 00038000 00000010 "system"
    mtd5: 0003a000 00000010 "backup"
    mtd6: 0003a000 00000010 "cache"
    mtd7: 00080000 00000010 "userdata"
    mtd8: 00179800 00000010 "user"
    mtd9: 00020000 00000010 "pagecache"
    mtd10: 00020000 00000010 "swap"
    # /data/rkdump /dev/block/mtdblock5 /scard/update.img
    /data/rkdump /dev/block/mtdblock5 /scard/update.img
    unknown image (00 00 00 00)

    Here's what I do have so far :
    Boot.img : http://www.mediafire.com/?ovcmjg0mdns398a
    Kernal.img : http://www.mediafire.com/?s3si2035b43p17o
    recovery.img : http://www.mediafire.com/?8i1ksiou4fszbnh
    System.img : http://www.mediafire.com/?cm1mwbiehb6l1p7
  15. jazzalee

    jazzalee Lurker
    Thread Starter

    you are the man!! using the above .img files and RKAndroidTool_v1.23 I was able to get my pendo working properly again.Much appreciated.:)
  16. Esotericizm

    Esotericizm Lurker

    No worries man glad I could help
  17. styelz

    styelz Newbie

    I can't download the SYSTEM image file, could you please send me a copy?

Share This Page