Root I need help Rooting! =PLEASE READ=


I got this tablet, and of course, I want to install a custom ROM, the bootloader is unlocked already (voided warrenty, whatever...) so next part is to downgrade, so i can use sparky root app to root it.

I downloaded the blob .zip, unpacked and put blob on the internal storage of my TF300 and the micro sd card (just in case) so whats wrong?
The Viper Tool says it works but it says "may take 3-10 minutes" but it takes like 30 seconds or less, so i know it didnt work (and I have root checker, still no root) so what do I have to do?

I have android 4.2.1
(i dont know how to read build versions)
Build version (below)

Pad EC is

I am on Windows 8, if you think its my Operating system, I can try on my Windows 7 laptop but I dont think it will make a difference. Please help :(

EDIT- I tried the same thing with the Viper tool + Asus PC suite (for drivers and all, and splashtop was OFF for sure) and it still didnt work, and this time it was on my Windows 7 laptop ._.


  • CMDfine.PNG
    61.4 KB · Views: 104


Thread starter
Can someone guide be through rooting, unlocking (if that Asus app didin't do the trick) and stuff. I know how to flash ROMs, but the rooting process has stuck me so I need help!