1. Check out our companion app, Forums for Android! Download from Google Play

I need to vent...

Discussion in 'T-Mobile' started by skeptic82, Dec 29, 2008.

  1. skeptic82

    skeptic82 Guest
    Thread Starter

    I finally got my G1 yesterday (Yay!). But now I'm waiting for my data package to take effect and it's taking FOREVER!!! I just sitting here looking at my phone and imagining all the fun I'll have once it starts working. But until then, I'm going to keep putting my SIM in it once an hour and trying in vain.....

    On a side note, if I see that "There was a problem connecting to Google's servers" message one more time I very well may go completely berserk...

    Thanks, I feel better... *twitch*
     

    Advertisement

  2. robsclone

    robsclone Member
    15

    Dec 17, 2008
    19
    0
    15
    At a certain point when waiting for my service to turn on, I had to power off the phone and turn it back on. I waited about 3 hours, nothing, and then after off/on it started working

    worth a shot:) welcome to G1-ownership!
     
  3. JBea

    JBea Member
    5

    Dec 29, 2008
    5
    0
    5
    yeah, mine took the full 48 hours and still didn't work. Turns out that the person who set it up didn't save my sim card number in the system, so it was never set up correctly. I had no phone calls or anything for three days waiting for it to work. Make sure your stuff is setup correctly. Once they fixed it, it worked immediately.
     
  4. randel77

    randel77 Well-Known Member
    35

    Dec 14, 2008
    137
    0
    35
    san diego
    weird mine took about an hour. closer to half:eek:
     
  5. skeptic82

    skeptic82 Guest
    Thread Starter

    I was afraid that was what happened, so I called customer care, and they verified my SIM # and the number of my G1. The nice lady just told me to wait, it could take up to 48 hours.

    I've seriously had to limit myself to checking it every 2 hours, this morning I think I tried to sign in 15 times in an hour. I was driving myself crazy! I think the best tactic is to go to the bar, drink until I don't care about the phone, then come home and try it.... At least then if it doesn't work, I'll be drunk. Sounds good.....
     
  6. STORM3333

    STORM3333 Well-Known Member
    56

    Oct 28, 2008
    160
    6
    56
    I AM A CHEF BY TRADE AND NOW RUN A RESTAURANT
    CALIFORNIA
    awe I really hope you get it up and running soon!
     
  7. Zeruel

    Zeruel Active Member
    36

    Jan 6, 2009
    32
    2
    36
    Las Vegas, NV
    I got my phone the day before it was supposed to officially launch and it activated instantly. Then somehow the data plan got removed from my account a few weeks later and I had to re-add it. The phone completely worked while the data plan was missing except for data services (no internet). After I added it back on through t-mobile.com everything was up and running in about 15-20 minutes.
     
  8. Babaki

    Babaki Member
    5

    Jan 5, 2009
    6
    0
    5
    Tech
    North Jersey
    they day i bought my phone the data was instantly active. the guy handed it to me and i immediately set up gmail account. porting my number and getting phone calls took about 24 hours though to fully work. but data was on immediately.
     
  9. skeptic82

    skeptic82 Guest
    Thread Starter

    i have flexpay and previously had the blackberry data plan. I had to wait for that plan to get taken off before the G1 plan could be activated. It was inconvienent but hey, it's working now. I'm more than happy with the phone. I feel bad for my girlfriend, I've barely put this thing down since I got it....
     
  10. lenny3683

    lenny3683 Member
    15

    Oct 16, 2008
    16
    0
    15
    I got mine back in October and promptly destroyed 7 sim cards:eek:, had to send it back, then go to a store and purchase it there. and then it finally worked:D
     
  11. How did you destroy (7) simcards...?
     

Share This Page

Loading...