1. Check out our companion app, Forums for Android! Download from Google Play

Support I still cant update to 2.2.1, please help me

Discussion in 'Android Devices' started by VMX, Oct 4, 2010.

  1. VMX

    VMX Well-Known Member
    Thread Starter

    Feb 22, 2010
    I cant update to 2.2.1. Its because I did the one click root, I know this. I was told I have to re-install FRF91. I go to this site..

    Nexus One/Guides & Tutorials - XDA-Developers

    and I follow those steps but it doesnt work. I dont know if I am doing it wrong or if something else is wrong. I will go over exactly what I do to re-install and if anyone can, tell me if I am missing a step and/or doing a step wrong.

    1. I download the file for FRF91.
    2. Using ASTRO, I rename it to PASSIMG.zip
    3. I copy the file, and paste it in the file labeled "Sd card." the other options to put it in are "asec" and "secure."
    4. Power phone down.
    5. Hold down the volume minus button and power it on. A white screen appears with 3 android guys at the bottom. It says "loading passdiag.zip" it says "no or wrong image."
    6. It then says loading "passimg.zip." it takes the time to load it.
    7. It says checking "passimg.zip."
    8. Then it goes to a list of options which are..FAST BOOT, RECOVERY, CLEAR STORAGE, SIMLOCK.

    Thats where it all falls apart. Step 8 is supposed to be when I supposed to get the update by pressing volume up. But if I press volume up or down its just scrolling through that list of options in step 8. Is ASTRO the reason? Am I not putting it in the right SD CARD folder? I am so confused.

    What is going wrong? Do I have to Revert HBOOT to older version? if so, I have no idea how to do that. Help me please.


  2. Mostly Harmless

    Mostly Harmless Well-Known Member

    Apr 15, 2010
    New York
    OK here is what I did, please note that I did this blindly and it may/may not be a good idea.

    1. I download the file for FRF91.
    2. I renamed it update.zip and moved it to the folder labeled sd card (if you do it by computer just drop it into the main folder).
    3. I turned the phone off.
    4. While holding volumn down I powered on the phone.
    5. I scrolled down to recovery and pressed the power button.
    6. When I saw the triangle with an exclamation point symbol I pressed the power and volume up buttons at the same time.
    7. Then I selected apply sdcard:update.zip and pressed the trackball.
    8. I then let the phone do it's thing, it paused for a while on the triangle with an exclamation point but I just let it sit there and eventually it powered back up.
    9. I then deleted that file off the card and did the same thing with the 2.2.1 update.

    That is what worked for me when I used the one click root method.
  3. Rusty

    Rusty Well-Known Member

    Jan 21, 2010
    Pompey, UK
    I suspect the file you've downloaded is a .zip within a .zip

    You probably need to extract the file, rename that to passimg.zip and try again.
  4. VMX

    VMX Well-Known Member
    Thread Starter

    Feb 22, 2010
    Ok so I did this and it worked!! Thanks so much man, I was getting so frustrated lol. Now I got 2.2.1. I will be able to recieve all future OTA updates right?

Share This Page