1. Are you ready for the Galaxy S20? Here is everything we know so far!

Root I think I'm going nuts

Discussion in 'Android Devices' started by strider70, Jul 16, 2013.

  1. strider70

    strider70 Member
    Thread Starter

    Sorry for the long post.

    It's been a while since I tweaked around with my phone.
    I was running Viper 4G 2.0.2, original firmware, and TWRP v2.2.2 (I think), S-OFF with LazyPanda.

    I liked the phone the way it was because it was running smoothly.
    But a few days ago:
    - my HTC widget that displays photos stopped working
    - Gallery app doesn't show any photos
    - Music app doesn't show any music files

    I have both camera shots and music files in both internal and external storage.
    The sdcard was mounted and I could see these files through ES File Explorer.

    Q: Has this happened to anyone before?


    I decided to back up my files on to the PC.
    After connecting my phone to the PC, it mounts to external sdcard folder only.
    I can't navigate up one folder via PC.
    Hence I am unable to open folders like DCIM for the photos via PC.
    I had to do it the long way by copying the photos to my external sdcard via ES File Manager, then copying from external sdcard to my PC.
    I don't remember this being normal.

    Q: Am I nuts or has it always been this way for the Evo LTE?


    I upgraded TWRP 2.6 via GooManager successfully after failing many times using fastboot to flash (stalls during "writing ...").
    However, I am unabled to make a backup using TWRP 2.6 because it fails while copying data.
    I also remembered being able to backup "android_secure" but the size was 0 this time.

    Q: Am I nuts or has it always been this way?

    I'm currently running Viper 3.1.5 and the photo widget, Gallery, and Music app works as I'd expect.
    But connecting it to my PC now gives me the choice of Mass Storage or Sync, but mounting with Mass Storage still ONLY allows mount to external sdcard as above.

    :thinking:

    Any help or advice is appreciated.
     

    Advertisement

  2. Granite1

    Granite1 Zercron Encrusted Tweezer

    I Personally, I would move all of the files you want to keep out of the internal memory, and wipe it clean from recovery.

    While you're in there, I'd also fresh install Viper to the latest rev.

    What is your radio version?

    Its shown on your hboot screen. :)

    You probably want to upgrade your firmware also.
     
    ocnbrze likes this.
  3. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    any time you get small hiccups or bugs i always wipe dalvik cache and cache and that usually fixes most issues.

    i have not tried the latest twrp just yet so i can't comment on it just yet....maybe this weekend.
     
    Granite1 likes this.
  4. Granite1

    Granite1 Zercron Encrusted Tweezer

    Latest twrp does backups and restores fine. Tested that last night.

    Haven't had time to wipe and fresh install anything yet. :eek:
     
    ocnbrze likes this.
  5. strider70

    strider70 Member
    Thread Starter

    I tried fastboot-linux flash of TWRP 2.6 again, but no good.
    I decided to reflash TWRP via GooManager and try nandroid one more time but omitted to backup android secure. It actually worked.

    Also flashed the latest Viper 4G.
    So far so good.

    I was hoping others would share if their experiences with connecting their LTEvo to PC only mounts to ext_sd. It seems I am going nuts with my lack of memory.
     
  6. Chief YYZ

    Chief YYZ Well-Known Member

    My internal memory works fine now, but, I could not get it to work correctly when I first switched to Viper 4g. I don't remember the exact issue, all I know is I had to copy my entire internal SD to to the external to back it up the first time I tried. I do find it odd the only options are HTC Sync Manager and Disk Drive. No more "charge only." I found I can replicate charge only by mounting as disk drive, then unmounting through windows and leaving the phone options alone. This is the only way I can get the Dalvik Debug Monitor in ADB to recognize the phone.

    Since "charge only" is often in the instructions for many root applications, this bothers me somewhat. Only somewhat since I am already rooted with S-Off and the above mentioned fix seems to replicate charge only. Still, I would like to know why these are the only options, is this only a Viper issue, or is this standard for the LTEvo stock OTA's as well?
     
Loading...

Share This Page

Loading...