1. Are you ready for the Galaxy S20? Here is everything we know so far!

I think my Droid X is a goner

Discussion in 'Android Devices' started by fonefreak, Feb 2, 2011.

  1. fonefreak

    fonefreak Well-Known Member
    Thread Starter

    Yesterday afternoon after I flashed the rubiX 1.9.7, my DX displayed the following:

    Bootloader
    30.04


    Battery OK
    OK to Program
    Connect USB
    Data Cable

    I have removed the battery. The phone instantly goes onto that bootloader page without me pressing a button. I can't get it to turn off holding any button. I also tried putting in the battery while holding every conceivable combination of buttons, but that didn't get me past the bootloader either.

    So I figured that I would have to SBF my DX. SIX TIMES LATER it still displays the same bootloader screen. I've pulled the battery, leaving it out for two - three minutes between each RSDLite session. I've tried every button combination known to man. But there's some sequence I'm missing. I refuse to believe that it is finally gone. It's only three months old! Right now it's sitting here without the fully charged battery on my desk (while I'm forced to use my BB Storm2! - aaagggghhhh!)

    Does anyone know of any other method to resurrect my DX?
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Diz

    Diz Well-Known Member

    What SBF are you using?
     
  3. fonefreak

    fonefreak Well-Known Member
    Thread Starter

    Vrz_mb810_2.3.15_1ff_01
     
  4. RMM

    RMM Member

    That is the wrong SBF if you were running the 2.3.340 software ... which by the way is also needed for Rubix 1.9.7

    Try the 2.3.320 full sbf. If that works you can then update back to 2.3.340
     
  5. hunterwrot

    hunterwrot Well-Known Member

    Sbf .320 then,340 what version of 2.2 did you have prior to the problem
     
  6. fonefreak

    fonefreak Well-Known Member
    Thread Starter

  7. bouchigo

    bouchigo Android Expert

    I've noticed a lot of people using the incorrect sbf lately. If you are unsure, it's better to ask for help beforehand and avoid a big headache, at least that's what I would do.

    Hopefully you can get your phone going with the 2.3.320 full sbf :)
     
  8. fonefreak

    fonefreak Well-Known Member
    Thread Starter

    I'm downloading it right now. Hope this works. Then do I RSD the maderstcok sbf on top of this one (assuming it works)?
     
  9. alprazolam

    alprazolam Android Expert

    +1 Found this out the hard way when I first got my X. It is almost certainly recoverable. Be glad that you aren't sitting in a bootloader error screen and charging your battery with a ghetto, sliced up, usb cable.
     
  10. bouchigo

    bouchigo Android Expert

    Maderstcok is not an sbf file, you have to apply it through clockwork using bootstrap. So you will have to root your phone after a successful flash of 2.3.320 sbf full to install bootstrap, or you could use the system only 2.3.340 sbf to get to 2.3.340.
     
  11. fonefreak

    fonefreak Well-Known Member
    Thread Starter

    Well, the phone has been charging for the past three hours. So I figured by now there's sufficient charge. Unplugged the wall charger, plugged in the phone and a message on the screen says Battery Low Cannot Program.

    How long does it need to stay on the charger? Or is it hosed now?
     
  12. DroidJW

    DroidJW Guest

    not 100% sure but I believe that you cannot charge the phone in bootloader mode (think this also applies when in bootstrap recovery).

    Also I am almost sure the SBF will not initiate without at least 40%+ battery level.

    Do you know someone with a DX that you can pop your battery into and charge?

    Then use charged battery in you phone to proceed with SBF
     
  13. RMM

    RMM Member

    Yes, phone will not charge in bootloader mode.
     
  14. bouchigo

    bouchigo Android Expert

    If you can't do this option, then try going to a VZW store and see if they will let you charge your battery there, or do what alprazolam mentioned a few posts up and charge your battery with a "ghetto, sliced up, usb cable."
     
  15. fonefreak

    fonefreak Well-Known Member
    Thread Starter

    Well, if it can't be charged while it is in bootloader mode, how can I get it out of bootloader mode so I can charge the battery?

    And no, unfortunately, I know no one else with a DX.

    Sliced up USB cable? Pinouts? Guess I can "Google" it...
     
  16. bouchigo

    bouchigo Android Expert

    As far as I know, you are not going to be able to charge your battery unless you have a working OS.

    If you are in bootloader or in bootstrap recovery your battery won't charge. Since your system is hosed right now, you will have to follow one of the options already given by me and the other posters.
     
  17. bouchigo

    bouchigo Android Expert

    I found this online, wish there were pictures, but I hope this helps; maybe you will have better luck and find a guide with pictures. I remember seeing a guide with pictures once, but it was a while ago and I don't remember where.

    1. Take your cable and cut off one of the ends, leaving a standard USB plug at the opposite end to plug into your computer.

    2. Now you need to strip about an inch of the wire off until you get to the core where you should see 4 colored wires (red, black, white, and green). The colors don't really matter and they may vary, just as long as you can see a red wire and a black wire.

    3. Strip off about a quarter inch of the rubber sleeving on the red and black cables, exposing the actual metal wire.

    4. Twist the metal strands of each of the wires a couple of times so that all of the strands from
    the black cable are together and all of the strands from the red cable are together. This is just
    to make sure that you don't create a short circuit.

    5. Here's where it gets a little tricky. You are going to use this cable to make the phone think the battery is fully charged, when in fact you will just be powering the phone using the power from the USB port. Pull out the battery on your phone and find the 4 exposed metal slots (the battery terminals).

    6. The terminals on the far right and far left should be labeled with a plus (+) or a minus (-) on the battery. What you need to do is put the exposed lead of the red wire up to the positive terminal and the lead of the black wire up to the negative terminal. Re-insert the battery to hold the wires in place against the terminals.
     
    Coolguy71261 and fonefreak like this.
  18. fonefreak

    fonefreak Well-Known Member
    Thread Starter

    Thanks - - it's more than what I found when I searched around. I'll try it when I get home from school today. Glad I have two of those cables lying around - one came with my Storm2 and one with the DroidX.
     
  19. GandalfTehGray

    GandalfTehGray Android Expert

    try looking on youtube, and once you get a battery charge and sbf the right file you'll be fine. i thought killed my first dx by not knowing battery didnt charge as well
     
  20. fonefreak

    fonefreak Well-Known Member
    Thread Starter

    I'm baaaaaaacccckkkkk...

    Thanks for all the helpful suggestions and to bouchigo for the cable hack!
     
  21. bouchigo

    bouchigo Android Expert

    So I'm guessing your phone's up and running again?
     
  22. sic0048

    sic0048 Android Enthusiast

    Darn, I was just coming on to post that there is nothing you can do with your phone except sell it to me for $10. ;)

    Glad you got it working!
     
  23. bouchigo

    bouchigo Android Expert

    I would have offered him $10.01 :p:D
     
  24. fonefreak

    fonefreak Well-Known Member
    Thread Starter

    Her. Girl geek.
     
  25. bouchigo

    bouchigo Android Expert

    Oh, sorry about that, that's what I get for assuming......how does the saying go, "you make an a** out of yourself when you assume things"...... lol :p
     

Motorola Droid X Forum

The Motorola Droid X release date was July 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 512GB RAM, TI OMAP3630 processor, and 1540mAh battery.

July 2010
Release Date
0
Reviews
Loading...

Share This Page

Loading...