1. Download our Official Android App: Forums for Android!

I thought i had it sussed....

Discussion in 'Android Devices' started by alowen, Mar 17, 2010.

  1. alowen

    alowen Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    20
    Joined:
    Mar 17, 2010

    Mar 17, 2010
    20
    2
    16
    Hi all, couple of questions: firstly, how do i get the weather app to update by itself without me refreshing? Oh, and ive gone to settings and set update automaticly.

    Secondly: Google mail, how do i get it pushed to my hero? as in real time?

    In the settings i can see the "always on mobile" thing, do i need to tick that box to enable both of the above?

    Thanks in advance

    Al

    P.S.

    Been reading the forum for a while now, love it.
     

    Advertisement

  2. nx1977

    nx1977 Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    2,421
    Joined:
    Feb 8, 2010

    Feb 8, 2010
    2,421
    174
    163
    UK
    Yup, turn that on.
     
  3. alowen

    alowen Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    20
    Joined:
    Mar 17, 2010

    Mar 17, 2010
    20
    2
    16
    Thanks for the response.

    Ive had it on now for 3 or so hours and nether emails nor weather has updated/appeared. Yet when i go to my email account and manually refresh theres emails there????

    Sorry with all the questions, but thanks in advance.

    Al
     
  4. Slug

    Slug Check six!
    Moderator
    Rank:
    None
    Points:
    2,043
    Posts:
    20,551
    Joined:
    Aug 1, 2009

    Aug 1, 2009
    20,551
    16,993
    2,043
    Male
    Mobile phone retail
    Inverness, UK
    I had issues with Googlemail not updating last week. I poll several other accounts via POP and forward the mail to my handset, and it hadn't refreshed for 6 days. I manually refreshed from the web page and within minutes Googlemail started working again. Perhaps a similar "kick-start" will help you?
     
  5. alowen

    alowen Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    20
    Joined:
    Mar 17, 2010

    Mar 17, 2010
    20
    2
    16
    Thanks slug, but it hasnt help im afraid. I got my phone through carphone warehouse and used my voda sim in it and it wouldnt send mms to start with. I rectified that by searching the web to get new settings to type in, it now sends mms.

    I wonder if the lack of updating of the weather and push of emails is caused by similar settings not catered for with a vanilla device with vodafone?

    Al
     
  6. lekky

    lekky Lover
    Rank:
    None
    Points:
    313
    Posts:
    5,250
    Joined:
    Oct 29, 2009

    Probably not if the internet connection works otherwise. I don't suppose you use a task killer do you?
     
  7. alowen

    alowen Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    20
    Joined:
    Mar 17, 2010

    Mar 17, 2010
    20
    2
    16
    Hi, yeah i use the free taskiller. Should i be putting the gmail and weather apps in the ignore list?

    They come up yellow so that means they are caining the battery doesnt it?

    Al
     
  8. alowen

    alowen Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    20
    Joined:
    Mar 17, 2010

    Mar 17, 2010
    20
    2
    16
    Hang on did i just answer my own question (via lekky) ?????????

    I'll give it a try, thanks

    Al
     
  9. lekky

    lekky Lover
    Rank:
    None
    Points:
    313
    Posts:
    5,250
    Joined:
    Oct 29, 2009

    Hah, thats probably the problem :p

    In order to auto-update, a task needs to keep a service open in the background. Most of the time this service will use little if any system resources, only coming into action when it needs to do something, like update a widget. Killing the service means no auto-update.

    However, you are safe to kill the gmail app, if you kill this you WILL still get auto notifications of emails. But this doesn't apply to the default mail app, killing that will stop you getting email updates for any email accounts you have set up on it.

    If you are using taskiller then yellow does mean it is using resources.

    Anyway add the weather (and any other widget you want to auto-update) to your ignore list :p

    Let us know if it works out!
     
  10. alowen

    alowen Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    20
    Joined:
    Mar 17, 2010

    Mar 17, 2010
    20
    2
    16
    Hi, yep it worked for the weather but not my gmail account, do i have to sync it first?

    Al
     
  11. lekky

    lekky Lover
    Rank:
    None
    Points:
    313
    Posts:
    5,250
    Joined:
    Oct 29, 2009

    Check the following:

    Settings > Data Synchronisation >

    Check 'background data'
    Check 'auto-sync'
    Check 'Google Mail'

    Or let us know if they are already ticked.
     
    alowen likes this.
  12. alowen

    alowen Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    20
    Joined:
    Mar 17, 2010

    Mar 17, 2010
    20
    2
    16
    done all your tips lekky, will try out tonight. Just out of interest, how often does it search for updates/new mail?

    Al
     
  13. lekky

    lekky Lover
    Rank:
    None
    Points:
    313
    Posts:
    5,250
    Joined:
    Oct 29, 2009

    the mail should be pushed to your handset as soon as its sent to your email address. Its "push" rather than checking the server at certain intervals, but don't ask me the technical process behind it! Should act like how you get sms.
     
  14. alowen

    alowen Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    20
    Joined:
    Mar 17, 2010

    Mar 17, 2010
    20
    2
    16
    All working now, thanks guys.

    Al
     
Tags:

Share This Page

Loading...