1. Are you ready for the Galaxy S20? Here is everything we know so far!

Support I5800 GPS Problem

Discussion in 'Android Devices' started by RyDeR`, Jan 15, 2011.

  1. RyDeR`

    RyDeR` Newbie
    Thread Starter

    Hi, I'm really tired of the GPS problem...

    It's not working proper. I tried GPSopt but didn't work either.

    Can someone finally give me something that'll fix this? Will the official FroYo fix this???

    Waiting for answer, thanks in advance.


  2. nonyx

    nonyx Lurker

    Hi there. I have the same problem that you have.

    My phone was unable to locate the position though GPS and always gave an error
  3. ceofficer

    ceofficer Lurker

    All, I purchased a Samsung 5800 a few weeks ago and could never get the Navigation to work reliably either. I could get it to work occasionally using the GPS test code of *#*#1472365#*#*, this seemed to kick start it into working some of the time. Tried various apps like Octy and GPS Fix but they seemed to make no difference.

    Was about to give up (I do have a sat nav for the car anyway so not a major issue for me) but decided to try to uninstall Google Maps. However it is factory installed so the phone won't let you do it. though I realised there was an update to Google maps which I must have installed when I first got the phone,

    So in settings->manage applications->maps I uninstalled the update

    Now it finds a GPS fix within 30secs or so (if outside) and this seems to have sorted it out permanantly. Not sure what the Maps update was for but I suppose I can live without it!

    Was about to take the phone back to the shop!
  4. steogede

    steogede Lurker

    I find that when I have difficulty getting a GPS lock, turning on the WiFi helps (even if you don't connect to a network). Failing that, rebooting the phone (and enabling WiFi) generally fixes mine.
    mitchelo likes this.
  5. nandroidman

    nandroidman Lurker

    use FasterFix after test it with GPStest
  6. mitchelo

    mitchelo Lurker

    it did help! I turned on gps and wifi with gps booster lite. thanks
  7. Eromittal

    Eromittal Lurker

    Did you find a permanent solution?
  8. glurta

    glurta Newbie

    Installed Faster Fix but faced with a blank screen, on rooted I5801 with Busy-Box installed. Anyone help?
  9. DrewMove

    DrewMove Newbie

    This always work for me:

    1. First of all start GPS Booster Lite (you can also choose at phone startup, but not necessary)
    2. Then start your GPS function in the menu
    3. At least start your GPS application.
  10. Eromittal

    Eromittal Lurker

    This worked for me

    1. [FONT=&quot]Press *#*#1472365#*#*. This will bring to GPS setting.[/FONT]
    2. [FONT=&quot]Settings [/FONT][FONT=&quot]-> Parameter Settings -> Address -> Server Type: 1x MPC [/FONT]
    3. [FONT=&quot]Settings [/FONT][FONT=&quot]-> Parameter Settings -> Position mode: option3[/FONT]
    4. [FONT=&quot]Settings [/FONT][FONT=&quot]-> Fix Request Settings -> Session Operation: Standalone[/FONT]
    5. [FONT=&quot]Settings [/FONT][FONT=&quot]-> Fix Request Settings -> Server Option: Local[/FONT]
    6. [FONT=&quot]gpsOne XTRA[/FONT][FONT=&quot] -> Xtra Enable: Enable[/FONT]
    [FONT=&quot]Then try with Google Maps.[/FONT]
    [FONT=&quot]If you want to go back to the default setting:[/FONT]

    1. [FONT=&quot]Settings -> Parameter Settings -> Address -> Server Type: UMTS SLP[/FONT]
    2. [FONT=&quot]Settings -> Parameter Settings -> Position mode: option2[/FONT]
    3. [FONT=&quot]Settings -> Fix Request Settings -> Session Operation: MS-based[/FONT]
    4. [FONT=&quot]Settings -> Fix Request Settings -> Server Option: Default[/FONT]
    csabi likes this.
  11. glurta

    glurta Newbie

    This didn't work for me but I did find this code *#*#1575#*#* which brings up a GPS menu with options, but I havent got a clue what to do from there!
  12. barqers

    barqers Android Expert

    If you're on Froyo try these commands:

    use Froyo code : *#*#3214789650#*#*
    after restart go to : Commands->Get Position ->Start GPS (it might be long test)
    i did this only and now i get locks within 10-20 secs
    for better results USE GPS under open skys
  13. glurta

    glurta Newbie

    Thanks Barqers, but tried this and got error message: "The application service mode (process.com.sec.android.app.servocemodeapp) has stopped unexpectedly".

    Search for a solution goes on...
  14. barqers

    barqers Android Expert

    o_O That might be the problem lol, isn't that the process which handles GPS data? If it's force closing it might be a problem with the apk itself. Are you using a custom ROM?
  15. glurta

    glurta Newbie

    I don't know if that process controlling GPS or not. I'm on official Froyo and rooted.
    Looking for a solution that doesn't involve using a custom ROM, for now.
  16. itsdaniel0

    itsdaniel0 Lurker

    I have this exact same problem, I thought the 2.2 update might fix the GPS. Apparently not.
    Anyone got a fix yet?
  17. barqers

    barqers Android Expert

    Maybe I can try and find the GPS apk on my phone and have you guys push it to /system/app/
  18. itsdaniel0

    itsdaniel0 Lurker

    I found you can load the GPS Setup via Launcher Pro
    Menu > Add >Shortcuts > Activities > GpsSetup2 > GpsSetup2 > Ok
    I tried the settings above, but no such luck. Any other suggestions now?
  19. AguxOne

    AguxOne Lurker

    Hi, i fixed my problem of the gps in my i5800 and this thread y definitely not the solution.
    Tried everything what mr internet says, and no results.
    One fix that surely most people have tried is to use the app "faster fix". It is an app to set an NTP server near to your location, in other words you are telling the satellites aproximadetely where you are, i.e north america, south america, spain, france, etc.
    This worked for lots of people but not for me, i am from Argentina, one of the few having this phone here.
    Searching and searching found other ways to stablish the ntp server and many combinations of the setting in the GpsSetup2 but nothing works, that setup is just meant for tests doesn't mean you are getting better results in another aplications.
    Finally i found something interesting, most of samsung phone have some serious problems with the gps like the i5800, including galaxy S the big and expensive leader of the galaxys.
    Some people made an app to solve the galaxy S problems, so i decided to try it on mi i5800. This software is meant to be used on the galaxy S but that it could work on other phones, and it does.
    The app is named GPS Aids, and it's free and you can download it from the market, it's the real solution. Just install, use the setup and set for other phones instead of the galaxy S, and you are done, go outside, stay still some seconds and you'll see lots of satellites.
    It was really surprising because i could see top 3 satellites and could not use any of them.
    The app is really complete and let's you change the ntp server from there and has a kind of radar like gps status to indicate the satellites.
    Hope this helps, and is my first post about this topic on the internet, so be free to spread this to the world if this works for you guys cause gps was a function that i really needed and have been lots of time trying to fix it.
    Good luck and please comment if it works!
  20. dalibor2222

    dalibor2222 Lurker

    I used to wait for like 15 mins to fix the location and was going nuts over it, as I use the droid for sports tracking. Looking over to Galaxy S forums I found a hint that has proved to pay back a great deal.

    Being in all this hassle for too long now, I got to conclusion that there is no universal setup that will fix all your problems, wherever you are and on whatever network you are connected to. So, I encourage you to give it try using all available settings in GPSSetup2 until you find the best solution. Use clear sky for testing. :)

    Here are the best settings that have worked for me so far. I live in Croatia, and I'm T-Mobile subscriber. Android Froyo 2.2. Galaxy GT I5800.

    1. Open stock dialer

    2. Type: *#3214789650#

    3. This should open GPSSetup2

    4. Settings:

    > Parameter
    > Address
    Server type: UMTS SLP
    Address type: URL
    Address: supl.google.com:7276
    > Start mode
    Start mode: Hot start
    > SSL
    Enable SSL: Disabled
    > Position mode:
    Position mode: option3
    [v] Standalone
    [ ] UP MS Based
    [ ] UP MS Assisted
    [v] 2G CP MS Based
    [v] 2G CP MS Assisted
    [v] 3G CP UE Based
    [v] 3G CP UE Assisted

    > Fix Request Settings:
    > Session type: New Position
    > Sessip operation: MS-Based
    > Number of fixes: 999999999
    > Time between fixes: 2000
    > Session timeout: 10
    > Accuracy: 50
    > Server option: local

    5. GPSOne XTRA: Enabled
  21. csabi

    csabi Lurker

    Post by Eromittal:

    Press *#*#1472365#*#*. This will bring to GPS setting.
    Settings -> Parameter Settings -> Address -> Server Type: 1x MPC
    Settings -> Parameter Settings -> Position mode: option3
    Settings -> Fix Request Settings -> Session Operation: Standalone
    Settings -> Fix Request Settings -> Server Option: Local
    gpsOne XTRA -> Xtra Enable: Enable

    Great, worked perfectly for me on GT-I5800, Galaxy 3 (in Hungary).
    Many thanks, Eromittal.

Share This Page