1. Download our Official Android App: Forums for Android!

Support I7500XEFJB2- Phone never sleeps !!!

Discussion in 'Android Devices' started by tekarthik, Feb 24, 2010.

  1. Alonski

    Alonski Newbie
    Rank:
    None
    Points:
    35
    Posts:
    44
    Joined:
    Mar 4, 2010

    Mar 4, 2010
    44
    0
    35
    Well I realized that my samsung sleeve was pressing my camera button after my phone died overnight... Hopefully now that I stopped using it I will get better battery life.

    Something interesting:
    I just booted up my phone after it was off. I check Advanced Task Killer Free after I turned on the phone. All of these applications are on:
    Photoshop.com Mobile - Pointless?
    MyBackup - Makes sense
    Meebo IM - Pointless?
    Smart Monitor Lite - Pointless?
    antivirus - Sort of makes sense
    EcoCharger - Pointless?
    SyncMyPix - Pointless?
    Alarm Clock - Pointless?
    Moxier Mail - Pointless?
    Better Clock - Pointless?
    Handcent SMS - Pointless?
    Gmail - Pointless?
    Advanced Task Killer Free... Duh

    Why the hell are these starting on start up. That's pretty stupid.
     

    Advertisement

  2. damuffinman

    damuffinman Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    203
    Joined:
    Aug 9, 2009

    I use Autostarts to manage which applications get to run when the phone boots. Shame really, each of those applications should have an option to not launch when the phone boots. I always wondered why the dev thinks the app should launch when the phone is on...
     
  3. mrqs

    mrqs Android Expert
    Rank:
    None
    Points:
    128
    Posts:
    1,446
    Joined:
    Sep 28, 2009

    think not
     
  4. qirex

    qirex Lurker
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Nov 12, 2009

    Nov 12, 2009
    6
    0
    5
    There goes my first post, i hope it may help..

    Updated my galaxy last week & didn't experienced the "no sleep" issue..untill today

    After charging the phone overnight(without switching off) at 7 am took the phone & it has eaten 25%
    battery. Spareparts shows the 100% usage, at the same time i founded the unlock button more responsive...

    Really weird...on my previous charge after 120h battery was at 30%(few calls, few wifi, few messages and no 3g), i've rebooted now...let's se what happens this weekend...
     
  5. gie62001

    gie62001 Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    265
    Joined:
    Aug 2, 2009

    Aug 2, 2009
    265
    25
    43
    UK
    after uninstalling google voice search i'm experiencing much better battery (might be just coinsidence) but been using phone for few days and it all seems to be good, and the battery usage against the screen on is almost identical. so, so far so good.
    will see how it goes later
     
  6. davyu

    davyu Member
    Rank:
    None
    Points:
    16
    Posts:
    92
    Joined:
    Dec 19, 2009

    Dec 19, 2009
    92
    3
    16
    I've gone back to galaxhero 1.5. The lack of battery power is killing me. I must say though, I miss the responsive lock button.
    On the brighter side, I can play with the fancy screen orientation setting again!
     
  7. Alonski

    Alonski Newbie
    Rank:
    None
    Points:
    35
    Posts:
    44
    Joined:
    Mar 4, 2010

    Mar 4, 2010
    44
    0
    35
    All right I guess it sort of makes sense but I don't use gmail on my phone and I use a different alarm application so =/ Ok maybe the alarm clock actually makes good sense =D
     
  8. michael.nights

    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Mar 3, 2010

    Mar 3, 2010
    6
    0
    5
    I tried a logcat with adb and my Galaxy seems to sleep quite well. I'm also using SetCpu and I noticed that there is a sort of conflict keeping the phone from sleep as well as it could.

    In my logcat I get

    Again, again and again. It is the only process (except for some some dalvikvm) that is running while the phone sleeps.
    The OS tries to do something and SetCpu reacts at it imposing its "Sleeping Profile". I guess this is a bug from JB2.
    However, I have nothing to complain, given that SpareParts tells
    "In execution = 11,6%"
    "Display on = 10,9%"
    The gap is really small.
     
  9. Nexus6

    Nexus6 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    8
    Joined:
    Feb 24, 2010

    Feb 24, 2010
    8
    0
    5
    Hi All.

    I have an assumption that problems with sleep mode can be caused if you kill some applications. Are there people who never kills apps and still have this issue ?
     
  10. Mr.DNA

    Mr.DNA Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    124
    Joined:
    Jul 29, 2009

    Jul 29, 2009
    124
    3
    36
    Since upgrading to 1.6 and experimenting on the no sleep issue, and after reading the recent thread discussing the merits of task-killing, I have uninstalled all such apps. I still occasionally observe the no sleep issue.
     
  11. kofuukali

    kofuukali Newbie
    Rank:
    None
    Points:
    16
    Posts:
    49
    Joined:
    Oct 7, 2009

    Oct 7, 2009
    49
    3
    16
    For many times now I have noticed and clearly identified that my phone experiences the never sleep issue, directly after unplugging the phone from it's charging status. It seems to have to be a relatively long charge though, it doesn't happen for just a short time.
    Don't ask me to define long please... (Alright I would say something above an hour or something...)
    So now, after every long recharge, I reboot.
    And my problems disappear.
    Isn't technology a great thing? I thought mandatory rebooting was a windows thing :)
     
  12. Andronix

    Andronix Android Enthusiast
    Rank:
    None
    Points:
    63
    Posts:
    676
    Joined:
    Aug 31, 2009

    Aug 31, 2009
    676
    16
    63
    Greatest idea for a workaround sofar. Anyone prove kofuukali wrong?
     
  13. inFECT

    inFECT Android Enthusiast
    Rank:
    None
    Points:
    53
    Posts:
    256
    Joined:
    Feb 22, 2010

    ill gonna test it on the next loading cycle

    Edit: Confirming this. After charging the phone and unplugging the Power device, the sleep bug came back.
     
  14. inFECT

    inFECT Android Enthusiast
    Rank:
    None
    Points:
    53
    Posts:
    256
    Joined:
    Feb 22, 2010

    bumping this.. anyone else tried it?
     
  15. pegasus21

    pegasus21 Android Enthusiast
    Rank:
    None
    Points:
    36
    Posts:
    253
    Joined:
    Aug 26, 2009

    Aug 26, 2009
    253
    1
    36
    I had the bug and noticed that under data synchronisation, contacts had a sync icon beside it even when there were no connected data networks. The running time was about 8hrs which coincided with the time that I edited one of my contacts.

    After syncronising contacts and making sure the icon wasn't there anymore, the phone slept as it should.

    So I guess there are more than 1 ways for this bug to occur.
     
  16. stangri

    stangri Newbie
    Rank:
    None
    Points:
    16
    Posts:
    17
    Joined:
    Jan 27, 2010

    Jan 27, 2010
    17
    1
    16
    I'm not sure wherever it's a same problem or not, but my phone has a problem detecting/displaying the battery level. It constantly shows battery as full until it dies from lack of juice which I have no way of predicting.
    I've tried cycling the battery (well, it comes naturally as I receive no warning before the phone dies), deleting the /data/system/batterystats.bin file and then cycling -- nothing helps.
    BTW, when you say "no sleep" do you mean the screen doesn't dim or does the screen dim but the phone/CPU don't go to sleep mode? How do I know if in addition to my problem I also have a no sleep issue?
    thanks!
     
  17. mrqs

    mrqs Android Expert
    Rank:
    None
    Points:
    128
    Posts:
    1,446
    Joined:
    Sep 28, 2009

    are you checking the percentage or going by the notification bar icon?
    how long does it usually last?
    if it really always stays @ 100%, it's quite definitely a hardware fault on the battery voltage sensor and you should get it fixed/replaced under warranty
    screen does dim, but phone doesn't sleep
    check your battery history (depending on your firmware, can be found in settings, or use spare parts -app); if the difference between running time and screen on time is very large, you've got the no sleep bug going on
    of course another obvious indicator of the no sleep bug is dismal battery life
     
  18. FadeFx

    FadeFx Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    183
    Joined:
    Mar 4, 2010

    Mar 4, 2010
    183
    12
    38
    Austria
    hi guys,

    here it is, the cure, not a workaround:

    odin the ih8 firmware, then flash recovery 4.6.2 then install galaxo with update.zip, restore gapps from jb6 and find out that no sleep bug is gone. this bug is caused by some error in the baseband and therefore is present in all firmwares past ih8. this will also cure 3g problems!

    have fun with testing ;-)

    edit: changed baseband version to ih8 since the bug is there already in ii5
     
    informale and Frojd like this.
  19. informale

    informale Android Enthusiast
    Rank:
    None
    Points:
    68
    Posts:
    704
    Joined:
    Oct 25, 2009

    Oct 25, 2009
    704
    33
    68
    Scotland
    May be worth a shot!
     
  20. Xenon

    Xenon Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    243
    Joined:
    Aug 30, 2009

    Aug 30, 2009
    243
    3
    36
    Croatia
    I have IL3 and there's no no-sleep, and it wasn't present on IK5 either :thinking:

    It came with 1.6 firmwares.
     
  21. FadeFx

    FadeFx Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    183
    Joined:
    Mar 4, 2010

    Mar 4, 2010
    183
    12
    38
    Austria
    xenon do you have the 3g bug? this was introduced with ik5 i think, but not everybody is affected.
     
  22. Xenon

    Xenon Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    243
    Joined:
    Aug 30, 2009

    Aug 30, 2009
    243
    3
    36
    Croatia
    I don't use 3G, so I have no idea.
     
  23. starquake

    starquake Lurker
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Mar 31, 2010

    Mar 31, 2010
    4
    0
    5
    FadeFx, (or anyone else :D)

    I'm now running JC6, I just had a problem with my 3G connection not working anymore. Is it possible to only flash baseband firmware to IK5 with Odin. Or must the firmwares be the same version? And is it going to fix that problem?
     
  24. Andronix

    Andronix Android Enthusiast
    Rank:
    None
    Points:
    63
    Posts:
    676
    Joined:
    Aug 31, 2009

    Aug 31, 2009
    676
    16
    63
    starquake, don't bother doing that, it won't help as informale wrote....
     
  25. Frojd

    Frojd Member
    Rank:
    None
    Points:
    18
    Posts:
    97
    Joined:
    Nov 9, 2009

    Nov 9, 2009
    97
    10
    18
    If you mean you have the problem with 3g not working from time to time (but it has actually worked in the beginnning), flash II5-baseband from this package: MEGAUPLOAD - The leading online storage and file delivery service
    This works for me, at least. :)
     

Share This Page

Loading...