1. Download our Official Android App: Forums for Android!

Support Icons gone on screen after USB connection

Discussion in 'Android Help' started by Android Question, Jun 1, 2016.

  1. Android Question

    Thread Starter
    Rank:
    None
    Posts:
    0
    Joined:

    Hello. My phone is running 4.4.3. I have apps on the physical SD card. Any time I plug the phone into USB, be it into a computer or now with my new car, well, the car, any icons on the screen related to apps that are loaded on the SD card disappear. They also disappear from the app drawer (I think that's what you still call that.)

    Usually upon removing from USB, they reappear in the app drawer, but I then have to put them all back onto the screen.

    This is new to me as I never plugged the phone into USB until I just bought this car. It's the first car I've had with a USB plug to connect the phone to the radio system.

    Thanks in advance.
     

    Advertisement

  2. chanchan05

    chanchan05 The Doctor
    Rank:
     #28
    Points:
    1,108
    Posts:
    15,005
    Joined:
    Jun 30, 2011

    Jun 30, 2011
    15,005
    4,682
    1,108
    Male
    This is normal if the phone is connecting via USB storage mode. The phone can't access the SD card if another device (PC or car) is accessing it's contents.
     
    Brian706 likes this.
  3. mrodgers

    mrodgers Member
    Rank:
    None
    Points:
    16
    Posts:
    30
    Joined:
    Jan 2, 2012

    Jan 2, 2012
    30
    2
    16
    Forgot to log on, that was my question above....

    Thanks for the reply. Problem is, the icons not reappearing after unplugging causing me to have to load about 20 icons that I use all the time back on the screens every time I plug into USB. I can understand the phone not being able to access while plugged in because another device (computer, car, etc) is accessing. Anyone know of a way for the icons to come back after unplugging without having to move 20 icons twice a day after I use it in the car? I want to connect to USB because it will charge the phone and the ports are right there on a shelf where I have the phone as opposed to stretching a cord through the car to connect to a 12v port.
     
  4. chanchan05

    chanchan05 The Doctor
    Rank:
     #28
    Points:
    1,108
    Posts:
    15,005
    Joined:
    Jun 30, 2011

    Jun 30, 2011
    15,005
    4,682
    1,108
    Male
    In the settings, turn off usb storage and set it to mtp connection.
     
    lunatic59 and Brian706 like this.
  5. Brian706

    Brian706 I like turtles!
    Moderator
    Rank:
     #29
    Points:
    1,053
    Posts:
    9,339
    Joined:
    Jul 25, 2012

    Jul 25, 2012
    9,339
    8,582
    1,053
    Drafter
    Or even charge only.
     
    lunatic59 likes this.
  6. lunatic59

    lunatic59 Moderati ergo sum
    Moderator
    Rank:
     #3
    Points:
    4,238
    Posts:
    36,353
    Joined:
    Jun 12, 2010

    Jun 12, 2010
    36,353
    33,984
    4,238
    Male
    IT
    Pennsylvania
    I'm not sure 'charge only' was available in 4.4.x ... at least it's not specifically listed in the USB option on an old Galaxy S2 I still have around running 4.4.2. MTP mode would be ideal provided that it works with the OP's car. I know some cars have a real problem with USB protocols beyond the basics.
     
    Brian706 likes this.

Share This Page

Loading...