1. Are you ready for the Galaxy S20? Here is everything we know so far!

ICS/CM9-JB/CM10 Development Thread

Discussion in 'Android Devices' started by lMonsterl, Apr 16, 2012.

  1. tdm

    tdm Android Expert

    No, I don't have the changes uploaded. I offered to do that some time ago and nobody was interested. It's close now so I'll keep at it until it's fixed, then upload.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. JBizzleATL

    JBizzleATL Newbie

    So listen been trying to read thru here and im a bit confused....is Jelly Bean or ISC working on a Marquee?? (BOOST) yet?? Im running CTMod 6.9 or something like that and it has quite a few bugs...getting stuck not saving pics from time to time....so I just need a straight answer: CAN I UPDATE TO JELLY BEAN OR ICS as of todaay?? And can you post links that I may do so with please I'd be happy to load them on the phone as the phone is off atm...thanks! :smokingsomb: :thinking:
     
  3. tdm

    tdm Android Expert

    There is an ICS build here. But cameras don't work.

    The 3.0.8 kernel that I'm working on should fix the cameras on both ICS and JB.
     
  4. JBizzleATL

    JBizzleATL Newbie

    Going over there now and installing it now, so I just put that file changed it LG855 cuz im on boot and save it in sdcard root folder correct? Im about to back up my rom then install it!!!! Thanks You Da Best!!:D

    By the way is there a better choice in ROMs than CT Mod's it drains battery life fast also but I have been to lazy to update and look for another one so far there has not been a update for it...what do you suggest the best working ROM that I can use with my LG855 ?? Thanks for the help!

    Also it says sprint so did I move the file correctly?? How do I install Google Play I have it on my card but no card explorer on the rom as i see.....??
     
  5. Phrant1c

    Phrant1c Android Enthusiast

    That is correct. Make sure you save it as .install.prop. If you do not have the . before the word install, it will not work. As stated, you really only need this if you have mismatched baseband/firmware, as the sniper installer will detect your BASEBAND and install the corresponding firmware.

    Right now, CTMod is the most stable ROM for this phone. Any ROM on this phone is going to cause fairly quick battery drain. Also, keep in mind the stock battery is only 1500mAh.

    Your battery drain is going to be effected by a number of things.

    For one, the screen. The Marquee has a fairly high-end display, and its going to drain power. Try adjusting your brightness settings, or keep it set to auto.

    Second, the kernel is going to have an effect. Blood has made several kernels with different tweaks, some of the older kernels have some GPU tweaks that are going to be a little more intensive than one of the test kernels with that removed. While were on the subject of kernels, keep in mind that your Governer and clock speed are going to effect your battery as this controls how the phone actually performs. Some are made to conserve battery while others are made with only performance in mind.

    Lastly, turn off any extras when you arent using them. Especially the battery hogs. This includes, but is not limited to, Wifi, Bluetooth, and GPS. If you leave them off when not in use, your battery will last much longer.
     
    JBizzleATL likes this.
  6. JBizzleATL

    JBizzleATL Newbie

    Last couple of things:

    Do I still have to access the LG Hidden menu to have tethering?
    ...damn the phone just reboot forsome reason.....anyway
    WHere is google play store?
    Where is the file explorer so that I can install applications on my memory card....
    With out the store I can not geto box and thats where I keep my APK's.....
    I set that file in the rootfolder of my sdcard ie: .install.prop , but the phone says sprint shall I tro a reinstall?
    Thanks for your help your super!
     
  7. Phrant1c

    Phrant1c Android Enthusiast

    Where on the SD card did you put it? By "root folder" it is referring to the top layer, aka when you open the sd card and see all the folders and files listed, that is the root. If you put it in a folder on the sd card, it is no longer in the root folder. Make sure the .install.prop says LG855 for the model so it installs the boost SW.

    The play store is installed seperately. There are licensing and copyright issues with Google, so the Google licenses apps can't typically be included in these custom roms. You have to flash a GApps package, located here:
    http://androidforums.com/marquee-al...jb-cm10-development-thread-6.html#post4764312

    At which point you may have to flash Gapps, fix permissions, then reboot. This will load all Google-branded apps. Always make sure you flash the most recent Gapps, and make sure it is for ICS.

    As for the file explorer, you will probably have to download one.

    For tethering, I never had to access the hidden menu, but you wont know until you try.
     
  8. JBizzleATL

    JBizzleATL Newbie

    Yep its in the root of the SDCard not in a folder....another thing is its not letting me importmy contacts can not find server bal blah check this post by me: http://androidforums.com/4764381-post279.html

    Trying to get the google store working now....been nice to have had a file explorer included in the rom!! Ill be right back...and im looking for ICS ver..
     
  9. JBizzleATL

    JBizzleATL Newbie

    FILE NOT FOUND!! :( can you pose the threed number I dont see it!!
     
  10. JBizzleATL

    JBizzleATL Newbie

    Look I have searched and I can not find ICS GAPPS for ICS I have a old on on my phone but its CT Mod will that work? Im really fustrated right now!!! And I done know what else to do can you tell me what post number it is on just post the link so that I can copy it??? the ones I have tried are no longer on the site it was hosted on!!!! HELP!!! PLEASE!!!!!
     
  11. Phrant1c

    Phrant1c Android Enthusiast

    Really? I posted the link to the Gapps. If you couldn't find it, i can't make this much clearer.

    https://dl.dropbox.com/u/26736615/Gapps-RSKYLINE.zip

    Just click it. Direct download. Flash, fix permissions, reboot.

    CTMod has the apps included, there is no Gapps package for that. If you are getting stuck, as much as you may not want to, go back to the first post in the Quattrimus thread and read from the first post on until it makes sense. A lot of people have had similar questions, and they are answered in the thread. It also explains any bug fixes that were made, issues others ran into and how they were resolved, and it even includes a fix for MMS that worked for some people.

    I cant stress enough how important it is to read, read, read. For all you know, the second page of the thread could say "DO NOT FLASH THIS ROM YOUR PHONE WILL EXPLODE" and you would never know because you stopped reading after the first post.

    There is only so much I can explain, and as much as I am willing to help, I am not going to do everything for you. We were all starting out at some point, and this board provides great support. But meet me halfway and brush up on the rom itself.


    EDIT: This link works. I just downloaded to make sure. You shouldn't even be re-directed. Once you click it, you should immediately be prompted to download.
     
  12. Minombre2001

    Minombre2001 Newbie

    Does the phone and 3g work on the test3
     
  13. Phrant1c

    Phrant1c Android Enthusiast

    EVERYTHING ON THIS ROM IS FUNCTIONAL MINUS THE CAMERA AND FINE GPS LOCATION.

    As I don't care about the camera, I used this ROM as my daily driver for months with no issues.

    I'm tempted to go back and count how many times people ask what's working. I can't stress this enough READ THE THREAD AND MOST OF YOUR QUESTIONS WILL ANSWER THEMSELVES.

    (this is not directed at anyone particular. Just very tired of redundancy. People don't mind answering questions but they don't want to answer the same question for 60 people on the same PUBLIC thread)
     
  14. tdm

    tdm Android Expert

    I went through and reverted most everything in drivers/usb/musb back to its original state. There are relatively few changes there now. The big changes I have at the moment are in drivers/mfd/twl* and drivers/usb/otg/twl4030-usb.c.

    I sprinkled some debugging into the regulator_enable() and regulator_disable() calls and watched a good vs bad connection.

    On the good 2.6.35 connection, it looks like twl4030_usb_irq() runs through all of its checks, enables, disables, and then reenables the VUSB1V8 and VUSB1V5 regulators, then the musb device starts getting interrupts.

    On the bad 3.0.8 connection, it looks like twl4030_usb_irq() runs through to the point where the regulators are enabled, then the musb device starts getting interrupts, then the regulators are disabled and reenabled. At which point the musb device gets a disconnect and suspend.

    So, as near as I can tell, this seems like a timing issue. I need to find out why the 3.0.8 kernel is receiving musb interrupts before twl4030_usb_irq() finishes, while the 2.6.35 kernel does not.
     
  15. Minombre2001

    Minombre2001 Newbie

     
  16. tdm

    tdm Android Expert

    This usb thing is seriously kicking my butt. Still.

    I looked through the twl4030-usb.c code and noted that it uses request_threaded_irq(). That means the irq handler runs in a kernel thread, not in irq context. Which in turn means interrupts are enabled. But in musb_core.c, it uses request_irq(). Which means that the irq handler runs in irq context. So it can and will always preempt twl4030_usb_irq().

    Just as a test, I disabled interrupts in twl4030_usb_irq() and the kernel complained vociferously that the various i2c operations were scheduling while atomic. So that basically proved the point above. Next, I hacked in some code to disable the musb irq while twl4030_usb_irq() was running. That did force the musb generic_interrupt() code to run after twl4030_usb_irq() finished, but it didn't change the result.

    Finally, I disabled CONFIG_LGE_USB_GADGET_FUNC_BIND_ONLY_INIT in the 2.6.35 kernel (and fixed up some minor compile breakage) on the theory that was affecting things. But usb kept on working without it.

    So it seems that somehow the 2.6.35 kernel prevents the musb irq from being delivered by the hardware until the appropriate time. Perhaps the hardware is put to sleep or disabled in some way, I don't know. But I've been through just about everything I can find and nothing is apparent.
     
  17. lMonsterl

    lMonsterl Android Expert
    Thread Starter

    Thought you guys might like this..

    [​IMG]
     
    JBizzleATL and Thadd Valeika like this.
  18. mvaness

    mvaness Android Enthusiast

    I want one! But I don't think it would fit in my pocket...;)
     
  19. joeycmb

    joeycmb Well-Known Member

    damn question, audio works or not?:thinking: sorry for being damn, what audio does not work. can someone put me n right direction
     
  20. Chopstikwar

    Chopstikwar Newbie

    If you look at the original post on the first link he clearly states what's working and what's not. Cm10 audio doesn't work. Cm9 does :D
     
  21. joeycmb

    joeycmb Well-Known Member

    i know that...sorry my question is ,what audio? music player? ringtones? or.......?

    i just asking bc iam on cm10 i can play audio on cell speakers ... but no no hearphones. i gues that what talking about
     
  22. wetbiker7

    wetbiker7 Extreme Android User

    As far as I can tell, ALL audio works on CM9.
     
  23. joeycmb

    joeycmb Well-Known Member

    thanks dude
     
  24. wetbiker7

    wetbiker7 Extreme Android User

    YouTube even works. I switched my picture app to Quickpic. It's faster. As far as audio, i'm using PlayerPro and everything plays like it's supposed to. I haven't experienced any lag either with music playback.
     
  25. Yunggin85

    Yunggin85 Newbie

    how do you install cm9 on boost mobile lg marquee
     

LG Marquee Forum

The LG Marquee release date was October 2011. Features and Specs include a 4.0" inch screen, 5MP camera, 512GB RAM, processor, and 1500mAh battery.

October 2011
Release Date
0
Reviews
Loading...

Share This Page

Loading...