1. Are you ready for the Galaxy S20? Here is everything we know so far!

Id3v2 MP3 Tags

Discussion in 'Android Devices' started by mvnjpy, Dec 16, 2009.

  1. mvnjpy

    mvnjpy Member
    Thread Starter

    Android on Galaxy seems to ignore them.

    From this thread, it doesn't seem to be a 1.5 issue only:

    The music player will only recognize my id3v1 tags, and those were sketchy to begin with. First of all, I don't think id3v1 supports utf-8 unicode, so I need to change my computer encoding because I don't have a good way to change the encoding for a specific file.

    It will show up as Unknown Artist/Unknown Album if there are no id3v1 tags.

    Other than that the music player is awesome.

    1. Download the Forums for Android™ app!


  2. arielf

    arielf Lurker

    I noticed some issue from the beginning regarding mp3 tags too. I have a lot of latin music and the accents and special chars like :
  3. mvnjpy

    mvnjpy Member
    Thread Starter

  4. sado1

    sado1 Well-Known Member

    Yes that's the problem. Luckily my mp3 player had the same issue [id3 2.4 not working, fix - converting to id3 2.3], so that was first thing that came into my mind when I saw my tags messed up on my Galaxy and it worked. Use [on Windows] Mp3Tag or EasyTag [on Linux] - in first one u should just save the files [program does save by default in 2.3], in second one u must select 2.3 in preferences and then save.
  5. mvnjpy

    mvnjpy Member
    Thread Starter

    Converting to 2.3 only partially fixes the problem. Now, it recognizes the tags but it doesn't interpret them properly. Characters will become just "???"..

  6. epicpajl

    epicpajl Lurker

    I used MusicBrainz (Mac) to create ID3 v1 tags and now I can see mp3 song details on my Samsung Galaxy. Not a preferable solution.
  7. mvnjpy

    mvnjpy Member
    Thread Starter

    still doesn't work for me with chinese songs. even with id3v1 tags. it shows up as "???"
  8. cl0wnzee

    cl0wnzee Newbie

    I have the same problem, I have a huge well organized music collection which I manage via iTunes and the i7500 is my only phone which has troubles with the ID3 tags.
    I first thought I "destroyed" my iTunes library, then I read this thread and I really hope for a fix or solution now.
  9. Kouske

    Kouske Well-Known Member

    I know it worked just fine on my previous firmware (I think it was a H firmware..not sure of the number because it was edited by my provider). Gonna try to fix this and post if I succeed.

    Just editing the existing ID3 tag works for me. The program Mp3Tag just tags it as ID3v1 and ID3v2.3 by itself.
  10. mvnjpy

    mvnjpy Member
    Thread Starter

    can you try to do whatever you did to this mp3 and see if the tags show up properly in the android music player?

    MEGAUPLOAD - The leading online storage and file delivery service

    please send me back the modified mp3 if you get it working
  11. Kouske

    Kouske Well-Known Member

    My computer can't really see chinese(?) letters so I don't know what I should do with this file...

    All I did was edit Artist/Title/Album/Track Number for each file as I wanted them to show + I added cover art to these files.

    You might want to remove the existing tag by using remove tag and tagging them from scratch.
  12. mrqs

    mrqs Android Expert

  13. davyu

    davyu Member

    I'm using galaxhero, and I can't get my phone to display Chinese id3 tags properly (or at all, for that matter)...
  14. cl0wnzee

    cl0wnzee Newbie

    btw russian titles also don't work. Don't have many but these "???? ????" are driving me crazy.
  15. ijabz

    ijabz Lurker

    The thing is ID3v1 ONLY supports the latin charset, so if Android only support V1 it wont be able to display Cyrillic (Russian) Chinese ectera.

    Some applications actually use a different charset to encode languages such as Cyrillic, then rely on playing application to work out that the characters are purporting to be Cyrillic , but this is non-standard and doesnt work very well.

    But this post http://androidforums.com/android-media/27570-track-numbers-media-players.html seems to imply that actually ID3v23 is supported just not ID3v24, so if thats the case using v23 would be the solution.
  16. mrqs

    mrqs Android Expert

    i am using v2.3, but i still don't get special characters (not talking cyrillic/chinese/etc, but stuff like Ř,
  17. ijabz

    ijabz Lurker

  18. mrqs

    mrqs Android Expert

    i'm at work atm, so can't check here, but if i remember right, the files in question are utf-16 encoded - not sure about the v1 thing; that could be it, will check when i get home
  19. ijabz

    ijabz Lurker

    Another thought, In ID3v23 if you need to display character that isn't in the ISO-8859 charset it should then use UTF-16, which can be either UTF16 most significant byte first OR least significant byte first. But maybe Android only understands one particular order.

    Also some tagger applications use UTF-8 instead of UTF-16, but this is not supported.
  20. mrqs

    mrqs Android Expert

    i used mp3tag for the tagging, which explicitly states it's utf-16 and not 8 (i mean there are both, but i've got 16 selected, 8 is only for v2.4, which doesn't work)

    wouldn't know about the byte order
  21. ijabz

    ijabz Lurker

    Could be byteorder then, another thing tags can be unsychronized to prevent players mistakenly identifying the metadata as the start of the audio. This only has to be done for songs with certain byte sequences in the metadata, but if you encode using UTF16 in one way this can happen quite often. Maybe MP3Tag is/not unsychronizing or Google understands/doesnt understand synchronization.

    I can't answer any of these questions for use because I don't have an Android phone at the moment, but I do have an opensrc tag library called JAudiotagger Library that a few devlopers would like to use for developing Android apps, hence my interest in your issue.
  22. muitommy

    muitommy Newbie

  23. muitommy

    muitommy Newbie

    i find something about this.
    i tried the HK rom again, and found the player in that rom actually did read the chinese character (id3v2 v2.4 utf-8) correctly!!!
    But the one in galaxo only read id3v1, how come?

Share This Page