1. Are you ready for the Galaxy S20? Here is everything we know so far!

Idiots guide to installing apps on incompatible devices

Discussion in 'Android Devices' started by Inksaver, Dec 30, 2012.

  1. Inksaver

    Inksaver Newbie
    Thread Starter

    I have started this thread in the Kindle Fire Rooting section, as it is in response to forum viewers as a How do you.. question, but it is relevant to any android device hence the title being fairly non-specific so non Kindle users may find it useful.

    So you have rooted your Kindle Fire (or Other device) and installed GooglePlay.
    You look for your favourite app on Google Play, and it tells you it is not compatible with your Kindle.
    What can you do.

    Well you have rooted your Kindle. You have SuperUser control. You can do what the hell you like...

    Whooa... wait a minute you don't want to brick it.

    ("Bricking" is a technical term used by those of us know-it-all nerds with superiority complexes who have soldered additional chips into our children's Playstations, XBoxes etc, flashed the firmware on DVD drives, and run exploits on the PSP and Wii, only to find the resulting device just sits there with a blank screen and various flashing lights... We have created a "Brick")

    Please be careful.

    The most obvious way to install on an incompatible device is to simply copy the app's .apk file into /system/apps/ using ES File explorer and tap the app to install it. A couple of problems here:
    1) You need to have the .apk file
    2) You may need additional .apk files which are not obvious. Example when you installed the Google Play Store, there were three files and an intermediate re-boot to take into account.

    There may be numerous methods out there, but I will demonstrate a fairly safe one which I used even before I knew what "rooting" meant:

    Section 1 - I do not have any other Android devices...

    I have Sony Xperia Tipo, and if you try to install an app called Carbs & Cals, it says the app is not compatible. I emailed the developers, who kindly replied this is because was the Tipo does not have an auto-focus camera....Great. At the time I did not have any other android devices....

    Solution: Install BlueStacks for Windows on your PC
    WARNING: Do not attempt to root a real Android device AFTER you have installed Bluestacks, it will cause multiple errors.

    Run Mobile Apps on Windows PC or Mac with BlueStacks | Android App Player

    1) Run BlueStacks, sign in to your Google Account.
    2) Download the app you want to install. By default Bluestacks appears as "T-Mobile Samsung GT-N7000" in your device list on Google Playstore. As long as your app is compatible with this device you are good to go.
    3) Download appmonster (free). Use App Monster to make a Backup of any apps you want to install to your real android device. By default this will save backups to (mnt)/sdcard/appmonster2/backup
    4) Download ES File Explorer (Free)

    Section 2 - I have another Android device with my app installed

    This device does not need to be rooted. all you need is the ability to read the contents of the SD card on a PC either by:
    1) Plug in the USB cable and open the "Mobile device" that appears in windows
    2) Remove the external SD card and plug it into your PC via suitable adapter
    3) Set up a network share in ES File Explorer
    You will need two apps for this process:
    1) Download appmonster (free).
    2) Download ES File Explorer (Free)
    Note: Use App Monster to make a Backup of any apps you want to install to your other android device. By default this will save backups to /sdcard/appmonster2/backup. This MAY NOT be the external 64GB MicroSD card you plugged in earlier at great expense. This often appears as /ext_sdcard or similar.

    Section 3 - Create an app backup on Bluestacks emulator/Real Android device

    As Bluestacks is a virtual device it is not easy to access the virtual SD card it creates. An easy method is to use ES File Explorer to create a network mount on your home LAN. It is also very useful to use this method for transferring files from a real Android device and your PC (or 4TB NAS server if you are a flash git)

    For the rest of this tutorial I will use the word "Tap" to mean both a light touch on the screen of your real Android device AND "Left-Click" with your mouse on the screen of your Bluestacks Emulator.
    1) Start ES File Manager
    2) Tap The word "Local" in the top left corner of the screen
    3) On the dialog tap "LAN"
    4) Tap Menu
    5) Tap New
    6) Tap Server
    7) Fill in your PC's IP address in the "Server" field. I have my main PC set at a fixed IP of (and my 4TB NAS server as - flash git confirmed)
    8) If you do not know the IP open a command prompt and type ipconfig /all and press Enter. It should be listed somewhere in all the output text
    9) Fill in your username and password that you use to access your PC at boot-up, or else tap Anonymous
    10) Fill in a name to display the share as when viewing it on your device. Mine is "HomeServer"
    11) Tap OK. With luck a new icon appears with a green planet earth sitting on a laptop with the name you just typed. If it is not connected check and edit the LAN settings
    12) Tap your new connection. The address bar will show smb:// (or your IP address). This confirms you are using the Linux Samba network protocol to connect to your PC. (I am using Win7 Enterprise, but I am fairly sure other versions support Samba natively)
    12) If you have previously set up any shares on your PC they will be listed. I am not certain which shares are enabled by default, but you should get at least "Users" if you used your username and password to connect.

    You are now ready to create a backup and copy it to your PC

    1) Start appmonster. You will see a list of all installed apps displayed
    2) Tap the app you want to backup. A dialog appears
    3) tap "Backup". A message confirms the backup has been completed
    4) Tap "Back" arrow to exit appmonster
    5) Open ES File Manager. It should open by default on \sdcard.
    6) Tap Menu
    7) Tap Settings
    8) Scroll down to "Root Settings"
    9) Tap Up To Root to select it. On non-rooted devices you will not be able to select any other items here
    10) Tap back to return to the folder listing
    11) Tap "Up" (4th icon along on the menu bar) You should now be in "/" the root directory
    12) Tap ext_card if it is there. If you have a new folder called "appmonster2" continue to step 21
    13) Tap "mnt". If you have a folder called ext_card Tap to open it. If it is empty you do not have a removable external SD card e.g. Kindle Fire HD. This is not a problem as the internal "SD card" (Internal fixed memory device) will be visible to your PC when connected via USB. Go to step 21
    14) (ext-card found which is not empty, but does not have "appmonster2" folder in it) Navigate to /sdcard/appmonster2 folder and Tap to open
    15) If you want to check what is backed up Tap "backup" folder. You should see any apps you backed up here. For example ES File Explorer itself is backed up into a folder called "de.android_telephonie.appmanager". Tap "back" to return to /appmonster2
    16) Tap select icon (2nd one in on menu toolbar
    17) Tap your appmonster2 folder. The text will go green
    18) Tap "Copy" icon (3rd on menu bar)
    19) Tap "Back" arrow until you reach root then navigate to ext_sdcard you discovered before
    20) Tap paste.
    21) You should now have a copy of your backup files here:
    Internal SD card/appmonster2
    External SD card (if fitted)/appmonster2

    Section 3 - Copy the appmonster backup to your PC

    On your real android device connect to your PC via USB or remove and connect the SD card or use a LAN share within ES File Explorer
    Copy the entire appmonster2 folder to your PC
    On bluestacks: Copy the entire appmonster2 folder to your PC via the network mount you created earlier

    Section 4 - Copy the appmonster2 folder to your incompatible device

    This is really very similar to the procedure above
    1) Install and setup ES File Explorer for root explorer access
    2) Install Appmonster

    The first step is to copy the appmonster2 folder you put on your PC back on to your incompatible device

    1) Start appmonster. You will see a list of all installed apps displayed. Pick any existing app to back it up. This will make sure the backup folder is created and give you an indication that you are in the right place to add your own backup(s). I suggest you backup ES File Explorer as the folder it creates is known to be "de.android_telephonie.appmanager"
    2) Tap the app you want to backup. A dialog appears
    3) tap "Backup". A message confirms the backup has been completed
    4) Tap "Back" arrow to exit appmonster
    5) Open ES File Manager. It should open by default on \sdcard.
    6) Check to see your test backup has worked by opening the "appmonster2/backup" folders. You now want to copy the backup files you stored on your PC into this folder
    7) Connect your incompatible device to your PC via USB cable/LAN share in ES File Explorer/ External MicroSD card in adapter. Your choice
    8) copy the backup files on your PC in the folder <PC Location>\appmonster2\backup\<Backup folder name(s)> to your device in /sdcard/appmonster2/backup/
    9) Re-start appmonster
    10) Tap Menu
    11) Tap "View Backups" With luck you should see the backup you copied from your other device/Bluestacks in the listing. If not make sure you copied the files into the correct location
    12) Tap the app you want to Restore
    13) on the dialog tap "Install from SD" If the procedure fails, make sure you have set your device to allow installation of apps from external sources, usually in the settings>-security menu or Settings>-Device (Kindle Fire)

    Depending on the reason for the incompatability, the app may or may not work, but at least you can give it a try
    It is probably worth contacting the developer to see if there is any workaround.

    Good Luck

    PRallday168 and tsevard like this.

    1. Download the Forums for Android™ app!


  2. tsevard

    tsevard Lurker

    Thanks for the info, it worked perfect! My daughter is extremely excited to get Instagram on her new Kindle.
  3. gilbequick

    gilbequick Well-Known Member

    Wait, so can this be used to move files to a NON-ROOTED Kindle Fire HD?
    I want to root my KFHD but I can't unlock my hard drive :(
  4. Inksaver

    Inksaver Newbie
    Thread Starter

    What do you mean by this and what have you tried so far?
  5. gilbequick

    gilbequick Well-Known Member

    I haven't figured out a way to put my hard drive on my notebook into the read/write state. There is no physical lock switch on drive, no jumpers to change. I tried something else that was mentioned but for the life of me I can't remember what it was.
  6. Inksaver

    Inksaver Newbie
    Thread Starter

    Sorry if I am not understanding you fully here, but the hard drive on a notebook is already in a read/write state. Booting a notebook from a Linux liveCD would make the boot drive read only (as it is a CD), but otherwise it will always be writeable.

    Can you give me an example of what you are trying to do, and the error(s) reported?
  7. TurtleRunner

    TurtleRunner Member

    Good write up, very easy to follow.
  8. jirachi

    jirachi Lurker

    I am in bluestacks right now trying to run an app called 'Monster Paradise'. When it starts up, it says "This game requires flash, and your device does not have flash installed." I don't know how to install flash, and I am not using the generic T-Mobile device, I have inputted my own device as the app Monster Paradise was not compatible with the T-Mobile presetting. If you could help me in anyway to bypass this flash requirement or to obtain this flash, please do so! I will greatly appreciate it! Thanks so much.
  9. Wrightslair

    Wrightslair Lurker

    Question: I have just gotten a Fire Kindle and sadly found that the Google play is not on it. I'm fairly computer literate, but by no means a guru. For me, would it be smarter & safer to install Bluestacks and use that on the tablet or follow the instructions to root the Fire Kindle and then follow the instructions to install Google Play? I'm seeing that if I do one thing, then the other might not work, so weighing alternatives. Thanks for your input.
  10. bg4m3r

    bg4m3r Android Expert

    If the Play Store is your only issue, then rooting isn't needed, or Bluestacks.


    You won't find the Play Store, or most Google apps on any Amazon device because competition.
  11. Wrightslair

    Wrightslair Lurker

    Perfect! Thank you for the quick response!
  12. Wrightslair

    Wrightslair Lurker

    After reading the article, I noted it is for a 5th generation Kindle. I have the Fire 7. Checking the page for the 7, I don't find an "install play app". Should I use the one for the 5th generation or is there another file name I should be looking for under the fire 7 HD?

    I went ahead and followed the instructions carefully and I can report that it DOES work on the new Fire HD7.

    Thanks for your wonderful help, the boys will be so pleased!!
    #12 Wrightslair, Feb 24, 2016
    Last edited: Feb 24, 2016
Similar Threads - Idiots guide installing
  1. lunatic59
  2. Happy App Lab
  3. decosoftapp
  4. DecosoftApps
  5. App Update
  6. Paozi
  7. App Update
  8. kisame010588
  9. kisame010588
  10. App Update

Share This Page