1. Check out our companion app, Forums for Android! Download from Google Play

Support IMAP Authentication Problem in Mail App

Discussion in 'Android Devices' started by thespudman, Jul 10, 2010.

  1. thespudman

    thespudman New Member
    Thread Starter

    Jul 10, 2010
    Hi There,

    I have been trying to set my IMAP account up in the Android Mail app. The problem i am having is that my username and password are being rejected even though i know they are definitley right. The port is definitley correct.

    Now what i believe to be the problem is that the username has a '*' at the begining - as it is a catch all account. eg. '*@mydomainname.com'

    If i set up another mailbox without a * in it the log in seems to be fine. eg. 'test@mydomainname.com'

    Now this is a problem for me as i have always used the catch all account for my domain name and it would not be practical to set up individual mailboxes without the * at the begining.

    To make things even stranger if i set it up as pop3 (also not practical) it accepts the username and password.

    My host is 1and1 and i have made sure that the settings are correct

    Its really annoying when it works on my ipod touch but not my Desire :(:mad:



  2. DanaH

    DanaH New Member

    Jan 28, 2011
    Seattle, WA
    At least you have been able to set it up once. Have you had any luck with your specific problem?

    On the G2 running Android 2.2 I have had no success in setting up an email account (other than gmail) at all. There is nothing out of the ordinary with my account name, no asterisk, but it rejects the username/password combination no matter what I do. I've tried POP and IMAP, various ports, various security settings, but nothing works.

    I'm new to the Android system but not new to computers or mobile phones. The setup process seems quite straightforward - it just doesn't work for me.

    Any ideas anyone?
  3. davidjgraph

    davidjgraph New Member

    Feb 7, 2012
    I had exactly the same problem on android 2.2, 2.3 and now 4.0, my catch-all didn't work on 1and1, but non-catch all with the same settings did.

    What I found was if you enter a prefix that the catch-all catches, like test@foo.com instead of *@foo.com, that works. This logs in correctly and gets everything that * would.
  4. hooperits

    hooperits New Member

    Aug 24, 2013
    Hello all,
    I have a problem configuring IMAP 1and1 email in Galaxy Note 2(GT-N7100) Android version 4.1.2. I can receive email but unable to send. These are my setting so far:
    SMTP Server: smtp.1and1.com
    Security Type: I have tried none and TLS, Port: I tried 587 and 25, and required sign-in checked. I dont got any error from the app but cant send email. Thanks a lot. Android forums rocks!
  5. Hadron

    VIP Member

    Aug 9, 2010
    Spacecorp Test Pilot
    Dimension Jumping
    Hi hooperits, and welcome to AF :)

    I don't know 1and1.com, but would suggest checking their website to see what settings they suggest for other mail clients (if they've no Android suggestions). Though from my brief research of this I'd have guess TLS and 587 would be the answers, which you have tried.

    1and1.co.uk suggest

    Server Type: IMAP
    Incoming Server: imap.1and1.co.uk
    IMAP port: 143
    IMAP port with SSL enabled: 993

    Outgoing Server (SMTP): auth.smtp.1and1.co.uk
    SMTP port: 25 or 587
    Outgoing server (SMTP) requires authentication (user name and password)
    Optional: Secure SMTP encryption using TLS (using either port)

    Account name/User name: Your full 1&1 e-mail address
    Password: Your e-mail account's password

    Don't know how different 1and1.com are from .co.uk - all of the stuff I've found in their help centre for email says port 587 when talking about IMAP, but that and the domain name are the main differences I can see.

    Good luck!

Share This Page