Dec 1, 2009
All of my imported contacts keep disappearing from the contacts app :(

anyway to fix this?
hi there thank for your reply!

unfortunately i cannot find this app in the market!

even when scanning the barcode it is not found :(
hi there thank for your reply!

unfortunately i cannot find this app in the market!

even when scanning the barcode it is not found :(

I just searched for it in MarketPlace and found it. Try searching for "ContactSync" all one work with no " marks around it.

If that does not work, try this (is this what you already tried?): ContactSync v1.0.2 Application for Android | Tools

I scanned it, and was able to find it properly.

If you still can not find it, it is possible that it is an app being "hidden" from you by your cell phone provider. This is a problem where some cell phone providers are blocking certain apps from their customers.

What country are you in?
I am in the UK on t-mobile

also when i say imported contacts i mean imported via my simcard...
@eastldn: yes, I know. I had the same problem. It's a bug that they know about. There is supposed to be a drop down box in Contacts to let you decide what sort of contact any entry should be (ie. Phone or Google), but it is missing.

When you import contacts from your SIM, they are imported as "Phone" contacts, while any NEW contacts you make on the phone are, by default, "Google" contacts (as are any that you have in you Gmail account)>

What happens is, you import the contacts from your SIM, and they are marked as "Phone". You sync with Gmail contacts online, and it deletes the contacts on your phone marked as "Phone" and only keeps the ones marked as "Google".

ContactSync allows you to change all the contacts marked "Phone" (that you import from your SIM) to be "Google" contacts instead so they won't be deleted.

as for the availability of ContactSync, it is possible it is not available to your market. Like I said it is a problem a lot of people are facing. In Canada we have no paid apps. In australia some users are blocked from apps as well. You will either need to check with your cell provider's tech support, or ask the Dev of ContactSync if he/she knows whether or not it is blocked from your area. Since it is free, he/she might be willing to send you the .apk file for it to install on your own.

BTW: Looking at the Dev's web site (HappyDroid) I noticed at the bottom under ContactSync it says that it only works on phones running cupcake (1.5) version of Android.

What phone/ver of Android do you have? If you are at 1.6 or above, that might explain why you can't see it in the marketplace.
I suggest you contact the Dev and ask if he/she has any plans to update it for 1.6.

eastldn: Also occurs to me, open one of the contacts imported from your SIM card, and see if you have the option of choosing "Contact Source". It should be a drop down menu. When I create a "new" contact, this drop down menu appears below the contact name. From this drop down menu, choose Google.

If you import your SIM contacts, open one of these contacts to edit, and if you have the "Contact Source" drop down menu, choose Google. Do this for all contacts imported from the SIM card.