1. Are you ready for the Galaxy S20? Here is everything we know so far!

In love with CM7... couple issues though?

Discussion in 'Android Devices' started by ssddyakno, Sep 5, 2011.

  1. ssddyakno

    ssddyakno Well-Known Member
    Thread Starter

    I'm using what I believe is the latest RC build. Finally stopped missing my incredible and fell in love with the phone.

    1) Wifi tether didn't come with it. Is the process to get it running pretty simple? I can't find the program I ran on CM6 with my Incredible. I believe it was simply called "wifi tether"


    2) I believe GPS isn't working properly. I know a lot of people are having problems with this. Is there any sort of fix for this right now or do I just have to wait for a final build?

    But other than that it seems to be VERY stable.

    Any help is appreciated!
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Flyguy94

    Flyguy94 Well-Known Member

    ssddyakno likes this.
  3. WormDoes

    WormDoes Android Expert

  4. ssddyakno

    ssddyakno Well-Known Member
    Thread Starter

    Worm, I'm having trouble finding a simple GingerBread Rom with Sense on that Rom list provided at the top of the forum. Is there one that's not a huge download that you know works?
     
  5. ssddyakno

    ssddyakno Well-Known Member
    Thread Starter

    GPS is working. Flashed that ROM, got lock and presto.

    But seriously, can somebody explain why that works? I know GPS will get a lock quicker if you're close to your last location when you activate it again, but what's the deal with sense/aosp?
     
  6. Yeahha

    Yeahha Usually off topic

    :D I wish I could explain why it works like that. All logic says that if you wipe it should wipe all the GPS stats as well. There must be something that is remembered between flashes that cause it to "know" how to lock on. I don't think anyone knows why it work just that it does.
     
  7. Turdbogls

    Turdbogls Android Expert

    The GPS fix is kinda wonky...i read about how/why it works but really didn't understand it. but here goes my short and sweet explanation.
    AOSP android does not have "network location" capabilities.
    Sense, Blur, Touchwiz, ect all have it working with their networks to get you fairly close to your location (for security/safety/weather ect)
    when you flash a sense ROM and get a GPS lock, something remembers the "network location" code (i guess) and keeps it in memory, so when you restore your CM7 nandroid, it remembers that "code" and applies it to CM7.

    something along those lines....lol

    as for the wifi tether. check out open garden wifi tether. looks exactly the same as wifi tether for root users (except has a different icon and different background) and works just as good. i used it this weekend for about 10 minutes with my touchpad.
     
  8. Yeahha

    Yeahha Usually off topic

    That line I feel weary about. If that were the case then why would anyone buy a Nexus phone. Also the trusty SDK says otherwise.

    Source

    I think the fix may help with something along the lines of the following string in the SDK
    Source

    All of that is in API level 1 which would mean it was in the SDK since before the initial public release of Android (cupcake)
     
  9. nateap87

    nateap87 Android Enthusiast

    i'm using rc.1.7 and the issues i have are that 1: the gps doesn't work at all. just spend the 4 bucks for root explorer in the market and followed the link to xda in one of the above posts and that didn't help at all. also, my phone doesn't receive calls half of the time.
     
  10. Yeahha

    Yeahha Usually off topic

    Are you on the proper radios? That might be the cause of the call missing.

    You need to flash a Sense rom and get a GPS lock the restore back to the CM7 backup you have and it should fix the GPS issues.
     
  11. nateap87

    nateap87 Android Enthusiast

    link to newest radio, please? also, how can i tell what radio i'm currently on?
     
  12. ssddyakno

    ssddyakno Well-Known Member
    Thread Starter

    I just tried to go from RC 1.6 to RC 1.7 and got the dreaded boot loop. Tried 2-3 other things to get it booted up and couldn't, so went back to Nandroid of 1.6 Not sure why I was concerned with 1.7, cause 1.6 worked wonderfully for me.
     
  13. Yeahha

    Yeahha Usually off topic

    Radios in 2nd post

    check the baseband info compared to this
    MR1 1.13.605.7 1.16.00.0402 n/a
    MR2 1.66.605.2 1.39.00.0508 0.01.69.0510
    MR2.5 1.68.605.3 1.39.00.0528 0.01.69.0602
    MR2.75 1.70.605.0 1.39.00.0627 0.01.69.0625
    2nd GB Leak 2.07.605.0 1.46.00.0704 0.01.76.0703_2
    3rd GB Leak 2.10.605.1 1.48.00.0726 0.01.78.0802
    4th GB Leak 2.11.605.0 1.48.00.0817 n/a

    I would suggest the 3rd GB leak if you are on lesser radios.


    Did you check the MD5 of 1.7 before flashing? Also wipe until you are clean:D If you have a good MD5 and a normal wipe doesn't help I would format /system, in CWM the setting is in the mounts menu, in TWRP the setting is in advanced. Follow that up with a factory reset and wiping cache/dalvik cache
     
  14. nateap87

    nateap87 Android Enthusiast

    couple of questions. i'm currently downloading the radio you recommended. how do i check the md5 (or whatever it's called) and also, how do i flash the radio?
     
  15. Yeahha

    Yeahha Usually off topic

    AFV is what I use to check MD5sums. First copy/paste the MD5sum from the thread in a notepad app (I use color note) then check the MD5 with AFV and paste that into the note to make sure it matches. If it does then rename the zip PG05IMG.zip and place on the root of your SD, power off and when powering back on hold volume down. That takes you to hboot, it will ask you to update press volume up and then reboot when prompted. Now delete or rename the zip file you renamed so it will not cause issues in the future.
     
  16. nateap87

    nateap87 Android Enthusiast

    sorry, but i still have no idea what you mean about the md5 thing. where do i get the md5sum? i downloaded the afv (america's funniest videos?).
     
  17. Yeahha

    Yeahha Usually off topic

    LOL no, android file verifier :D

    Open the app, navigate to your download folder and long press on the zip you wish to get the MD5 for. It will pop up a long list of things you can get the top one will be the one you wish to pick "Calc MD-5 Check Sum" or something close to that. Your phone will think for a bit and then pop up the MD5, it will also copy it so you can paste it in the notepad
     
  18. nateap87

    nateap87 Android Enthusiast

    it's not updating! i changed the name and put it on the root of my sd card and it gives me an error message.
     
  19. Yeahha

    Yeahha Usually off topic

    What error are you getting? I would double check the name it should be exactly "PG05IMG.zip" If you renamed with a computer then it may have put an extra .zip on it.
     
  20. nateap87

    nateap87 Android Enthusiast

    Ahhh. I renamed it using astro and did end up having to put another. Zip
     
  21. Yeahha

    Yeahha Usually off topic

    Glad you got it figured out.
     
  22. ssddyakno

    ssddyakno Well-Known Member
    Thread Starter

    Posting this so the information is public on the forums for search purposes. This is a message between me and Yeahha.

    So I flashed the one you told me to flash. I can receive calls, but the network is stuck on 1X. No 3 or 4 g no matter what option I select in wireless/networks. A reboot didn't happen either. Is there time it takes to recognize it? Or another radio you would recommend?
     
  23. ssddyakno

    ssddyakno Well-Known Member
    Thread Starter

    Yeah don't add the .zip

    Windows already puts it on there and doesn't show it, so if you type it, it's gonna be .zip.zip and the phone won't see it.
     
  24. Yeahha

    Yeahha Usually off topic

    Make sure data is enabled and you don't have use only 2g networks checked also network select should be cdma /evdo + lte auto so something close to that
     
    ssddyakno likes this.

HTC Thunderbolt Forum

The HTC Thunderbolt release date was March 2011. Features and Specs include a 4.3" inch screen, 8MP camera, 768GB RAM, Snapdragon S2 processor, and 1400mAh battery.

March 2011
Release Date
0
Reviews
Loading...

Share This Page

Loading...