1. Check out our companion app, Forums for Android! Download from Google Play

Root Installed 2.2 Camera and internal mem not working

Discussion in 'Android Devices' started by Bug Splat, Jul 28, 2010.

  1. Bug Splat

    Bug Splat Well-Known Member
    Thread Starter
    43

    May 28, 2010
    280
    34
    43
    Installed the new leaked froyo and now my camera does not work. Both Pic and video app come up but the screen is black. Also my internal 8gb of storage says "Unavailable". I tried formatting the storage a few times and reboot each time and nothing.

    I had root my Dinc the old way so I unrooted back to stock, installed the first OTA, then rooted using the Unrevoked tool then installed the 2.2 zip file. Every step went exactly as the videos showed.

    Can anyone help me? :(

    UPDATE!!!!
    Fix on Post 14
     

    Advertisement

  2. necosino

    necosino Well-Known Member
    163

    Apr 14, 2010
    1,962
    338
    163
    Accountant and semi-pro poker player
    Upstate NY
    Before you flashed the 2.2 update, did you select "Clear Data/Factory Reset" and then "Clear Cache"?

    did you install any custom kernels?
     
  3. Bug Splat

    Bug Splat Well-Known Member
    Thread Starter
    43

    May 28, 2010
    280
    34
    43
    Yup, cleared both. No custom roms just rooted it with the old push-in-out SD card trick.

    Can I reinstall the 2.2 zip over the top or will that brick my phone?
     
  4. najaboy

    najaboy Well-Known Member
    53

    May 3, 2010
    390
    68
    53
    What baseband version is listed in your software information?
     
  5. Bug Splat

    Bug Splat Well-Known Member
    Thread Starter
    43

    May 28, 2010
    280
    34
    43
    Android Version - 2.2
    Baseband Version - 2.05.00.06.11
    Kernel Version - 2.6.29
    Build Number - 3.16.605.0 CL203589 release-keys
    Software Number - 3.16.605.0
    Browser Version - Webkit 3.1
    PRI Version - 1.28_002
    PRL Version - 51920
    ERI Version - 5
     
  6. Bug Splat

    Bug Splat Well-Known Member
    Thread Starter
    43

    May 28, 2010
    280
    34
    43
    Can I go back and put 2.1 stock on and start over or will that FUBAR it?
     
  7. necosino

    necosino Well-Known Member
    163

    Apr 14, 2010
    1,962
    338
    163
    Accountant and semi-pro poker player
    Upstate NY
    I think that's what you need to do since it seems your kernel didn't update, which is why the camera isn't working.
     
  8. Bug Splat

    Bug Splat Well-Known Member
    Thread Starter
    43

    May 28, 2010
    280
    34
    43
  9. necosino

    necosino Well-Known Member
    163

    Apr 14, 2010
    1,962
    338
    163
    Accountant and semi-pro poker player
    Upstate NY
    Yup, then do the OTA, and then do the 2.2
     
  10. Bug Splat

    Bug Splat Well-Known Member
    Thread Starter
    43

    May 28, 2010
    280
    34
    43
    CRAP! Can't downgrade. Says its an older version.

    Any way to force it to take the older version?
     
  11. Mezmryz03

    Mezmryz03 Well-Known Member
    43

    May 3, 2010
    114
    33
    43
    Audio/Video Professional
    Southern California
  12. Bug Splat

    Bug Splat Well-Known Member
    Thread Starter
    43

    May 28, 2010
    280
    34
    43
    Well guys I'm stuck. I went back to the old HBOOT and was running 2.1 just fine. Followed all the steps and confirmed the camera and internal storage were working all the way through the Leaked OTA with 720p. As soon as I installed Froyo I lost the camera and storage. Any more advice?
     
  13. Marlboro

    Marlboro Active Member
    16

    May 8, 2010
    42
    3
    16
    I followed the videos and my Kernel didnt update either, so my camera isnt working. Not sure what I did wrong.
     
  14. Bug Splat

    Bug Splat Well-Known Member
    Thread Starter
    43

    May 28, 2010
    280
    34
    43
    OK I figured it out. The Wireless tether APK that you also install with Froyo is doing it. I tried 3 times to follow the video exactly and each time I lost thee camera and internal storage. The 4th time I left out the WIFI tether APK and froyo installed and the camera and storage work.

    Hope there is another wifi tether APK that comes out that works. Good luck guys.
     
  15. Marlboro

    Marlboro Active Member
    16

    May 8, 2010
    42
    3
    16

    I take it you cant uninstall the Tether apk but Ill have to downgrade then redo the 2.2?
     
  16. teufeltexan

    teufeltexan Well-Known Member
    23

    Apr 27, 2010
    98
    28
    23
    Paramedic
    TEXAS, y'all!

    I had the same issue. Used Clockwork to wipe the data/cache and reinstalled 2.2 again, no other steps (Left Root and the original Leaked OTA Radio Update in place). On reboot (avoiding the wireless tether apk) the problem was corrected.
     
    opes likes this.
  17. Bug Splat

    Bug Splat Well-Known Member
    Thread Starter
    43

    May 28, 2010
    280
    34
    43
    Wish I would have known that 5 hours ago ;). I was so afraid of bricking that I downgraded back to 2.1 factory every try. After the whole "don't install the leaked OTA over itself!!!" I was scared to do the same for Froyo.
     
  18. Marlboro

    Marlboro Active Member
    16

    May 8, 2010
    42
    3
    16
    The leaked OTA Radio you speak of, do you mean the recent leaded OTA that added the 720 Cam and Hotspot?
     
  19. teufeltexan

    teufeltexan Well-Known Member
    23

    Apr 27, 2010
    98
    28
    23
    Paramedic
    TEXAS, y'all!

    Me too... ;) it was my second or third complete trip down that little lane before I ID'd the wireless issue and figured out how far I'd have to go back. I was just about to make a thread about the issue when I saw your posts and realized it wasn't just me... :D

    It's all golden, now, though. Got wireless tether working via the other workaround and I'm all good...
     
  20. Marlboro

    Marlboro Active Member
    16

    May 8, 2010
    42
    3
    16
    Thanks guys. That did it!
     
  21. Bug Splat

    Bug Splat Well-Known Member
    Thread Starter
    43

    May 28, 2010
    280
    34
    43
    Please share. what is the workaround? :D
     
  22. teufeltexan

    teufeltexan Well-Known Member
    23

    Apr 27, 2010
    98
    28
    23
    Paramedic
    TEXAS, y'all!

    Sorry, Bug... Had too many threads going at once and thought I had already linked to it in this one.

    I used the .bin file and wireless tether apk from this thread (created an "android.tether" folder in root of sd card and placed them there).

    Resolved my memory issue and wireless tether is working like a charm...
     
    Bug Splat likes this.
  23. below_radar_00

    below_radar_00 Well-Known Member
    36

    Apr 2, 2010
    125
    8
    36
    Charleston, SC
    I'm having this same problem. I've tried uninstalling Wireless Tether and deleting the android.tether folder and my phone storage and camera still aren't working. I'm REALLY hoping I don't have to reflash the stock ROM. It took me like 5 hours to apply 2.2 since I had to reflash the stock ROM, apply the OTA, install 2.2 and then restore all my apps and settings with Titanium. Any helpers out there?
     
  24. najaboy

    najaboy Well-Known Member
    53

    May 3, 2010
    390
    68
    53
    You're going to have to reflash the ROM. The good news is that you don't need to through everything again. I've been bouncing back and forth between this and adrynalyne's ROM all night with no ill effects.
     
  25. below_radar_00

    below_radar_00 Well-Known Member
    36

    Apr 2, 2010
    125
    8
    36
    Charleston, SC
    What do I need to do differently to make sure it work this time and I get the .32 kernel? I installed the 2.2 version from the video thread on here...maybe it's different than the xda one?
     

Share This Page

Loading...