1. Are you ready for the Galaxy S20? Here is everything we know so far!

Installing .apk in system/app directory

Discussion in 'Android Devices' started by Super_Grinch, Apr 17, 2010.

  1. Super_Grinch

    Super_Grinch Lurker
    Thread Starter

    I am still getting to know the ins/outs of my newly rooted phone. I am using an app called PowerManagerPro and it gives the following instructions to install to the system/app directory to activate certain rooted functions:

    I am not able to get this done using the Terminal Emulator, it keeps saying "cp not found". I also cannot find a function in Root Explorer to install the .apk in the the system/app.
    Is there another way to install apk's into the system/app folder?

  2. CRPercodani

    CRPercodani OFWGKTA

    cp is a busybox command so you might not have busybox, what ROM are you running? Try typing busybox cp then the rest of the command.
    BurrCheese likes this.
  3. GirLuvsDroid

    GirLuvsDroid Android Expert

    The easiest way, at least for me, to get an app into /system/app is to use Root Explorer to copy the apk into /system/app.

    To do this:
    • In Root Explorer, copy the apk file you want to put in /system/app
    • Navigate to the /system/app directory
    • Tap the Mount R/W button on the top right
    • Tap Paste
    • Scroll down to the pasted apk, long press on it and select Permissions (you'll see 9 check boxes when you do this)
    • Check the Read and Write buttons for User, and only the Read boxes next to Group and Others, then tap OK (once you're done, the read/write permissions under the app name should be the same as all the other apps listed (rw-r--r--))
    • Reboot.
    trek7000, Codawg, Sidain and 7 others like this.
  4. Eazail70x7

    Eazail70x7 Android Expert

    I have a live wallpaper I am trying to install and the package installer cant install it. Is it possible to install it using root explorer or connect bot? If so, how? Been trying all day
  5. Super_Grinch

    Super_Grinch Lurker
    Thread Starter

    This worked for me, thanks!
    As for what rom I'm using, its NexBeast 0.9. So far its great. I am still getting used to the unix commands, busybox ect....

    Thanks for all the replies.
    scsbo likes this.
  6. shadowdude777

    shadowdude777 Android Expert

    Also, yes, cp is a busybox command, but cat does the same thing and is not. It's just that cp uses this format:

    cp [original file] [new file]

    And cat uses this:

    cat [original file] > [new file]

    Note the > between the file and its destination.
  7. scsbo

    scsbo Lurker

    Hey, Super Grinch
    You saved me from lots of sleepless nights ! I had deleted a system file from my beloved Galaxy Tab and had been suffering to restore it. Now it is there.
    Thanks a lot, man !
  8. sheni7

    sheni7 Lurker

    I have been trying to install the buddies now apk using the method above. The problem that I am having is that I can't modify the permissions to (rw-r--r--). I everytime I delete the file it reappears each time I exit and reopen the system/app folder. I can't uninstall it and it won't allow me to reinstall it either. I get an error message stating that "Activity Not Found - com.sec.android.widgetapp.buddiesnow" when I tried to launch the program. What's the problem. It is the only apk file in the system/app folder with the wrong permissions. I tried to overwrite the odex file with matching permissions. It refused to overwrite the file. What else can I do?
  9. mrterry

    mrterry Member

    +1 for this also.

    I've run into a few mods/tweaks/apps that had install instructions that suggested copy/paste via shell. Since my typing skills aren't the greatest in a shell, I also preferred to do it in a more 'traditional' way, if you please, and root explorer works awesome for it.

    Havent tried but I wonder if Astro would work as well?
  10. sheni7

    sheni7 Lurker

    I was able to copy and past the apk into the /system/app folder. The problem was that the I could change the permissions for the file. When I changed it and closed the file it kept reverting back to the original permissions which were wrong. I eventually uninstalled it using root uninstaller. I tried deleting it several times too but each time I did it kept popping back up in the folder. I was REALLY weird. I would appreciate it if anyone has the buddies now apk file to share it with me. I am having similar problems with samsung apps too.

    Thank you,
  11. teddyearp

    teddyearp Android Expert

    Does Astro have a method to mount /system as read/write? Not the last time I checked, so no.

    @ sheni7, for one, do you NEED that app in /system/app? Or are you just wanting to put it there for the thought of it working better? Forgive me I am not familiar with the app. One thing that gives me pause, you said you were having problems with other Samsung apps, that said, the things you read in this section may not help you at all, since this is the Motorola A855/Droid 1 all things root.

    Anyways, there's another way to try. It requires terminal emulator on your phone or adb shell on your computer. Either way, get there and here's the commands to try:

    Code (Text):
    1. su
    2. mount -o remount,rw /dev/null /system
    3. chmod /system/app/[name of your app goes here] 0644
    4. mount -o remount,ro /dev/null /system
    5. sync
    6. reboot
    good luck
  12. shadowdude777

    shadowdude777 Android Expert

    Some ROMs have a "God Mode" in them, which, when enabled, allows any file manager to write to /system.
  13. sheni7

    sheni7 Lurker

    Thanks for your input. I ended up deleting the file from my phone and installing the people contact widget the come with the app launcher pro widget app.
  14. Pengo007

    Pengo007 Lurker

    I've done the above although can not see the app in my installed apps list, and hence can not open it. Any ideas?
  15. teddyearp

    teddyearp Android Expert

    Reboot your phone. Then it should show up.

    good luck
  16. Calicab

    Calicab Lurker

    i got the stock optimus messenger apk in the system app folder, and rebooted, but its not coming up anywhere.....how do i "install it"
  17. garryw1305

    garryw1305 Lurker

    ^^ I too would like to know this ^^

    I've installed a custom ICS ROM on my SGSII, but really liked the "Mini Paper" widget on the stock ROM (postit.apk). I've tried to install it as a system app following all the above instructions (copying to system/app, giving correct permissions using ES File Explorer, clearing Dalvik Cache, Rebooting) but to no avail.

  18. teddyearp

    teddyearp Android Expert

    Try following the steps below.

    But then things _might_ be different for the devices you two are using.

    With the Motorola A855, I can copy/push any .apk to the /system/app folder, set the proper permissions, reboot and it's there in my app drawer.

    good luck
  19. GumbyDroids

    GumbyDroids Lurker

    I followed all the steps (including reboot) but I'm still not seeing the app in my app drawer either.

    Background: I'm running the eclipse rom on my Motorola Droid Razr (I know this is not a razr forum, but is the closest thing I found related to my issue). The rom deleted all Motoblur apps and I'm trying to re-install some. I got the apk files from my wife's razr system/app folder, but even after the steps above I can't install them.

    If I try to actually hit the install button in Rom Manager (after moving files to system/app and changing permissions) it runs the install but at the end I get "application not installed".

    Please help! Thanks
  20. teddyearp

    teddyearp Android Expert

    I am not aware of an application install function within Rom Manager, the only thing I know that Rom Manager will install is another rom.

    Please elaborate.

    Plus, it _could_ be that the blur apps you want to re-install are dependant upon blur actually being on your phone as well.
  21. GumbyDroids

    GumbyDroids Lurker

    Sorry, I meant Root Explorer, when you click on the actual apk and it gives you the option to install....

    I have been doing a lot of reading and it does seem that those app may require part of the Motoblur infrastructure that has been removed by the rom, but I have not been able to confirm if this is really it, or if there is a work around to installing these apps.
  22. OutOfPhase

    OutOfPhase Premium Member

    what apps are you trying to install?
  23. GumbyDroids

    GumbyDroids Lurker

    Mainly the smart CarDock and the SmartDock for the HD dock (the ones that the rom left are much more basic and limited and I use both the car dock and HD docks daily. I also like the email app better than gmail and I also wanted smart actions app. Those are the main ones. Like I mentioned earlier, I have all the apks which I pulled from my wife's razr.
  24. OutOfPhase

    OutOfPhase Premium Member

    As far as I know all those apps are going to be blur and Razor specific. There is no way I know of to make them work on the OG droid which has no blur.
  25. Fabione72

    Fabione72 Lurker

    Same issue also on GT-I9000 (Samsung galaxy S), no way to install stock apps from the same phone.
    - I took 3 stock apps from original ROM (Gingerbread): DLNA, FM Radio and Double Watch.
    - I changed the phone ROM to CM9 (ICS)
    - I copied the files, changed permissions, rebooted, etc.

    No way, stock apps are not there :(

    I'm wondering if it is just an android version issue (Gingerbread vs ICS. 3 apk over 3?! is unlikely), or if I'm still missing something (I go through all the steps and I double checked permissions etc.)


Motorola Droid Forum

The Motorola Droid release date was November 2009. Features and Specs include a 3.7" inch screen, 5MP camera, 256GB RAM, processor, and 1400mAh battery.

November 2009
Release Date
Similar Threads - Installing apk system
  1. melani78
  2. muddlemand
  3. Somogyi Henrik
  4. Olivianeal
  5. OM2
  6. LukeShaw
  7. pnbalaji
  8. Mike Zap
  9. Saaquib Ahmad Neyazi
  10. oleb84

Share This Page