1. Download our Official Android App: Forums for Android!

Support Interesting JPG file corruption issue...

Discussion in 'Android Devices' started by tesh, Feb 27, 2012.

  1. tesh

    tesh Newbie
    Thread Starter
    Jun 12, 2010

    Jun 12, 2010
    I'll start with the TL;DR:

    - I had a photo folder on a 32g micro sd in my tf101; between the process of trying to read/write using a mac connected via usb, the folder somehow corrupted leaving me with all the photos titled """""."" when viewed on the tf101 but the names are visible when viewed on a pc via the tf101 connected as a usb device... any thoughts?

    the TL;

    I created a directory (folder) on a 32gb Sandisk MicroSD on the tf101 and put a bunch of photos in it, there was nothing else on the mSD.

    I ejected it properly then placed the mSD in a Sandisk fullsize SD adapter and placed it into a generic expresscard34 reader on my MBP. it popped up as 'this drive was not recognized, scan and fix?' i told it to ignore, as mac's do this to windows and other OS based memory even though they will still read/write to it.

    i ejected the memory and tried again - when i tried to copy files over, nothing happened...

    now, when i view the mSD on a windows computer the folder in which my photos were is gone and the only files visible are all titled """"."" and have a size of 0kb.

    when the mSD is viewed through the tf101's file browser, it's the same thing...

    however... when the mSD is viewed from a windows7 pc via the tf101 connected via usb, the folder is visible, all 149pictues are there with file names and various mb file sizes, but cannot be copied, viewed or in any way modified...

    the same goes for when the tf101 is connected to a mac using the android.com/filetransfer app for droid/mac communication...

    what could be causing this? how can it be reversed? I'm attempting to use CGsecurity's photorec app but it's got only 25/149 files recovered..


Share This Page