Help Interesting....


Android Expert
Check this out:

Just updated my Dad's Moment. Guess what just hit him less than 2 minutes after first boot when he was re-installing some of his applications? If you guessed a radio lockout, you're tonight lucky winner! Come on down, and get your prize!! Tonight you've won........ONE MAD PERSON!!!!!

Seriously? How in the hell is THAT not fixed in 2.1?! It's CDMA NATIVE.

At this point, I can safely say I'm happy I dropped this phone before I knew what the 2.1 update fixed....

As for my dad, he's seriously contemplating dropping this one in exchange for either his old Nextel i850, or a Samsung Reclaim. His reason is because, "I know they both work, and they won't die on me before I leave the office!".

Is there anything we can do for this?? That's just stupid in my opinion... before the 2.1 update, my Moment would only lockout if I was streaming music then tried to do anything else that involved using the phone's data connection/radio. Even so, it happened to me at least 3 or 4 times a day, 9 if it was a bad day.


Well-Known Member
Only thing I can offer is that I reset my phone by going to system settings and changing my setting from automatic to home then back again. Quicker than rebooting phone, but until something comes along may help him bear with it.


Android Expert
Thread starter
Yea.... nothing I did... did anything. It's the same exact crap that was present daily with 1.5. Nothing can bring it out of it's nose dive once it's stalled out with it's radio locked up. That is, unless the pilot jumps out with a parachute. By that metaphor I mean pulling the battery, as always. Same old song and dance, glad I dropped this thing on it's head before it bit me any harder.


Pâtes avec votre foie
For me, the problem mostly occurs sometime after using and shutting down wifi. I've tried the wireless setting thing and running device self service but the only thing that corrects it is a reboot. I now make it a habit to reboot whenever I shut down wifi. There's a major flaw in the radio implementation that affects a significant number of Moments and it's never going to be fixed. This is very reminiscent of the bt problems the old HTC 6700 had. A ton of people had frequent disconnect issues, but HTC kept silent till the phone was discontinued. Verizon swapped out so many, which all ended up on ebay. I remember the forums being flooded with complaints about ebay purchased 6700 bt late in the phones life.

Mama Luigi

Well-Known Member
I've had the data stop working on me, but it always fixes itself without a reboot if I can just get the cell radio to restart. Of course, going into airplane mode is NOT the way (this causes it to get stuck in airplane mode until you reboot!). Connecting to a WiFi network always works, but then again if I have WiFi available there's no reason to use the cell data in the first place. So usually I just stop whatever it is I'm doing and let the phone sit for a minute or two. Once I see the "EV-D" (EV-Disabled) logo, I try again and it works.

The lockups have also occurred much less frequently since the phone was new, although that might be because I use it a lot less than I did when it was my shiny new toy. And I'm not trying to excuse the phone for a stupid bug that shouldn't be there in the first place, just relaying my personal experience to see if anyone else has had the same thing happen or to help people who have had trouble.