1. Check out our companion app, Forums for Android! Download from Google Play

[International / GSM] FastBoot Fail. Help!

Discussion in 'Android Devices' started by quickmustang, Dec 17, 2011.

  1. quickmustang

    quickmustang Active Member
    Thread Starter
    36

    Nov 7, 2009
    37
    4
    36
    Engineer
    Wooster, OH
    I am trying to root my new Galaxy Nexus. I have unlocked the bootloader already. When I try to copy a boot image through fastboot, it fails. In the bottom right corner when I am in the recovery screen it says "fastboot status FAIL Invalid Command" Then why I try to flash anything it says FAILED (remote: Invalid Command). Here is my complete command history:

    C:\android-sdk-windows\New Folder>adb devices
    List of devices attached
    0146975A0201B01B device


    C:\android-sdk-windows\New Folder>adb reboot recovery

    C:\android-sdk-windows\New Folder>fastboot devices
    0146975A0201B01B fastboot

    C:\android-sdk-windows\New Folder>fastboot boot boot.img
    downloading 'boot.img'... FAILED (remote: Invalid Command)

    C:\android-sdk-windows\New Folder>


    Any ideas?
     

    Advertisement

  2. civicsisedan

    civicsisedan Well-Known Member
    93

    Apr 26, 2010
    840
    178
    93
    Army
    Maryland
    Theres a space between boot boot.img?

    Which method are using? There is an easier method now.
     
  3. quickmustang

    quickmustang Active Member
    Thread Starter
    36

    Nov 7, 2009
    37
    4
    36
    Engineer
    Wooster, OH
  4. civicsisedan

    civicsisedan Well-Known Member
    93

    Apr 26, 2010
    840
    178
    93
    Army
    Maryland
    It sounds like the boot.img isnt in your folder with fastboot...
     
    Yeahha likes this.
  5. quickmustang

    quickmustang Active Member
    Thread Starter
    36

    Nov 7, 2009
    37
    4
    36
    Engineer
    Wooster, OH
    Did a battery pull and now everything works. Thanks for the help!
     

    Attached Files:

  6. sandich

    sandich New Member
    5

    Dec 20, 2011
    3
    0
    5
    Hey I'm having the same problem. Everytime I enter the bootloader it says FAIL Invalid Command as well, could you go into more detail about how you fixed it? At what point did you pull the battery? Thanks.
     
  7. trophynuts

    trophynuts Well-Known Member
    313

    Jul 6, 2010
    5,630
    1,792
    313
    I work in a Tech related field. Have been in a tec
    SouthEastern US
    are you having this at the exact same time in the process as the op?
     
  8. sandich

    sandich New Member
    5

    Dec 20, 2011
    3
    0
    5
    Yeah every time I plug in my Nexus while in bootloader mode the bottom corner instantly shows the FAILEDinvalid command. Unlocking worked just fine though following the same Droid-Life instructions.
     
  9. quickmustang

    quickmustang Active Member
    Thread Starter
    36

    Nov 7, 2009
    37
    4
    36
    Engineer
    Wooster, OH
    I just turned it off and pulled the battery out. I let it sit for a minute, then turned it back on and booted into the bootloader with both volume keys pushed down. Everything worked fine from there. Does the fastboot devices command recognize your phone?
     
  10. sandich

    sandich New Member
    5

    Dec 20, 2011
    3
    0
    5
    Actually I tried the process from a different computer and everything worked! For some reason my particular computer wasn't running fastboot correctly and you suggested. Thanks for the help though!
     
Tags:

Share This Page

Loading...