1. Are you ready for the Galaxy S20? Here is everything we know so far!

[International / GSM] Updating yet not updated?

Discussion in 'Android Devices' started by Bungi, Apr 27, 2012.

  1. Bungi

    Bungi Newbie
    Thread Starter

    Hey!
    Some time ago, after I've bought my GNex I decided to root it and get the yakju version. Both seemed to have worked perfectly fine, I had root access in terminal, wasn't so sure about the version but it wasn't really all that important.
    Today my phone notified me about an available update from 4.0.2 to 4.0.4. I said to myself - why the hell not - and just proceeded. After the reboot the phone seemed bricked, there was a red exclamation mark above open android symbol and the phone was not responding to anything.
    I had to pull the battery out and was hoping for the best. The phone did boot up properly (it took a while though) but in 4.0.2 version. Being a curious person I decided to check for updates and now I was informed there are none available.

    My question is: what has happened? How can I check whether or not I have the yakju distro and if I do, should I update the phone in some other way to avoid this from happening again?

    Thanks in advance,
    Bungi

    PS. This is my first android phone. I still may not know a lot about the OS so please be patient about my questions ;)
     


  2. GrenW

    GrenW Android Expert

    When you rooted it did you install ClockworkMod recovery? One of the outcomes of doing this is that OTA updates will fail.

    To check which version (Yakju etc) you have, download GN Official Update Checker from the Market.

    Also to update to 4.0.4 try searching on here for instructions on how to manually update. It may be different depending on whether you have CWM installed.
     
    Bungi and scary alien like this.
  3. Bungi

    Bungi Newbie
    Thread Starter

    Thanks for your answer ;)

    I think I did install ClockworkMod recovery, will check it soon enough.

    Thanks for info about distro :) Should any other option fail I will find a proper way to update it manually :)
     
  4. TheOozyman

    TheOozyman Member

    Bungi likes this.
  5. Bungi

    Bungi Newbie
    Thread Starter

    Quick info: GN Official Update Checker doesn't exist anymore. I found Android System Info though and checked everything easily ;)

    In terms of updating - the HOWTO was very easy to follow. The only problem have now is restoring my root. I wanted to do it manually by ADB as stated in the link:
    So I connected with phone turned on via ADB and received
    Code (Text):
    1. 10|shell@android:/ $ chmod -R 4755 /system/bin/su                              
    2. Unable to chmod /system/bin/su: Read-only file system
    Then I recalled I should do it while in CWM but to no avail, I could not connect:
    Code (Text):
    1. :~/telefon/nexus/sdk-tools$ ./adb-linux devices
    2. List of devices attached
    3. ????????????    no permissions
    How can I do it now?
    I checked if by any chance maybe I had root but after typing "su" in terminal on the phone I just got "permission denied".

    Thanks in advance ;)

    EDIT:
    Got it working. I just turned the phone in CWM recovery mode and used the same su.zip I used the first time while rooting. Worked like a charm :)
     
  6. scary alien

    scary alien not really so scary
    Moderator

    Bungi,

    I think you can use the sudo command to overcome the permissions issue for adb. For example:

    Code (Text):
    1. sudo ./adb-linux devices
    Glad you got it going, though! :)

    Cheers!
     
  7. TheOozyman

    TheOozyman Member

    NICE! For future reference though - its super easy to restore root with Wug's Galaxy Nexus Root Toolkit

    And although you need the different superuser for 4.0.4 you can easily find that online and place it in a folder on the internal SD

    This lovely guide by @scaryalien has the download for the proper superuser for 4.0.4 too :)

    How to Root GSM Galaxy Nexus
     
    scary alien likes this.

Galaxy Nexus Forum

The Galaxy Nexus release date was November 2011. Features and Specs include a 4.65" inch screen, 5MP camera, 1GB RAM, TI OMAP 4460 processor, and 1750mAh battery.

November 2011
Release Date
0
Reviews
Loading...

Share This Page

Loading...