1. Are you ready for the Galaxy S20? Here is everything we know so far!

[International] Help me fix my newb screwup...

Discussion in 'Android Devices' started by dixie460, Sep 29, 2014.

  1. dixie460

    dixie460 Member
    Thread Starter

    Alright, so a few weeks ago I bought this phone, unlocked the bootloader, and rooted it so I can do as I please. Fast forward to tonight and I'm going thru some stuff using Titanium Backup and noticed Google Play Services had been updated. Not wanting that update to sit in /data, I hit "Integrate Update Into ROM"... well apparently this was a dumb idea. TiBU froze up, and even though I was able to force it to close, it seems to have corrupted Google Play Services on my device.

    No worries, I'll just restore my NANDroid backup from CWM... or so I thought, til I got the message "Error restoring /data" in CWM. Hmm... ok wipe /data and try again. Still got the same error.

    Okay I'll just ADB Push the Google Play Services APK to my phone and install it that way. Nope, when I try that it says "App Not Installed". Sure enough, I log into Google Play from my computer and it says Play Services is already installed... :hmmmm2: (How does it determine this?)

    Alright let me try something else. Wipe Dalvik, cache, data, and try to install Carbon ROM since I don't have a clean factory ROM image. Well that was a mess... com.android.phone and a whole lot of other stuff was crashing. Flash back to my NANDroid backup (still says "Error restoring /data") and here I am.

    What can I do to reinstall Google Play Services? Or do I need to do more than just that?

    Phone is currently back on the NANDroid backup of factory ROM with a failed /data recovery, and my computer is running Linux (Ubuntu 12.04 LTS) with ADB installed.

    Thanks for any help!
     



    1. Download the Forums for Android™ app!


      Download

       
  2. dixie460

    dixie460 Member
    Thread Starter

    Well, I tried to change the thread title to reflect that I fixed the issue, but I guess that ain't possible.

    Anyhow, I got 'er fixed. Went back to Titanium Backup and was looking for any trace of Play Services, when I found the option to "Extract From Nandroid Backup"... NICE!

    So I extracted what I needed and installed it without a problem... everything's back to normal!

    Now to figure out why CWM couldn't restore my /data partition...
     
  3. alfick3

    alfick3 Android Expert

    Glad you got it worked out. I'd leave Google stuff alone, from here on out. :D
     

Motorola Moto G (1st Gen) Forum

The Motorola Moto G (1st Gen) release date is unknown..Features and specs are not yet known.

unknown.
Release Date
0
Reviews
Loading...
Similar Threads - International Help fix
  1. rogerbid
    Replies:
    10
    Views:
    1,594
  2. bbbl67
    Replies:
    11
    Views:
    1,735
  3. tendoboy1984
    Replies:
    8
    Views:
    852
  4. Edjekadetje
    Replies:
    2
    Views:
    1,045
  5. mtgsilentstorm
    Replies:
    3
    Views:
    550
  6. PrimitiveScrewhead
    Replies:
    10
    Views:
    2,128
  7. PrimitiveScrewhead
    Replies:
    15
    Views:
    1,409
  8. kumaranil13k
    Replies:
    4
    Views:
    894
  9. Retrodyne
    Replies:
    20
    Views:
    2,820
  10. Garaera
    Replies:
    3
    Views:
    1,908

Share This Page

Loading...