1. Are you ready for the Galaxy S20? Here is everything we know so far!

[International] [how to] get a rom to your sd card if your phone wont boot

Discussion in 'Android Devices' started by scotty85, Jun 26, 2013.

  1. scotty85

    scotty85 Extreme Android User
    Thread Starter

    current recoveries are no longer supporing "mount usb storage" to transfer files(Exactly why,im not sure)

    if you find yourself in a predicament where you need to flash a rom on a non booting phone,you have a couple of options:
    1)push with adb

    2)install via adb sideload

    i personally used cw to test these,ill have to check twrp later.

    push to sd card via adb
    1)place rom into adb/fastboot folder
    2)boot to recovery
    3)open cmd,check connectivity:
    adb devices
    (should return serial number)
    4)push rom to sd card:
    adb push romname.zip /sdcard/ (where romname is your actual zip file name)
    5)you should then be able to simply wipe and flash the rom as you normally would.

    *if you can find a nandroid for your particular build,you should be able to push that,with:
    adb push nandroidname /sdcard/clockworkmod/backup/nandroidname/
    (again,using cw. ill update if i can determine this to work for twrp)
    be patient,the nandroid is a big file,so this will take some time.

    2)install from adb sideload
    1)place rom into adb/fastboot folder
    2)boot to recovery
    3)open cmd,check for connectivity
    adb devices
    (should return serial number)
    4)select "install from sideload" from the recovery menu
    5)in cmd,enter:
    adb sideload romname.zip (where romname is your actual rom's name)
    you should see it installing on the phones screen

    hope this helps some folks,ill refine it later as i learn more about it. i did successfully sideload superSU,and pushed nandroids to clockwork/bckup and zip files to sd card.

    again, the above was done with clockwork touch recovery

    we will have to verify the processes with twrp

    rosh88, HenryLuo, clsA and 1 other person like this.

    1. Download the Forums for Android™ app!


  2. Nimitz87

    Nimitz87 Newbie

    appreciate you making this thread scotty.:D

    ok I have adb running and see my device for the first time (using CWM and not TWRP)

    when I go and try to adb push Nocturnal_1.27.531.7_Odex_unrooted.zip after pressing enter I get this error.

    C:\Users\BAMF PC>adb devices
    List of devices attached
    FA35PW905487 recovery

    C:\Users\BAMF PC>adb push Nocturnal_1.27.531.7_Odex_unrooted.zip /sdcard/
    cannot stat 'Nocturnal_1.27.531.7_Odex_unrooted.zip': No such file or directory

    C:\Users\BAMF PC>

    ROM is placed in the adb/fastboot folder im so close!

    edit: when I try the sideload method I get a "cannot read sideload" error.
  3. scotty85

    scotty85 Extreme Android User
    Thread Starter

    the errors your getting indicate the pc cant find the rom.i actually got the same error when i forgot to type inthe ".zip" file extension. :eek:

    off the top of my head:
    -you could have the name slightly off
    -the file may be a different type(not a .zip)
    -you could be in a different directory. if you have the sdk in your path,try cd:\ing to the actual folder where youve put the file
    -maybe a name issue? i dont think your name should have any impact,but you might try shortening/simplifying the name.
    -you also may try a different rom

    ill ponder it some more the rest of the afternoon,im usually home around 8ish EST :)
    Unforgiven likes this.
  4. Nimitz87

    Nimitz87 Newbie

    ok so I tried a different ROM, and after a few mins it pushed successfully! I flashed ARD and all is working, went ahead and made a backup :)

    thanks so much for the help
    scotty85 likes this.
  5. scotty85

    scotty85 Extreme Android User
    Thread Starter

    Awsome! Glad you are sorted :cool:
    Unforgiven likes this.
  6. Nimitz87

    Nimitz87 Newbie

    well that didn't last long...I think something is actually wrong with my phone doesn't matter what ROM AOSP, AOKP, Sense, etc. i'll have random freezes and hard reboots which normally means I have to full wipe and install again.

    well it happened earlier went to boot into recovery and no recovery boots, it freezes on the splash screen with "entering recovery"

    at this point I just want the phone to work :eek:
  7. Nimitz87

    Nimitz87 Newbie

    got cwm to boot after reflashing it via fasboot, however it froze in recovery and started boot looping....I rebooted and tried to get to recovery with it freezing on the splash screen again.
  8. scotty85

    scotty85 Extreme Android User
    Thread Starter

    Hmmm are you using the gsm image? Are you s on,or s off?

    Have you changed kernels,overclocked,or made any other mods?

    Changed cid or mid?
    Unforgiven likes this.
  9. Nimitz87

    Nimitz87 Newbie

    s-on, haven't changed cid or mid, the kernel has changed depending on some of the ROM's yes.

    gsm image?

    what other info can I provide?
  10. Nimitz87

    Nimitz87 Newbie

    I could definitely use some help, right now I can't access adb thru fastboot/hboot for some reason at all.

    right now my phone is a paper weight :(
  11. scotty85

    scotty85 Extreme Android User
    Thread Starter

    you cannot access adb via hboot or fastboot,period. adb commands are used in recovery or the booted OS,fastboot commands are used with the phone in fastboot.

    best bet is to flash a recovery,then do a full wipe and try and restore a backup or flash a stock rom. assuming you are able to flash a matching kernel run the phone a few days without flashing a rom or making mods and see what happens.
    Unforgiven likes this.
  12. Nimitz87

    Nimitz87 Newbie

    I can't flash a recovery, it just hangs on the "entering recovery screen" for about a minute then goes black and reboots.
  13. scotty85

    scotty85 Extreme Android User
    Thread Starter

    Are you using the same image you've used before,and been able to boot to?

    What is its md5?
    Unforgiven likes this.
  14. Nimitz87

    Nimitz87 Newbie

    yes sir, same clockwork I flashed the first time you recommended me to switch.


  15. clsA

    clsA Android Enthusiast

    did this get sorted or are you still stuck ?
  16. Nimitz87

    Nimitz87 Newbie

    was fixed, however a random reboot broke it again it seems.

    sorry, yes it is the correct md5 and checked with a hasher.

    I also tried the touch/standard versions just for the hell of it.

    I just tried the

    fastboot boot imagename.img

    when I do this the phone reboots, but not into recovery, if I vol down + power and try to reboot into recovery the same thing happens, hangs on entering recovery, and then reboots into a boot loop.

    I'm not sure I follow what you mean by flashing a matching boot image.

    where do I get the boot.img from? extract it from one of the ROM's?

    sorry for such long delayed reply's, I work the third shift :/

    I appreciate any and all feedback
  17. Nimitz87

    Nimitz87 Newbie

    found this thread which seems somewhat similar problem


    I have the same adb issues where it works and sometimes doesn't (very very frustrating)

    I saw you asked for his getvar so here is mine

    C:\android-sdk\fastboot>fastboot getvar all
    (bootloader) version: 0.5
    (bootloader) version-bootloader: 1.44.0000
    (bootloader) version-baseband: 4A.16.3250.24
    (bootloader) version-cpld: None
    (bootloader) version-microp: None
    (bootloader) version-main: 1.27.531.8
    (bootloader) version-misc: PVT SHIP S-ON
    (bootloader) serialno:
    (bootloader) imei:
    (bootloader) meid: 00000000000000
    (bootloader) product: m7_ul
    (bootloader) platform: HBOOT-8064
    (bootloader) modelid: PN0713000
    (bootloader) cidnum: T-MOB010
    (bootloader) battery-status: good
    (bootloader) battery-voltage: 4331mV
    (bootloader) partition-layout: Generic
    (bootloader) security: on
    (bootloader) build-mode: SHIP
    (bootloader) boot-mode: FASTBOOT
    getvar:all FAILED (status read failed (Too many links))
    finished. total time: 0.047s

    tried to flash the file you dumped and got this

    C:\android-sdk\fastboot>fastboot devices
    FAXXXXXXXXXX fastboot

    C:\android-sdk\fastboot>fastboot erase cache
    erasing 'cache'...
    OKAY [ 0.400s]
    finished. total time: 0.400s

    C:\android-sdk\fastboot>fastboot oem rebootRUU
    (bootloader) Start Verify: 3
    OKAY [ 0.040s]
    finished. total time: 0.040s

    C:\android-sdk\fastboot>fastboot flash zip 1.29.1540.3miniruu_tmoible_.zip
    sending 'zip' (951927 KB)...
    OKAY [ 42.140s]
    writing 'zip'...
    (bootloader) zip header checking...
    (bootloader) zip info parsing...
    FAILED (remote: 99 unknown fail)
    finished. total time: 42.380s

  18. clsA

    clsA Android Enthusiast

    scotty85 likes this.
  19. Nimitz87

    Nimitz87 Newbie

    uh in the other thread, Scotty states the bootloader must be UN-locked, I'm not trying to restore to stock, I'm trying to get the phone in a state where it can boot any OS, not even running an RUU (since there isn't one for tmob) its just the RUU flash screen I believe.

    also I can't flash a recovery, tried numerous times, hence stock recovery.
    scotty85 likes this.
  20. clsA

    clsA Android Enthusiast

    Humm.. I know it's stressful time but you need to take things slow.
    You said earlier you flashed a rom from CWM
    so you do have custom recovery.
    does the phone boot to CWM now or no ? when you use power + volume down ?
    scotty85 likes this.
  21. Nimitz87

    Nimitz87 Newbie

    sorry for the confusion but the thread was made for a different issue which scotty resolved. the current problem is from post #6-7

    however I had a random freeze/reboot IN recovery and now I can't access recovery at all (boot loops) and flashing it fastboot shows it successful but does nothing when rebooted into recovery.

    right now the only thing I can access is the RUU flash screen and Hboot/fastboot.
    scotty85 likes this.
  22. clsA

    clsA Android Enthusiast

    the fastboot erase cache should stop the bootloop
    then fastboot reboot and hold down on the volume should get you back to bootloader.

    in bootloader go to recovery hit power you should be back in CWM
    scotty85 likes this.
  23. Nimitz87

    Nimitz87 Newbie

    yeah thats a no go, hangs on boot into recovery screen, then screen goes dark, and reboots about 20 seconds later and boot loops from there.
    scotty85 likes this.
  24. clsA

    clsA Android Enthusiast

    guess your returning it to T-mo then it's screwed
    scotty85 likes this.

HTC One M7 Forum

The HTC One M7 release date was March 2013. Features and Specs include a 4.7" inch screen, 4MP camera, 2GB RAM, Snapdragon 600 processor, and 2300mAh battery.

March 2013
Release Date
Similar Threads - International rom card
  1. Justin Raney
  2. Christopher Clayton
  3. DankeShen
  4. rogerbid
  5. bbbl67
  6. tendoboy1984
  7. Edjekadetje
  8. mtgsilentstorm
  9. PrimitiveScrewhead
  10. PrimitiveScrewhead

Share This Page