1. Are you ready for the Galaxy S20? Here is everything we know so far!

[International] I can't root my i9300

Discussion in 'Android Devices' started by quinnygoth, Jan 10, 2013.

  1. quinnygoth

    quinnygoth Newbie
    Thread Starter

    Hello everyone

    I've tried multiple times to root my i9300 but I've had no luck.

    Initially I tried doing it on my MacBook Pro following an online tutorial. I got almost to the end and it didn't work. I realised I needed to install Clockworkmod Recovery.

    I've tired doing this but it seems to me that this is only for Windows.

    I then tried to root my i9300 on my friends Windows computer and laptop. I installed Odin on both the laptop and computer and the program didn't pick up my phone when it was plugged in.

    I'm really stuck, and I really don't want to start dicking around with it loads for fear of bricking it.

    The phone is a GT i9300. It used to be with Vodaphone but I got it unlocked and now I'm on EE.

    Android version 4.1.2

    Can anybody help me out? I'm trying to root it because I want to get rid of all of the bloatware.

    Thanks!
     


  2. silentwitness

    silentwitness Android Expert

  3. SUroot

    SUroot Extreme Android User

    The guide in the sticky thread covers all of this
     
  4. quinnygoth

    quinnygoth Newbie
    Thread Starter

    Jzo 54k is the firmware I'm using. That tut is for a different firmware :(
     
  5. SUroot

    SUroot Extreme Android User

    That's not a samsung based firmware. That's Google AOSP.

    The tutorial is for all samsung firmwares.

    Please post screen shot of settings > about device
     
  6. Shotgun84

    Shotgun84 Extreme Android User

    Would you be able to scroll down a little further so we can see the build number please
     
  7. CDPlant

    CDPlant Android Expert

    Looks like it says JZ054K I9300XXELL5 but I can't be certain :eek:
     
  8. Shotgun84

    Shotgun84 Extreme Android User

    That would make sense as that's stock vodafone firmware. In that case the cfroot method is the way to go.
     
  9. heat57

    heat57 Android Enthusiast

    I'd recommend Mskip's AIO Toolkit. Just make sure that you uninstall Kies before you install his toolkit (if it's already installed) and follow the instructions within the toolkit. I am sure that your firmware is included. Just read through his thread on XDA and make sure you follow the toolkit instructions per verbatim. Here's the link http://forum.xda-developers.com/showthread.php?t=1746665
     
  10. SUroot

    SUroot Extreme Android User

    Yes, its XXELL5.. So the guide in the sticky should work fine for a windows computer. It covers what to do with drivers etc.

    That said, i dont want to detract from what heat has said above either.
     
  11. quinnygoth

    quinnygoth Newbie
    Thread Starter

    Sorry about the bad screen shot.

    The build number is JZO54K.I9300XXELL5

    Is this okay for the XDA guide and the sticky guide?

    I'll check out the guide in sticky and the XDA guide anyway. I'll have to do all of this on a friends computer as I have a MacBook.

    Thanks!
     

Samsung Galaxy S3 Forum

The Samsung Galaxy S3 release date was May 2012. Features and Specs include a 4.8" inch screen, 8MP camera, 1GB RAM, Exynos 4412 Quad processor, and 2100mAh battery.

May 2012
Release Date
0
Reviews
Loading...

Share This Page

Loading...