1. Check out our companion app, Forums for Android! Download from Google Play

Root [International Tegra 3] I am terribly sorry if this is redundant but...

Discussion in 'Android Devices' started by Gullinbursti, Mar 29, 2013.

  1. Gullinbursti

    Gullinbursti New Member
    Thread Starter

    Oct 8, 2012
    Thessaloniki, Greece
    I have been trying (on and off for two weeks now) to get CM10 on my HTC One X. I m not in the states, so it's not an AT&T but an international version and I have found a thousand guides on how to do this from scratch, half of them in this site.

    Alas, I have a huge problem getting it to work...

    I have followed numerous guides and I managed to get my phone's bootloader unlocked. Apparently it was so easy I could just follow HTCdev's instructions.

    Then I tried to create a backup for my phone. Since I am a late adopter I had a lot of things in my phone I didn't want to lose. I made an adb backup (twice to make sure) and then I went on to do whatever I had to do to root it and then mod it. Thankfully after I managed to root my phone I also created a CWM backup and a titanium backup.

    From this point on I have rooted and tried installing a rom (specifically CM10 - not CM10.1) countless times, and I really mean countless... every single time (no matter the method - I have even factory reset the phone and tried starting from scratch) the phone hangs at the HTC logo for more than the normal 10-20 minutes. Heck, I left it there for 35' just to be sure and it never got unstuck... I tried manually with the adb boot and boot.img method, I've tried redoing the whole thing - same results...:(

    From that point on it was restore backup from either CWM or an adb restore and on with the process again, always ending up looking at the HTC logo for more than 20 minutes at a time.

    I really, really want to get my phone another mod (preferably CM10) but I just can't find where the problem lies...

    Any help would be greatly appreciated!


  2. El Presidente

    El Presidente Beware The Milky Pirate!

    Jan 3, 2011
    Did you flash the relevant boot image or are you just flashing the zip file? For CM10, you might need a modified boot.img if your stock handset was jellybean.

    CM10.1 or AOKP might be easier.
  3. shauny13

    shauny13 Well-Known Member

    May 24, 2010
    Beautiful Dorset
    also are you

    "fastboot erase cache" after fastboot flashing the boot img? if not

    this is usually why you get hangs at the htc logo.

Share This Page