1. Are you ready for the Galaxy S20? Here is everything we know so far!

Internet connection problems on Galaxy S7

Discussion in 'Android Devices' started by ByeIOS, Aug 16, 2017.

  1. ByeIOS

    ByeIOS Newbie
    Thread Starter

    My S7 has developed a problem in that it won't connect to the internet and I don't know how to solve this.

    With all the apps that require an internet connection such as email, BBC Weather, Google searches my (free) version of Spotify etc. I get messages telling me I need an internet connection. They did all work at one time!

    All that I know about this is to go into settings > connections > W-Fi > select my ISP and click connect.

    The blue slider says that Wi - Fi is on throughout this. I get a red message saying incorrect password but when I put the correct one in I just get back to the same error message. If I just click connect I get a message saying authenticating and then back to the same screen.

    Back at the point where I select my ISP there is an error message saying authentication error.

    I have had problems with my broadband in that it keeps dropping the connection but other devices using the internet that we have soon pick up the connection again. I have approached my ISP as well but they have not resolved my interrupted broadband issue yet.

    Any ideas or suggestions, please?

    1. Download the Forums for Android™ app!


  2. mikedt

    mikedt 你好

    Tried restarting your WiFi router?
  3. lunatic59

    lunatic59 Moderati ergo sum

    When you say you select your ISP, I am going to assume you have a WiFi router/modem combo supplied by your ISP that you use to connect to the internet.

    First, do you have any devices directly wired to the router? Or, are all your connections wireless?

    There are several reasons why correct credentials may still refuse a connection. It could be you are using an incorrect or outdated security protocol on your phone. The certificate on your router might have expired. Your router might require MAC authentication ... there are a few more as well, but if you say other devices work and it's just your phone with the issue, then I'd try this ...

    Go to menu>settings>connections>WiFi and long press your connection. You should see an option to 'forget network'. Once the network is 'forgotten' (It just clears the settings for that connection) reboot your phone.

    Then check for available WiFi networks and re-login to your router.
    Snakeyeskm and mikedt like this.
  4. ByeIOS

    ByeIOS Newbie
    Thread Starter

    Thanks for the replies.

    mikdt, sorry I should have listed the router re-boot and yes, tried that with no success but thanks for the suggestion.

    lunatic59. Thanks for all of your suggestions. The option to long-press connection is a useful one to know for the future.

    I also contacted Samsung support via the chat contact. They took me through various options including checking that power saving was on. they checked to see if the issue would go away in safe mode (It didn't) and then they took me through a factory reset (after a Smart Switch back up). The reset resolved the issue but they did not give me a cause for the fault that I can report, unfortunately.
    mikedt and lunatic59 like this.

Samsung Galaxy S7 Forum

The Samsung Galaxy S7 release date was March 2016. Features and Specs include a 5.1" inch screen, 12MP camera, 4GB RAM, Exynos 8890 Octa processor, and 3000mAh battery.

March 2016
Release Date

Share This Page