1. Check out our companion app, Forums for Android! Download from Google Play

Internet works in brower, not app. (emulation)

Discussion in 'Application Development' started by ajent, Jun 6, 2010.

  1. ajent

    ajent Member
    Thread Starter
    5

    Jun 3, 2010
    7
    0
    5
    I'm trying to make an app, following the "hello, webview" tutorial here Hello, WebView | Android Developers

    Everything, Seems to be correct, although when I run the emulator, the console says
    "[2010-06-06 14:41:50 - appname]No Launcher activity found!
    [2010-06-06 14:41:50 - appname] The launch will only sync the application package on the device!"

    Then the emulation loads, but I have to manually open the application. (the hello android app loaded itself).

    When I run the app, it appears to "display" correctly, but it tells me the address is unavailable, check settings, etc.

    The difference of my issue, is I Can get internet by going through the regular browser. It seems only my application can't get access.

    Manifest File:
    Code (Text):
    1. <?xml version="1.0" encoding="utf-8"?>
    2. <manifest xmlns:android="http://schemas.android.com/apk/res/android"
    3.       package="com.android.universalwait"
    4.       android:versionCode="1"
    5.       android:versionName="1.0">
    6.       <uses-permission android:name="android.permission.INTERNET" />
    7.     <application android:icon="@drawable/icon" android:label="@string/app_name">
    8.     </application>
    9.     <uses-sdk android:minSdkVersion="7" />
    10. </manifest>
    I figured the permissions is the only cause, but it looks fine to me?

    Any other ideas?
    Thanks a lot. [​IMG]
     

    Advertisement

  2. ajent

    ajent Member
    Thread Starter
    5

    Jun 3, 2010
    7
    0
    5
    Well I resolved the issue, not sure which did it, but I made a new project, used android 1.5 instead of 2.1 and added a name in the Create activity before clicking finish, on the new project. that seemed to fix it.

    Thanks
     

Share This Page

Loading...