1. Are you ready for the Galaxy S20? Here is everything we know so far!

IPSec / L2TP working on some models, but not all

Discussion in 'Android Lounge' started by raaboof, Feb 4, 2011.

  1. raaboof

    raaboof Lurker
    Thread Starter

    Hello forum,

    couple of weeks ago I had success in connecting a Samsung Galaxy S to our corporate VPN (Cisco ASA) using L2TP/IPSec with certificate based authentication. Now I have tried to do the same with Galaxy GT-I5510 and Sony Ericsson XPeria X10 Mini Pro. GT-I5510 has Android 2.2, and XPeria X10 has Android 2.1. Both of these have identical user interface to configure the VPN connections compared to Galaxay S. But, either of these do not even try to open the connection when I try to enable it. Both simply say:

    "Unable to connect to the network. Do you want to try again?"

    I know that the devices do not even try to connect to the VPN server, because I have monitored network traffic on the server side. No packets incoming at all. Also, network browsing works, so it's not about data connections being disabled at the device or something like that. I have also tried it using my own WLAN, so it's not about operator blocking IPSec traffic either.

    Does anyone have a clue what is wrong with these devices, why do they allow to configure an IPSec/L2TP VPN connection, but then do not even try to open it when activated?
     



    1. Download the Forums for Android™ app!


      Download

       
  2. nneton8

    nneton8 Lurker

    Hi,

    Even I am facing exactly the same issue with L2tp/IPsec but I could not find the solution yet....

    But the similar configuration for L2tp alone does not give this error and it tries to send atleast some packets to the server. Then why error only for L2tp/IPsec?????

    The same I faced with LG Optimus as well as Samsung galaxy phones....

    Please help us if any one is having the clue. I really need it.
     
Loading...

Share This Page

Loading...