1. Are you ready for the Galaxy S20? Here is everything we know so far!

Is my new Nexus 7 actually a refurb?

Discussion in 'Android Devices' started by UncleMike, Jul 17, 2013.

  1. UncleMike

    UncleMike Android Expert
    Thread Starter

    I picked up a Nexus 7 32GB over the weekend from Staples for $170. After unlocking the bootloader with WUG's Nexus Root Toolkit I tried rooting the Nexus 7 and got the following message:
    A pretty clear indication to me somebody has had this tablet in their hands before me, and flashed a custom recovery, although the OTA update from 4.2.1 to 4.2.2 successfully applied prior to any of this. Am I wrong about this having been in someone else's hands?
     



    1. Download the Forums for Android™ app!


      Download

       
  2. jhawkkw

    jhawkkw Chinchillin'

    The evidence sure is significant. I would wager a strong guess as well that it is pre-owned. Though it could be an ambiguous message from the toolkit saying the .img they have is old and are asking if you want the toolkit to update it's files rather than the tablet.
     
  3. UncleMike

    UncleMike Android Expert
    Thread Starter

    To confirm my suspicion, I tried booting into recovery by holding down both volume keys while powering on, then selected recovery, and it gets stuck on the android with a red triangle and exclamation mark (which I've read reports of with regard to TWRP recovery). At that point, I held the power button and pressed volume up and got the attached screen. I see no mention of TWRP. Is this the stock recovery?
     

    Attached Files:

  4. jhawkkw

    jhawkkw Chinchillin'

    Yeah, that is the stock recovery. It may well have been just that the toolkit had out of date files and nothing more.
     
    UncleMike likes this.
  5. UncleMike

    UncleMike Android Expert
    Thread Starter

    I think you're right. IIRC, the toolkit uses an alternate recovery (without flashing it) as part of the rooting process. It appears that TWRP is the recovery it uses for this, but this still seems a little odd since the toolkit offers to flash Clockworkmod recovery during the rooting process, with no option to flash TWRP.
     
  6. John Bean

    John Bean Happy Wanderer

    Are you sure there is no option to install TWRP? I don't have access to the toolkit at present but I'm pretty sure it has an option to install TWRP which seem to recall they refer to as a "recovery script" or something similar.
     
  7. DimBulb

    DimBulb Android Enthusiast

    I had occasion to try and use the Toolkit recently, and found it will ONLY use TWRP, and could not offer me the option to install or even use CWM.
    And that was after it updated, when I initially started it.
     
  8. UncleMike

    UncleMike Android Expert
    Thread Starter

    My mistake... the options screen does offer the choice of TWRP or Clockworkmod or a user-supplied recovery image, as well as a choice of Super SU (Chainfire) or Superuser (Koush). Since I didn't want to flash a non-stock recovery, I can't elaborate on that, but I did choose Superuser over the default Super SU, and the rooting process went without a hitch.
     
  9. Sheerluck

    Sheerluck Newbie

    I got the same message using the toolkit. It told me my version of TWRP was out of date when actually it was up to date and the toolkit reinstalled the same version of TWRP I was already running. I think it must be some kind of default question.
     
  10. Gulfstream

    Gulfstream Well-Known Member

    ^^This^^!
     
  11. colchiro

    colchiro Extreme Android User

    Every time you fire up the toolkit, it updates local files. It has nothing to do with what's installed on your tablet. :D
     
Loading...

Share This Page

Loading...