1. Check out our app, Forums for Android! Download and leave feedback here!

Is noone else have orientation change hang-ups?

Discussion in 'Android Devices' started by RichardCranium, Jan 27, 2010.

  1. RichardCranium

    Thread Starter
    35

    Nov 21, 2009
    18
    0
    35
    911
    919
    I have searched and found nothing of the sort, which kind of shocked me.

    Scenario: I get a text, pull my phone out of the belt holster.....and read it in normal orientation. With the phone unlocked, I read the text(s) and decide to respond. About 75% of the time, it either takes 5-10 seconds to change orientation when I go to horizontal mode......or it won't even switch at all. It gets so frustrating I feel like throwing the phone.

    Fwiw, a quick slide to expose the hardware keyboard will quickly change to horizontal orientation, but sliding it closed brings it back to default orientation, and doesn't seem to affect the speed of orienting back to horizontal.

    Anyone have any tips or suggestions? Or even something else to search with if this topic has been discussed? My bad if so, but I did search.
     

    Advertisement

  2. brettlewis

    brettlewis Well-Known Member
    68

    Nov 3, 2009
    867
    49
    68
    Arizona
    almost exactly the same for me.
     
  3. kbayer

    kbayer Well-Known Member
    43

    Dec 5, 2009
    417
    32
    43
    Houston, Tx
    Please don't feel insulted, but I gotta ask... do you have the orientation thingie checked in the display settings? I wouldn't have a clue as to what else to check.
     
  4. messenger13

    messenger13 Well-Known Member
    163

    Dec 8, 2009
    3,133
    381
    163
    Director of IT
    Cleveland, OH
    Sounds to me like your accelerometer needs calibrated. I've never had the issue, but I have read about it. Supposedly, if you just lay the phone flat on a table, spin it 3 times. Put it on it's side, spin it 3 times. Hold it up on one end, spin it 3 times. That is supposed to fix your issue. That also calibrates the GPS somehow, though I don't understand the logic there at all. :thinking:

    Give it a shot and report back.
     
  5. MinConst

    MinConst Well-Known Member
    16

    Dec 29, 2009
    51
    2
    16
    Same issue the last few days. Just calibrated and it is much better now. When I'm using navigation I set the droid on the console in my truck and it doesn't lay flat. It seems to stay in the standard mode. Maybe this is also the cause. I will see tomorrow if this helped.
    It does seem to be done on occasion. This is the third time I've done this in the couple of months I've had the phone.
     
  6. ssantan2

    ssantan2 Well-Known Member
    38

    Nov 24, 2009
    352
    20
    38
    if your running the OEM 2.0.1 there was a thread a while back that where it was stated that motorola made it so the home screen only stays in portait but some people have had the ability to go in landscape too. maybe yours is kinda of stuck on which type it wants to be???
     
  7. RichardCranium

    Thread Starter
    35

    Nov 21, 2009
    18
    0
    35
    911
    919
    Yup.
    The calibration sounds like something at least worthy of checking. Does someone have the procedure documented by Motorola? I'd like to see the information they have in the excerpt for this calibration.
     
  8. brettlewis

    brettlewis Well-Known Member
    68

    Nov 3, 2009
    867
    49
    68
    Arizona
    its not that it doesnt know im rotating it, but it seems to hang up and lag while attempting to rotate the image. It sometimes goes to a 400x400 resolution instead of full resolution for like a second or two.
     
  9. Zephyrmoon

    Zephyrmoon Member
    15

    Dec 11, 2009
    23
    0
    15
    Colorado
    Hello-

    I've had the same problem with the serious lag in screen orientation. I would check and uncheck the orientation box to reset it but still had problems. Sometimes it lagged so bad I had to "shake" the phone for it to get into position. I just tried the calibration like Joe suggested, and it seems to be working much better now. I'll see how the rest of the day goes with it.
    (I've tried calibrating it a month ago for my GPS, so....it's probably user error on my part...lol):eek:
     
  10. RichardCranium

    Thread Starter
    35

    Nov 21, 2009
    18
    0
    35
    911
    919
    I did the calibration, and it worked much better for about 24 hours.....now its back to acting up again. :(
     
  11. tangomango

    tangomango Well-Known Member
    36

    Jan 30, 2010
    105
    2
    36
    Michigan
    exact same problem here, and I JUST got the phone like an hour ago in mail.

    It seems I have to shake it as well. I tried doing the spin fix but it doesn't seem to be working.

    I'm contemplating on returning it...
     

Share This Page

Loading...