1. Download our Official Android App: Forums for Android!

Root Is rooting possible on the Bell Mobility Vibrant?

Discussion in 'Android Devices' started by yakkamut, Aug 7, 2010.

  1. yakkamut

    yakkamut Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Aug 7, 2010

    Aug 7, 2010
    13
    2
    16
    Vancouver, Canada
    Hey everyone! I'm a proud owner of a Samsung Galaxy S, which was just released in Canada yesterday. It's my first smart phone and I must say I am loving it!

    I was wondering if any Canadian users on Bell Mobility have had any luck rooting their Vibrant. I have tried a couple methods out there, and to no avail. Holding down any combination of the buttons on a fresh restart won't open up the recovery mode screen at all!

    Thanks
     

    Advertisement

  2. GreatWhiteVibrant

    Rank:
    None
    Points:
    15
    Posts:
    13
    Joined:
    Aug 7, 2010

    Please message me with the answer you get when you find this out. My Vibrant is supposed to be shipped to me tomorrow (Didn't come friday, company doesn't ship on weekends) and I would love to know if I can root it as well.
     
  3. yakkamut

    yakkamut Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Aug 7, 2010

    Aug 7, 2010
    13
    2
    16
    Vancouver, Canada
    I went to my local Bell store today, and the rep told me that Bell is planning to upgrade to Froyo (2.2) in September, so I think I will wait until then before I try rooting my phone again.
     
  4. Vakman

    Vakman Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    120
    Joined:
    Apr 4, 2010

    Yes, it can be rooted.
    Thanks to jentech for changing the script to add the model number to the list and thanks to AllGamer for posting the tutorial over on XDA. Here is the tutorial.
     
    ABCDawg and yakkamut like this.
  5. yakkamut

    yakkamut Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Aug 7, 2010

    Aug 7, 2010
    13
    2
    16
    Vancouver, Canada
    Thanks for the link!

    I followed the instructions Allgamer posted and gave it the ol' college try, but I seem to be running into some problems.

    When I double click adb.exe, a prompt pops up really quickly and then disappears.

    I'm not quite sure how to run "adb devices", I can't seem to find anything like that in Android SDK.

    One thing I tried was using the method posted at:
    http://theunlockr.com/2010/08/02/how-to-root-the-samsung-vibrant-captivate/

    This at least gets me to the recovery screen.

    I then try using the update.zip file that jentech posted on the xda forums, but I get a message that says

    Phew. Good thing I don't back away from a challenge. :)
     
  6. Vakman

    Vakman Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    120
    Joined:
    Apr 4, 2010

    Uh, it sounds like you are doing the ADB commands incorrectly.
    You have the Android SDK in your C: right? Fire up CMD and type in cd C:\ and hit enter and then type cd C:\android(Or whatever you named your folder containing it)\tools and then hit enter.
    Then adb shell and hit enter.
    Then type adb devices and see if it is connected, it should be in fastboot mode while trying this.
    You do not just open up adb.exe
    His instructions assume you have the AndroidSDK setup already.
    The SDK you downloaded, put it into the root folder of your C: drive and name it android
    Then follow my instructions above.
    Also you may need an account on XDA to download the update.zip that was posted above.
     
    yakkamut likes this.
  7. yakkamut

    yakkamut Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Aug 7, 2010

    Aug 7, 2010
    13
    2
    16
    Vancouver, Canada
    Thank you for your patience Vakman. Your advice helped me out immensely.
     
  8. Vakman

    Vakman Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    120
    Joined:
    Apr 4, 2010

    Not a problem, everything worked fine now?
     
  9. yakkamut

    yakkamut Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Aug 7, 2010

    Aug 7, 2010
    13
    2
    16
    Vancouver, Canada
    Yes, I now have superuser permissions. Think I will play around by upgrading to 2.2 and installing some ROMs. :)
     
  10. GreatWhiteVibrant

    Rank:
    None
    Points:
    15
    Posts:
    13
    Joined:
    Aug 7, 2010

    Thanks a bunch Vakman! I'll try this in a few days, I'll post if i need help :D
     
  11. Vainglorious11

    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Aug 12, 2010

    Aug 12, 2010
    2
    0
    5
    I just rooted my i9000m last night. Restore mode worked with Vol Up + Power + Home - start with power off, hold until title screen comes up, goes blank and then appears again.

    To those who have done the same, what roms have you tried for the i9000m? Are regular i9000 roms fully compatible? Any recommendations?,
     
  12. yakkamut

    yakkamut Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Aug 7, 2010

    Aug 7, 2010
    13
    2
    16
    Vancouver, Canada
    After playing around with a rooted phone for the past week, I think that rooting it is fantastic.

    After reading and posting on this thread Bell phones and the lack of 3 button combo - xda-developers I think I should probably take my phone back.

    So, I have to unroot my phone first. I am having a world of trouble trying to do this. Does anyone have any pointers?

    When I try to unroot, it takes me to the recovery screen, but I do not have the "reinstall packages" as an option to highlight. My only options are:

    rebot system now
    apply sdcard:update.zip
    wipe data/factry reset
    wipe cache partition

    Am I doing something wrong? Should I attempt to re-root my phone first with the "One click Root" button, then unroot?

    Thanks!
     
    colin6187 likes this.
  13. colin6187

    colin6187 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Aug 27, 2010

    Aug 27, 2010
    1
    0
    5
    Hey Yakkamut,
    i am having the same problem about the error in the sd card update. zip and status 7.
    What did you do to fix the problem, ive tried a bunch of things but nothing seems to work?
    I really want to root it, so get back to me please :)

    Thanks!
     
  14. SamsungVibrant

    SamsungVibrant Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,613
    Joined:
    Jul 23, 2010

    Jul 23, 2010
    1,613
    165
    143
    oh wow, another carrier has the vibrant also? just curious, whats canada like? I feel like its so close but so far away.
     
  15. yakkamut

    yakkamut Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Aug 7, 2010

    Aug 7, 2010
    13
    2
    16
    Vancouver, Canada
    Hey Colin,

    I used adb to root my phone, just follow the advice in the above thread and it should be pretty self explanitory.

    I never figured out how to unroot my phone, but as far as I see it, there is no need to (unless you are bringing your phone back for warranty purposes). From what I have read, the Android 2.2 update that is officially coming out to the Bell i9000m in September will install without problems.

    Sorry I couldn't be more help. Good luck.
     
  16. melll

    melll Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    444
    Joined:
    Aug 21, 2010

    Aug 21, 2010
    444
    35
    43
    I do it all
    Toronto Ontario
    Why isnt everyone using the one click lag root app?

    Its fantastic.
     
  17. yakkamut

    yakkamut Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Aug 7, 2010

    Aug 7, 2010
    13
    2
    16
    Vancouver, Canada
    I can't speak on behalf of the entire country, but Vancouver is a really nice place to live. The weather is quite mild compared to the rest of the country. The winters usually don't get much colder than -5 Celsius, and the summers usually don't break the 30 degree mark. It rains. A lot. Summer is a fantastic time to visit.

    It is always in the top 10 for most livable cities in the world. World's most livable cities - Wikipedia, the free encyclopedia

    I think the best way to see what a place is like is to see it for yourself. If you ever have an opportunity to visit, you should come up here for a vacation.

    Hope I provided you with a little snapshot of Vancouver. :)
     
  18. krustypick

    krustypick Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Dec 15, 2010

    Dec 15, 2010
    3
    0
    5
    Just tried rooting my new Bell on Froyo 2 with 3e recovery screen and no dice.

    update fails signature verification.

    Any ideas?
     
  19. reminator

    reminator Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Dec 25, 2010

    Dec 25, 2010
    1
    0
    5
    Same bell phone sgt 9000m here, been trying all day: same results... very sad...

    is the update.zip file actually any good ?
    funny how i cannot manage to open it either from pc, or running phone ??

    ...duh...


    maybe we just need healty bell update.zip ?

    :cool:
     
  20. krustypick

    krustypick Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Dec 15, 2010

    Dec 15, 2010
    3
    0
    5
    I used SuperOneClick to root my phone. WORKED ! YEAH ! Now the problem is that it is locked. Emergency calls only and won't receive. Any ideas please.

    Rick ;-)
     
  21. vic_singh

    vic_singh Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jan 12, 2011

    Jan 12, 2011
    1
    0
    5
    I have downloaded and installed all the packages,

    now i just cant understand what to do.

    what program to run, when to plug in the phone, what to do with update.zip file and so on. I was a Pre owner and everything seems so much easier.

    a video would be great with instructions.

    please help me out Vakman.

    Thanks
     

Share This Page

Loading...