1. Download our Official Android App: Forums for Android!

Is there a way to turn on wifi, without the phone service on (ie airplane mode)

Discussion in 'Android Devices' started by drdms37, Feb 5, 2010.

  1. drdms37

    drdms37 Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    11
    Joined:
    Oct 29, 2009

    Oct 29, 2009
    11
    0
    15
    I am leaving the country and would like to be able to check my email using wifi, but want to prevent getting roaming charges incase the data/phone connection kicks on. I know that if you turn on airplane mode, it will not allow you to turn on wifi. Is there a way, or an app that will allow you to do this.

    Thanks
     

    Advertisement

  2. treborcj

    treborcj Android Enthusiast
    Rank:
    None
    Points:
    68
    Posts:
    646
    Joined:
    Dec 11, 2009

    Dec 11, 2009
    646
    33
    68
    I believe you just need to turn off mobile network. Airplane mode disables all wireless connections.
     
  3. cooolone2

    cooolone2 Android Enthusiast
    Rank:
    None
    Points:
    78
    Posts:
    737
    Joined:
    Nov 5, 2009

    Nov 5, 2009
    737
    65
    78
    New York
    Settings>Wireless> then turn off all you want, like Mobile Network, roaming, etc.

    I would suggest trying this prior to leaving the country to validate it works the way you want.

    Hope that answers your Q...

    :cool:
     
  4. armandov99

    armandov99 Well-Known Member
    Rank:
    None
    Points:
    16
    Posts:
    77
    Joined:
    Dec 17, 2009

    Dec 17, 2009
    77
    4
    16
    Los Angeles
    It seems to me like "Mobile Network" only turns off data, not the CDMA radio. I turn off mobile network and I lose the EVDO icon and I have no data, but I can still receive calls.

    If the OP wants to turn off the CDMA radio completely and have the phone function more as a pocket PC with just WiFi. I haven't figured out how to do this...
     
  5. treborcj

    treborcj Android Enthusiast
    Rank:
    None
    Points:
    68
    Posts:
    646
    Joined:
    Dec 11, 2009

    Dec 11, 2009
    646
    33
    68
    You are right, still getting calls. Go to menu > settings > Wireless controls> mobile network settings > mode of operation and change to EVDO-only. I did not get the call after that.
     
  6. drdms37

    drdms37 Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    11
    Joined:
    Oct 29, 2009

    Oct 29, 2009
    11
    0
    15
    Thanks, that works perfectly
     
  7. sprucebeach

    sprucebeach Member
    Rank:
    None
    Points:
    16
    Posts:
    73
    Joined:
    Nov 12, 2009

    Nov 12, 2009
    73
    1
    16
    As I understand it the user wants to use wi-fi at, say, an overseas wireless hotspot. Won't the solution above allow an EVDO connection which will incur data-roaming charges? Data roaming is only free in the U.S.
     
  8. oldjackbob

    oldjackbob Member
    Rank:
    None
    Points:
    18
    Posts:
    67
    Joined:
    Dec 26, 2009

    Dec 26, 2009
    67
    12
    18
    Download the Airplane Mode Wi-Fi app from the market. That will do what you need.
     
  9. treborcj

    treborcj Android Enthusiast
    Rank:
    None
    Points:
    68
    Posts:
    646
    Joined:
    Dec 11, 2009

    Dec 11, 2009
    646
    33
    68
  10. rdisanza

    rdisanza Member
    Rank:
    None
    Points:
    15
    Posts:
    52
    Joined:
    Jan 14, 2010

    Great APP, works perfectly on a Sprint Hero.
     
Tags:

Share This Page

Loading...