1. Check out our companion app, Forums for Android! Download from Google Play

Support Is this more than just a problem I can simply fix?

Discussion in 'Android Devices' started by JBones, Mar 13, 2012.

  1. JBones

    JBones New Member
    Thread Starter

    Mar 13, 2012
    My battery just now (about 2 days ago) started draining like crazy. I used to be able to take it off the charger at like 8 am and it would hold a charge until the next day at roughly noon (this is with Juice Defender, I've always had it). Until recently that's how it worked and just now it can't even hold a charge until 10pm that night. As well, I could plug a completely drained phone into my charger and have it fully charged in only a couple of hours and now, after a whole night and more of charging (roughly 10 hours), it can't even get past a charge of 70-75%. I tried taking the battery out and putting it back in to make sure it was connected well, and I always have auto-sync off. No apps run besides my txt messaging and calendar at any time. I'm not sure what's quite going on here or if maybe I need to go back into Verizon to get this fixed. Thanks for any help guys.



  2. txwolf1980

    txwolf1980 Well-Known Member

    Jun 2, 2011
    Wherever my 18 wheels take me
    I'd say there are a couple of possibilities here.
    1. Your battery stats have gotten corrupted. I'm guessing you aren't rooted, which would be the only way to fix that. But, if you are, and flashed a rom you need to wipe them.

    2. Your battery is going bad.

    What you can try to do, is let your battery drain until your phone dies, and charge it all the way up before you turn it back on. That may reset the stats.

    The other option is to take the phone to verizon and see if they will replace your battery, under warranty - if it's been less than a year, since you got the phone. If not, you may need to buy a new battery .

    As for it getting to 70-75% and stalling out, have you tried unplugging and plugging it back in? That is what is making me think you battery stats are corrupt.
    Hopefully, this helps.

Share This Page