1. Are you ready for the Galaxy S20? Here is everything we know so far!

Is USB Mass Storage Available rather than MTP

Discussion in 'Android Devices' started by crazybrit, Dec 5, 2013.

  1. crazybrit

    crazybrit Lurker
    Thread Starter

    So I went into T-Mobile to transfer over my AT&T Atrix 2 phone and the guy snapped off the sim contacts trying to install a SIM adapter. They ended up giving me a new LG Optimus F6.

    On my old Atrix2 I have the following three USB options: Mass Storage, MTP and PTP

    On the F6 I have 4 options; Charge Only, MTP, LG Software and PTP

    Is there any way to get the equivalent of the Atrix2 Mass Storage, which worked always.

    On the F6 I've tried the "LG Software" and "MTP". Right now it's setup as MTP. Every time I connect the phone to my Windows 7 (x86_64) machine the phone displays a USB status of "Connected as an installer", Windows opens a window to the autorun folder on the phone. Either it sits there for 30 seconds or I have to manually click on the drive letter at which point the phone switches to "Media Sync (MTP)".

    This is kind of annoying plus there is another problem, I can drag and drop files from the desktop to the phone via MTP but certain apps cannot save directly to the phone, error out. Also I get errors (device stopped responding) if I try to copy large amounts of files (music) over MTP to the phone.

    1. Download the Forums for Android™ app!


  2. Rukbat

    Rukbat Extreme Android User

    Microsoft decision, and a bad one IMO. There should be an "always do this" type of checkbox on the autorun menu. Check that before clicking on the phone's drive.

    Don't quote me on this one because I haven't analyzed Microsoft's USB firmware, but from similar situations and tests I've run, I'd say that's a failing of Windows. I've had it happen transferring files to/from a phone, an SD card, an external drive and a network, all via USB. Not too much in common there, except Windows and USB, so ...
  3. crazybrit

    crazybrit Lurker
    Thread Starter

    There is but this has no effect on the fact that the phone always displays "Connected as an installer".

    It always cycles through this first. The phone is first mapped to "CD Drive (H) LGE Mobile". You change the auto play so that it opens that folder but all this contains is the autorun files.

    Either once this times out or once you click on the "CD Drive (H) LGE Mobile" entry in the "Computer" view, H is unmounted and a "Portable Device" LG-D500 appears and the phone switches from "Connected as an installer" to "Media Sync (MTP)"

    Basically I'd like to bypass the stupid installer step.
  4. billigerent

    billigerent Lurker

    It will connect as installer always first to check your drivers. If you don't have "ask on connection" checked in your settings, it will remain in installer mode til you click on mtp, lg, or ptp after you plug in the usb. Still doesn't work, delete the drivers from windows and install fresh from lg. Still doesn't work, root the b#@ch and tell it what to do.

    Sorry, didn't realize the date of submission.
  5. mscheaf

    mscheaf Member

    Microsoft didn't remove the USB mass storage option from Android. My phone used to be able to be recognized by all computers and stereos. Now it is recognized by about 5% of them. It that Android's version of progress?
  6. hubsabubs

    hubsabubs Android Enthusiast

    From what I've read these are issues with Android 4.1-4.3 . Android 4.4 doesn't do this. My Android 4.2 tablet uses MTP, my wife's tablet that she just got has 4.4 and it mounts as mass storage. It's the way the system was written to read, write and manage storage.
  7. spicaalex

    spicaalex Member

    LOL it's device manufacturer's policy not the android! if LG makes a phone w/out mass storage function, I doubt it will suddenly appear after applying KK update...;)

    EDIT: updated my SGE2 from 4.2.2 to 4.4.2, NO MASS STORAGE FUNCTION appeared!;)
    for samsung phones there are app on gplay to use phone as mass storage. however it's so f**kin' buggy that's almost screwed up my phone (not completely of course, but i needed to reset phone then!!:mad:)
  8. dewcansam

    dewcansam Lurker

    ECHO... Yes this is NOT a Microsoft, Windows X, Android, or even a carrier (MetroPCS) issue. The fault strictly falls upon LG.

    Also, the key clue here is the 3rd option on the USB connection list. It states, "LG Software / Connect to PC software for LG mobile." And since you were able to view the autorun directory, you should have been able to see the "config.ini" file. From there we can see that the first thing it does is install "tools\LGUnitedMobileDriver_S4981MAN38AP22_ML_WHQL_Ver_3.8.1.msi". Then downloads the pc software "pcsuite_download_url = \LGPCSuite\Autorun\LGPCSuite_Setup.exe". Then checks if you are using XP and if so downloads a Windows Media Player update. Checking all this leads to the possibility that there is NO way to mount a drive letter using USB. HOWEVER...

    Now, just by chance I stumbled upon an ugly way to connect the computer / phone and mount as a drive letter. Go to 'Settings' >> 'Share & Connect' >> 'File networking'. And check off 'Share my folder'. Then using Windows Explorer go to "\\" (where is the ip address of the phone) or you can try "\\LGMS500". Now I have my network setup differently so in order for me to use "\\LGMS500", I first have to use the ip address. Then just map a drive letter to "\\LGMS500\LG-NetworkFolder".

    scripting command
    net use p: \\LGMS500\LG-NetworkFolder
    net use p: \\LGMS500\LG-NetworkFolder mypassword /user:LGMS500
  9. igemini

    igemini Lurker


LG Optimus F6 Forum

The LG Optimus F6 release date was September 2013. Features and Specs include a 4.5" inch screen, 5MP camera, 1GB RAM, Snapdragon 400 processor, and 2460mAh battery.

September 2013
Release Date

Share This Page