1. Check out our companion app, Forums for Android! Download from Google Play

Is Your Stock Internet Browser Working?

Discussion in 'Android Devices' started by LisaFitz, Jul 7, 2010.

?

Is Your Stock Evo Browser Working For You?!?

  1. Yes - no problems to report

    32 vote(s)
    69.6%
  2. No - Its having major issues lately

    7 vote(s)
    15.2%
  3. Stock Browser - Who uses that? (Dolphin, Opera, Skyfire etc. user instead)

    7 vote(s)
    15.2%
  1. LisaFitz

    LisaFitz Well-Known Member
    Thread Starter
    58

    Apr 11, 2010
    167
    13
    58
    Teacher
    NY
    I have noticed more and more users complaining about this "slow" or "page only loading half way than stopping" issues with the stock browser.

    Seems only with the stock browser as I am now using Dolphin HD and its amazingly fast -
     

    Advertisement

  2. Droidone

    Droidone Well-Known Member
    93

    Dec 12, 2009
    595
    118
    93
    This is an issue that I have from time to time. I notice it the most after the phone has sat for a few hours, especially over night. I have noted it on a couple other threads. I notice more and more people starting to have the same problem.
     
  3. RedWingsFan

    RedWingsFan Well-Known Member
    68

    May 10, 2010
    365
    108
    68
    I think I used the stock browser for a few minutes after receiving my EVO. NOw its 100% Dolphin.
     
  4. whtge8

    whtge8 Well-Known Member
    38

    Jun 8, 2010
    137
    11
    38
    As per my earlier thread I am having a problem loading sometimes. The green bar gets stuck halfway and I cant stop the loading process even though it says 'Stopping'. Then it wont let me do anything on that webpage. Hoping this is a common problem so we can get a fix for it.

    I think ill try Dolphin but the reviews for it on the market are not that great.
     
  5. Droidone

    Droidone Well-Known Member
    93

    Dec 12, 2009
    595
    118
    93
    I am trying out dolphin to see if that helps. I have always found it to he slow though. I do like the additions to dolphin since the last time I used it. If the problem goes away then I will assume its a bug in the evo's browser.
     
  6. doriansoto

    doriansoto Member
    16

    Jun 22, 2010
    12
    1
    16
    I am having the same issue with 2 evos. Mine and my gf's. But its not only with the stock browser its with all that I try. Pages won't load and my gf has experienced problems with using the mobile facebook site. Last night I factory reset my phone and it has been working flawlessly...
     
  7. Droidone

    Droidone Well-Known Member
    93

    Dec 12, 2009
    595
    118
    93
    A hard reset is my next step.
     
  8. Kickstand

    Kickstand Member
    36

    Jun 9, 2010
    17
    3
    36
    Torrance ca.
  9. doriansoto

    doriansoto Member
    16

    Jun 22, 2010
    12
    1
    16
    Dolphin skyfire and stock have all given me problems :/
     
  10. dr g

    dr g Well-Known Member
    93

    Jun 7, 2010
    589
    187
    93
    No problems with stock browser. Did you turn off always-on network?
     
  11. WaSTeLaNd

    WaSTeLaNd Well-Known Member
    73

    May 12, 2010
    415
    98
    73
    welder lvl 1
    rosenberg tx
    Mine acts stupid all the time but I hate dolphin browser and skyline there fast but to much going on I like things simple so i just deal with it, also if u put the mobile shortcut on your screen switching it off and on helps
     
  12. Khaelum

    Khaelum Active Member
    16

    Jun 26, 2010
    27
    1
    16
    Law enforcement
    Virginia
    I loved Dolphin at first, but it seemed to really slow down after a while and began taking way too long to resize the text of sites and fit them to my screen. Loved it up until this point. Went straight back to the stock browser which seems MUCH faster.

    Sent from my HTC Evo using Tapatalk + Swype
     
  13. Droidone

    Droidone Well-Known Member
    93

    Dec 12, 2009
    595
    118
    93
    Well I'll be the first to admit when I'm wrong. I have been test driving dolphin HD heavily for the last couple hours and it is working out great. I think I will make it my default. I am not having any issues like I had with the stock browser. I notice once pages are in the cache, the pages load very fast and I also moved my cache to SD to save space. My browser lag when typing in forums is gone too. The new improvements are very impressive. Keep in mind, I am using dolphin HD
     
  14. someguy45

    someguy45 Member
    35

    Jun 30, 2010
    14
    0
    35
    Stock browser works great for me. Super fast, faster than dolphin and I like thumbnail bookmarks.
     
  15. pwnst*r

    pwnst*r Well-Known Member
    113

    Jun 4, 2010
    912
    206
    113
    Just curious here...how would that resolve the issue?
     
  16. IT-Monkey-Dave

    IT-Monkey-Dave New Member
    5

    Jul 7, 2010
    1
    0
    5
    I've had my Evo for 1 day. Previously had an iPhone 3G for almost 2 years. So far my user experience with the Evo is a series of "WTF" moments. The latest is the broken native browser, which is behaving as described above in this thread. "Oh, don't use the native browser, it's broken". Also discovered that the native Sprint Navigation app is "unapproved".

    This phone is going to be an unnerving experience for iPhone converts.
     
  17. myriam

    myriam Well-Known Member
    16

    May 17, 2010
    63
    7
    16
    Census worker while lasts
    Austin, Texas
    I don't have problems loading pages, but when I go to New York Times only gives me the mobile version. I go to the settings and uncheck mobile version but it doesn't work. I'm also having problems with Skyfire not showing flash content. What's going on?
     
  18. pwnst*r

    pwnst*r Well-Known Member
    113

    Jun 4, 2010
    912
    206
    113
    I've had both the 3G and Evo since their respective launch days and have easily transitioned from one to another.
     
  19. QuickDraw

    QuickDraw Well-Known Member
    43

    Jun 12, 2010
    328
    29
    43
    Disabled Veteran - USMC
    No problems here, but I still went with Dolphin HD. It's just a better experience.
     
  20. finndo77

    finndo77 Well-Known Member
    103

    Jun 1, 2010
    860
    107
    103
    Male
    Unix/VMware admin
    Richmond, VA
    I've been using xScope, I love it, and it is very fast. does either dolphin or the stock browser use flash lite? if so do you have any sites that I could test xScope on? I have not been to a website that I know uses flash without getting the "you need flash" message. It looks like google chrome, and may also use the same engine for page rendering. I do not think I have even used the stock browser once.
     
Tags:

Share This Page

Loading...