1. Are you ready for the Galaxy S20? Here is everything we know so far!

Issue installing .apk files

Discussion in 'Android Devices' started by tcallahan, Nov 1, 2010.

  1. tcallahan

    tcallahan Well-Known Member
    Thread Starter

    Hey Guys,

    I have a question or more of a problem and need a fix.

    im rooted running 2.2 leak.

    everything works fine besides when i go to install an apk that i download from the phone.

    For example: if someone posted an .apk file for some app in this forum and i dl'ed it from my phone when i open it it does not give me the option to run package installer or w.e its called. It just has gba emu gensoid emu and androzip.

    Now i do have it checked to allow non market apps to be installed and there is no default set.

    It happens with any .apk not just one.

    If you guys have any idea what could be causing this that would be great!!

    Its pretty annoying.

    edit** there is no app protector or anything like that on the phone. so no apps should be blocking me from using the package installer. but that is definitely whats happening, just not sure how to fix it.


    1. Download the Forums for Android™ app!


  2. scary alien

    scary alien not really so scary
    VIP Member


    Is the .apk file actually downloading? I have trouble downloading and installing .apk files using the stock browser. The download appears to work, but when I pull-down the download notification, I see a pop-up seeing "Download unsuccessful: Cannot download. The content is not supported on this phone."

    I have no trouble using Opera Mini in downloading these files and then selecting the downloaded .apk files using Astro File Manager.

    Hope this helps.
  3. dhoffman1421

    dhoffman1421 Android Enthusiast

    I had this happen when I tried to DL 928 Black Glass to my phone directly. I ended up using my PC to move manually to the DX. It might be the stock Browser and IIRC there was a setting to change that allowed it. Somewhere...
  4. scary alien

    scary alien not really so scary
    VIP Member

    Lol, I thought so too! But, I've lost that memory and can't find it again :p.

    I've also scanned through the stock browser settings and can't find anything obvious...

    I'd love to find out the solution to "Download unsuccessful: Cannot download. The content is not supported on this phone." issue...I haven't been able to find anything with a Google search either...
  5. skyhigh

    skyhigh Newbie

    I have also seen this problem when attempting to download an apk file and having the Android file download fail with a status:

    Download unsuccessful
    Cannot download. The content is not supported on this phone.

    I am running unmodified Android 2.2 (Froyo) on a Motorola Droid and using the default Android browser to initiate the download.

    I did some experimenting downloading the very same apk file from two different web sites. From one site the apk file downloaded and installed successfully and from the other site the Android download manager is showing the "content is not supported on this phone" error.

    I took a Wire Shark packet capture to look at what is getting downloaded from the two sites. Almost everything is identical. There are a few minor HTTP reply header differences. The two main HTTP reply headers which are different and which may be related to this issue are:

    Working one does not have a "Content-Disposition" header

    Failing one has:
    Content-Disposition: attachment; filename="BookPlayerPersonal_apk.apk

    Working one has:
    Content-Type: text/plain

    Failing one has:
    Content-Type: application/octet-stream

    The downloaded data appeared to be identical after the HTTP reply headers for as far as I bothered to manually compare the bytes.

    I am thinking that the Android download manager must be responding badly to one of these HTTP reply header differences. I would appreciate any insights that others might have regarding this download problem.
  6. skyhigh

    skyhigh Newbie

    I have determined that this issue with the Android download manager only exists in Android 2.2 (Froyo). When using previous Android versions such as 1.6 or 2.1-update1 the download manager will download and install the apk file just fine from both of the web sites.

    There appears to be a change which Google introduced in Android 2.2 (Froyo) which is causing it to refuse to download and install the apk file. Apparently in 2.2 the problem is triggered by the differences in these HTTP reply headers which are returned from the web site.
    Netherlords likes this.
  7. scary alien

    scary alien not really so scary
    VIP Member


    Thank you for continuing to research this...great job in doing the Wire Shark capture--very good idea.

    Maybe this will be fixed in an upcoming OTA update...

  8. G.Armour

    G.Armour You know you want to.

    I'm having problems with mine downloading altogether, it'll just hang at 0%. If I reboot anf retry the download, everything works fine.
  9. skyhigh

    skyhigh Newbie

    I reported this issue on the web site where the download was failing, and they have modified the server to no longer return a Content-Disposition header as part of the HTTP response headers returned with the download.

    The .apk file now downloads and installs just fine using the default Android 2.2 browser. This definitely confirms that the problem introduced in Android 2.2 causes downloads to fail if the web server returns a Content-Disposition header.
    bladebarrier and scary alien like this.
  10. DoubleEagle

    DoubleEagle Well-Known Member

    well i had the same problem downloading 928 blackglass, there not much discussion on it but I stumbled across somewhere here or another forum about downloading astro manager. Then open astro manager, hit the menu hard key,hit more button lower right corner,then hit preferences,scroll down to enable browser download and check it. Back all the way out and then try downloading just like you would from browser, it worked for me! Then after I downloaded 928 I just went back and unchecked it, really don't know why just did.
    scary alien likes this.
  11. scary alien

    scary alien not really so scary
    VIP Member

    Very interesting! Never saw that option before (maybe the good folks that made Astro saw an opportunity to help us poor folks out ;)).

    Anyway, when selecting the "Enable Browser Download" (Allow the Web Browser to download any type of file.), you'll get a pop-up that says "Notice: This feature will interfere with viewing attachments in Google mail. Please disable the Downloader before you view attachments in Gmail.".

    No biggie...easy to turn this on and back off. :D

    Still, looks pretty-much like this will solve the browser download issue.

    Thank you very much! :)
    DoubleEagle likes this.
  12. DoubleEagle

    DoubleEagle Well-Known Member

    Thanks scary alien, I just try to pass on what I'm still learning!

Motorola Droid X Forum

The Motorola Droid X release date was July 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 512GB RAM, TI OMAP3630 processor, and 1540mAh battery.

July 2010
Release Date

Share This Page