1. Download our Official Android App: Forums for Android!

Support Issue with Predictive Text & Samsung Keyboard

Discussion in 'Android Devices' started by jfich, Jul 6, 2013.

  1. jfich

    jfich Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Jul 6, 2013

    Jul 6, 2013
    5
    1
    5
    Hello,

    I've had the S4 for about a month now and it was all working out great until Thursday... Not sure what happened there but I was very happy with the Samsung keyboard and the predictive text and all of a sudden all the words I type on a daily basis (names, etc...) that were not originally in the dictionary simply disappeared...

    I haven't installed any other keyboard app and I don't believe I downloaded or deleted an app around the time that happened.
    Even right now it still does not remember the text I type in anymore (or just for a couple minutes sometimes).

    Predictive text is still set to "ON" and I haven't changed the language or anything...

    Any help appreciated. Thx!

     

    Advertisement

    CDMA LTE likes this.
  2. CaptainGG

    CaptainGG Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Jul 10, 2013

    Jul 10, 2013
    3
    0
    5
    Same EXACT problem. Please guys, this needs to be fixed! My device used to remember ALL of my personalized words, like "lolololol" "rofl" "lmfao" "btw" <names> etc etc etc and now NOTHING. What has happened???????
     
  3. jfich

    jfich Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Jul 6, 2013

    Jul 6, 2013
    5
    1
    5
    Anyone else with the same issue?
    Anyone else that can help?

    Not sure if relevant but I have the Sprint version.
     
  4. CaptainGG

    CaptainGG Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Jul 10, 2013

    Jul 10, 2013
    3
    0
    5
    Bump. Mine is getting progressively more ******ed. Replacing normal words with ridiculous alternatives.

    I tried to delete all the learned words I knew it was messing up and then re adding them by typing them and then selecting them from the suggested words bar but that didn't work either.


    PLEASE HELP
     
  5. hbryder

    hbryder Android Enthusiast
    Rank:
    None
    Points:
    53
    Posts:
    405
    Joined:
    Aug 7, 2012

    Aug 7, 2012
    405
    64
    53
    Best free suggestion: Google Keyboard
    Best paid suggestion: Swiftkey

    Samsungs keyboards are not so great imo.

    Good luck :)
     
  6. CaptainGG

    CaptainGG Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Jul 10, 2013

    Jul 10, 2013
    3
    0
    5
    Just downloaded the Google keyboard. It's much better in terms of the autocorrect problem but it's ugly as hell and not as functional as the gs4 keyboard (e.g. the Samsung keyboard has the numbers always at the top of the keyboard, no need to press shift.
    SAMSUNG KEYBOARD FIX PLEASE
     
  7. jfich

    jfich Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Jul 6, 2013

    Jul 6, 2013
    5
    1
    5
    Thanks for the suggestions
    I tried the Google keyboard and agree it's ugly as hell

    I might end up buying swiftkey but I actually really liked the samsung keyboard...
     
  8. mgadbois87

    mgadbois87 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Jun 9, 2013

    Jun 9, 2013
    2
    0
    5
    Same exact problem, email address removed from known words and now common words being replaced with nonsense
     
  9. jfich

    jfich Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Jul 6, 2013

    Jul 6, 2013
    5
    1
    5
    When did it start happening to you guys?
     
  10. tytlyf

    tytlyf Member
    Rank:
    None
    Points:
    16
    Posts:
    72
    Joined:
    Jun 20, 2013

    Jun 20, 2013
    72
    3
    16
    Just use the Kii keyboard app. Free and does what you want.
     
  11. jfich

    jfich Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Jul 6, 2013

    Jul 6, 2013
    5
    1
    5
    Nice gonna try it looks good
     
  12. romythagirl

    romythagirl Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Sep 15, 2013

    Sep 15, 2013
    1
    0
    5
    This started happening with my keyboard (Samsung) in July. Just stopped recognizing my kids names, regular words I use every day and stopped remembering my email which was my favorite thing. My email is miamivirgo.....as soon as I'd hit the "v" my whole email would pop up. Now all that pops up is nonsense words such as Miami veggie blah blah. Went from smart ass keyboard to duh
     
  13. sarathx4

    sarathx4 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Dec 9, 2013

    Dec 9, 2013
    1
    0
    5
    Hi, my s4 had the same issue, even though the predictive text btn is on, it still not working.. So I turn it off and restart phone.. And then on it back.. voila it works.. I encounter this issue after recent update from samsung.
     
  14. DrOctagon

    DrOctagon Newbie
    Rank:
    None
    Points:
    15
    Posts:
    10
    Joined:
    Jan 11, 2012

    Jan 11, 2012
    10
    0
    15
    I posted about this a few months ago. Never got any good info on it. I just switched to the Swype keyboard, which is better... but I miss the layout on the Samsung one. Seems some update happened and destroyed its functionality.
     
  15. Uniqua

    Uniqua Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Feb 15, 2014

    Feb 15, 2014
    1
    0
    5
    I saw someone else posted this in another thread so I thought I would share... since it worked for me.

    The user wrote:

    Hi I don't know if you figured it out yet but I was having the same issue. I like my Samsung keyboard but it wasn't saving words. Just reset it. Go into settings, language input, click the settings cog by Samsung keyboard and down at the bottom is a reset. Click that and it will start to save your words again. Hope this helps.
     
  16. afaqhaider

    afaqhaider Lurker
    Rank:
    None
    Points:
    6
    Posts:
    2
    Joined:
    Feb 19, 2014

    Feb 19, 2014
    2
    1
    6
    hi,

    I am having the same problem, this problem started like 4 to 5 days ago.

    i have just contacted the Samsung Support, i supplied him with following query,

    i am using GT-i9505, and having problem with Samsung Keyboard, Specially Personalized Text, don't remember words,

    he did his best resolving the issue, by following steps, (performed through Samsung Tutor) must have the predictive text option on, through Language and input settings, also the Personalized text must be active.

    1. he go to settings, More>Application Manager>(Tab) All> selected Messages> and cleared the data by clicking on Clear Data,
    2. Clicked on "More" button, (left touch key beside Home Button") and selected Clear App Preferences.
    3. asked me to restart the phone, by shutting down and Removing the battery.
    4. restarted, tested, worked.

    but as soon as he left, again doomed :( i tried the word "Asalam o Alaikum" he told me you will have to retype and save the words again, so, at first it was working, i would only write "asa" a suggestion will appear as Asalam, i press o then Alaikum would automatically appear.

    but its not working again.

    i suppose i need to reset the phone, but i think it can be worked out as,

    Settings>application Manager>all (Tab) select Samsung Keyboard> clear Data, (mine was 49 mb) think its working for me as of now.
     
  17. afaqhaider

    afaqhaider Lurker
    Rank:
    None
    Points:
    6
    Posts:
    2
    Joined:
    Feb 19, 2014

    Feb 19, 2014
    2
    1
    6
    Settings>Application Manager> All(Tab)>Samsung Keyboard>Clear Data> Restart Phone (by shutting down> removing battery, inserting battery, Power on)

    But please note, you will have to resave all personalized data, other settings should be to your convenience,
    Mine are,
    Settings,>More(Tab)>language and input>Keyboard Samsung>
    Language >English US
    Predictive Text >on
    Auto replacement> off
    Auto Capitalization> on
    Auto Spacing> on
    Auto Punctuate> on

    Keyboard Swipe None
    Sound>off
    vibrate>off
    Character Previw> on
     
    shettysatishs likes this.
  18. DaveGerard

    DaveGerard Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Mar 13, 2014

    Mar 13, 2014
    2
    0
    5
    The process suggested by sarathx4 worked for me (for now).

    Steps I used...
    1) Go to Settings/My Device/Language and input/Samsung keyboard (settings)
    2) Turn off Predictive text
    3) Restart Phone
    4) Return to Samsung keyboard settings
    5) Turn on Predictive text.

    I would like to add that this was the most frustrating thing for me for the last week. Learned words (email addresses, usernames, etc.) just suddenly stopped working. I almost wanted to buy an iPhone (Grrrrr) just to spite 'em...whoever 'em are.

    It would be nice if the Samsung keyboard actually used a database that could have words manually added to it.
     
  19. avenue j

    avenue j Lurker
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Jul 24, 2011

    Jul 24, 2011
    6
    0
    5
    Female
    Tried all those steps. None of it worked. Any other ideas?
     
  20. jj86gmc

    jj86gmc Lurker
    Rank:
    None
    Points:
    15
    Posts:
    6
    Joined:
    Aug 31, 2013

    Aug 31, 2013
    6
    0
    15
    Male
    My GS4 just started messing up when texting. I haven't changed anything or downloaded anything and when I picked up my phone to text it started typing different letters but only on landscape mode. When I text with my phone straight up it works fine. Any help will be greatly appreciated.
     
  21. rache6987

    rache6987 Lurker
    Rank:
    None
    Points:
    15
    Posts:
    1
    Joined:
    May 6, 2014

    May 6, 2014
    1
    0
    15
    I had that same problem, finally figured it out last night! Go to Settings> my device> language and input. Click the settings symbol to the left of Samsung Keyboard. Click on the words Predictive Text. This will bring up a new menu. Clear remote data and personal data, then hit the buttons to learn from contacts, messages, etc. This worked perfectly for me, I hope it helps you too!!
     
  22. shettysatishs

    shettysatishs Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jun 16, 2014

    Jun 16, 2014
    1
    0
    5
    this worked perfectly fine.. for me. thanks @afaqhaider
     
  23. Krishna Ganesh

    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Jun 16, 2014

    Jun 16, 2014
    2
    0
    5
    Even I have the Same problem whenever "i" the letter is the it is replaced by my email so I turned off predictive text.
    When it was on I got a white bar on top of keyboard
     
  24. Krishna Ganesh

    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Jun 16, 2014

    Jun 16, 2014
    2
    0
    5
    same here... It started to replace I with my email address... Had to download swiftkey and agreed why its the best keyboard in the android world
     
  25. farahinn

    farahinn Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Aug 23, 2014

    Aug 23, 2014
    1
    0
    5
    Hi ii I just solved my predictive text problem. The solution was so simple. You guys can simply go to SETTING>PERSOANAL> LANGUAGE AND INPUT. Under KEYBOARDS AND INPUT METHOD click SETTING ICON beside SAMSUNG KEYBOARD and under SMART TYPING, SELECT your PREDICTIVE TEXT on! Solved!:)
     

Share This Page

Loading...