1. Are you ready for the Galaxy S20? Here is everything we know so far!

Issues downloading updates from Market

Discussion in 'Android Devices' started by thegadgetguroo, Feb 5, 2011.

  1. thegadgetguroo

    Thread Starter

    Within the past few days I have noticed that a few of my apps have been getting download errors and the updates will not install. I have tried rebooting the phone and my updates still will not install. Phone issue(droid x) or market issue???By the way this problem only seem to currently appear on a few apps not all the apps that require an update.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Doit2it

    Doit2it Android Expert

    This is apparently an ongoing issue due to the creation of the web based Market this week. I had issues the other day where an app would say it was downloading in the notification bar, then just disappear.
    This morning I tried to update Angry Birds, and it downloaded fine, but hung on the installing phase. I just tried again, and when I get to the "Replace application" popup in the market, when I click OK, nothing happens.
    Hopefully, they will get the bugs worked out soon. It's getting frustrating.

    Update: Just tried downloading a new app, and when I pressed OK in the Market, nothing would happen. Rebooted phone and download of new app was successful.
    Tried to update Angry Birds again but got an Update unsuccessful message...Installation error...Unknown reason -18. Whatever that means.
     
    thegadgetguroo likes this.
  3. Shamrock13

    Shamrock13 Android Enthusiast

    Same thing happened to me with Angry Birds this exact morning as well!
     
  4. thegadgetguroo

    Thread Starter

    Samehere with Angry Birds, Soundhound and a few others. Hope it gets resolved soon.
     
  5. GoNe2heLL

    GoNe2heLL Member

    Been happening to me for the last few weeks, I got about 20 application that can't update I always get the unknown reason - 18 message. I'm rooted and still running 2.3. 9.
     
  6. rmrlc

    rmrlc Member

    The solution: move all the apps back to phone, put your microSD into a card reader and delete .android_secure folder. That's it! [​IMG]
     
    GoNe2heLL likes this.
  7. cultldr

    cultldr Android Enthusiast

    From Fab's site:

    How to Fix Market Error -18 | FabDroid
     
    SLR 722, Doit2it and GoNe2heLL like this.
  8. GoNe2heLL

    GoNe2heLL Member

    did the "fix' last night updated few apps w/ out any problems, haven't tried the others yet
     
  9. Doit2it

    Doit2it Android Expert

    THANK YOU VERY MUCH!

    They might also add to reboot before trying to download.

    First try:
    Plug in USB
    Delete folder from Windows Explorer
    Unplug USB
    Open Market
    Stuck on installing
    Reboot
    Open Market
    Install unsuccessful

    Second try:
    Plug in USB
    Delete folder from Windows Explorer
    Unplug USB
    Reboot
    Open Market
    Success!

    Thanks again!
     
  10. thegadgetguroo

    Thread Starter

    Why do we have to go through all of this to correct an error that should not be happening in the first place? Also can you move those apps back to the SD card after the fix?? It seems to me that there should be an update of some kind to address this issue.
     
  11. thegadgetguroo

    Thread Starter

    :mad
     
  12. Doit2it

    Doit2it Android Expert

    Unfortunately, it's probably Android's ability to multitask, task swap, run widgets, run background apps, etc that create these errors on occasion. You could get a phone that's locked down and stringently controlled. You'd have less problems, but you'd have an iPhone. I'll stick with the versatility, customization, and the occasional problem, than have a phone that someone else tells me what I can and can't do with it.

    Besides, we've got this GREAT forum to get answers and share what we love about the Android platform. That and have the occasional rant. Mine's over now.
     
  13. thegadgetguroo

    Thread Starter

    I guess you make a good point. I'm better know...lol.
     
  14. almahix

    almahix Android Enthusiast

    I have had the unsuccessful install problem on all updates from the market. I have to delete the app then install it again. Really annoying!
     
  15. Doit2it

    Doit2it Android Expert

    No, the article doesn't say uninstall the app, just move any app you have on the SD card (probably the ones you are having trouble updating) to the phone, delete the folder (.android_secure) from the SD card, reboot, then update from the market.
    It worked for me.
    I only had the Angry Bird apps on my SD cause they default to install there.

    This is more and more sounding like a glitch in Google's implementation of the Apps2SD feature. Hopefully it will be fixed in the future. But with the abundant internal storage built into the newer phones (8Gb on the Droid X) Apps2SD isn't needed anymore.
     
  16. Hoya94

    Hoya94 Newbie

    I tried checking the article but it is no longer there. I did do what you guys suggested in this thread but I still can't get apps form the market or updates to angry birds and aldiko. Help!

    Hoya
     
  17. thegadgetguroo

    Thread Starter

    Remove your SD card from your phone and mount it in your computer. Look for folder .android_secured and open folder. Scroll down until you find file smdl2tmp1.asec. delete file and reinstall card to phone. You should be okay after that.
     

Motorola Droid X Forum

The Motorola Droid X release date was July 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 512GB RAM, TI OMAP3630 processor, and 1540mAh battery.

July 2010
Release Date
0
Reviews
Loading...

Share This Page

Loading...