1. Download our Official Android App: Forums for Android!

Support Issues Powering On The Epic 4G

Discussion in 'Android Devices' started by PersonalJournals, Dec 30, 2013.

  1. PersonalJournals

    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Dec 30, 2013

    Dec 30, 2013
    3
    0
    5
    Hey all, I attempted to start up my phone today and the blue light flashed (as it does), the logo appeared, but then the logo disappeared and the blue light flashed again while the phone turned itself off. I can't turn the phone on at all. Highly frustrating.
     

    Advertisement

  2. DragonSlayer95

    DragonSlayer95 Resident Air Bender
    Rank:
     #32
    Points:
    653
    Posts:
    8,779
    Joined:
    Mar 9, 2012

    Mar 9, 2012
    8,779
    3,758
    653
    Male
    Reno, Nevada
    Have you thought to leave the phone plugged in for a bit before attempting to power it back on?
     
  3. PersonalJournals

    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Dec 30, 2013

    Dec 30, 2013
    3
    0
    5
    I have done that, it was at 100% when I tried.
     
  4. PersonalJournals

    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Dec 30, 2013

    Dec 30, 2013
    3
    0
    5
    Bump for desperation?
     
  5. beledi

    beledi Well-Known Member
    Rank:
    None
    Points:
    58
    Posts:
    124
    Joined:
    Jan 5, 2011

    Jan 5, 2011
    124
    11
    58
    try taking out battery a minute and put back in. Maybe that will help.
     

Share This Page

Loading...