1. Check out our companion app, Forums for Android! Download from Google Play

Support Issues? S4 Out Of The Box

Discussion in 'Android Devices' started by Caller1982, Jun 5, 2013.

  1. Caller1982

    Caller1982 New Member
    Thread Starter
    5

    Jun 5, 2013
    2
    0
    5
    Hi there, I am new to Android (having come from 4 years of the iPhone) ... and just received my Galaxy S4 phone today. However I am having some issues so I was hoping to get some help prior to taking it back to the store (if necessary)

    As per the instructions I added the sim card and the battery, and then plugged in the phone to the jack.

    When I press the Home button the phone makes several beeping sounds and the Menu and Back buttons light up, but the screen remains dark. I have tried a few things but am at a loss to turn on the phone.

    Any suggestions?
    Thanks
     

    Advertisement

  2. Caller1982

    Caller1982 New Member
    Thread Starter
    5

    Jun 5, 2013
    2
    0
    5
    Never mind, I reinstalled the battery and it seems to have worked ...
     
  3. dontpanicbobby

    dontpanicbobby Well-Known Member
    713

    Dec 31, 2011
    7,382
    4,037
    713
    Male
    Boston MA USA
    Welcome to the forums Caller1982. Your phone was just getting it's little brain together for the first use. Depending on your battery level that first start up can take a little while. The only time you may experience that again is if you do a full power off then turn your phone back on. With normal use just hitting the power button will turn it on right away.
     
  4. DragonSlayer95

    DragonSlayer95 Resident Air Bender
    653

    Mar 9, 2012
    8,764
    3,729
    653
    Male
    Shreveport, Louisiana
    Welcome to the forums!

    Glad you already got your problem sorted out, moved into the galaxy s4 forums.
     

Share This Page

Loading...