1. Are you ready for the Galaxy S20? Here is everything we know so far!

issues with unlocking

Discussion in 'Android Devices' started by rafalo, Jun 16, 2013.

  1. rafalo

    rafalo Lurker
    Thread Starter


    I tried many times to unlock a htc wildfire with hboot 1.02.0002 from my macbook pro.

    I downloaded fastboot and adb and ran the commands "adb devices", etc...

    when I run "fastboot oem unlock" or "fastboot get_identifier_token" I get the message "command error", and nothing happens.

    I tried different cables, different usb ports, different fastboot binaries, and i even tried a "fastboot-mac" originally developped by htcdev, but nothing works.

    I also mention that unrevoked does not work because "my firmware is too new".

    If you have any idea your help will be appreciated.

    1. Download the Forums for Android™ app!


  2. scary alien

    scary alien not really so scary
    VIP Member

    Welcome to the AndroidForums, rafalo! :)

    I've moved your post over over to the all-things-root area for the HTC Wildfire where hopefully someone will have a quick answer for you.

    By the way, I'm wondering if the "command error" indicates that you don't have the directory path that the fastboot command lives in in your PATH variable for the shell to auto-find it. Perhaps using the ". ./fastboot" syntax in place of the "fastboot" portion of your command might help (that's assuming that your currently in the same local directory that you are cd'd into). [full disclosure: I don't have an HTC Wildfire or use a Mac, so I only suggested the above based on my experience with Linux].

    Cheers and best of luck to you!

  3. ChryzaorFlux

    ChryzaorFlux Android Enthusiast

    That just means you are running a version of android incompatible with unrevoked. You have to downgrade your ROM using an RUU to android 2.1 (eclair) then use unrevoked

HTC Wildfire Forum

The HTC Wildfire release date was May 2010. Features and Specs include a 3.2" inch screen, 5MP camera, 384GB RAM, Snapdragon S1 processor, and 1300mAh battery.

May 2010
Release Date

Share This Page