1. Are you ready for the Galaxy S20? Here is everything we know so far!

Issues with updating radio and recovery mode?

Discussion in 'Android Devices' started by digger, Apr 22, 2010.

  1. digger

    digger Newbie
    Thread Starter

    Hi all,

    I'm currently trying to flash my phone to the Android 2.1 ROM in this thread, but am stuck on updating the radio (one of the prerequisites of the howto is having the latest radio firmware).

    I've followed this guide to root the phone (successfully!), however the last step is updating the radio. I've downloaded the latest radio img file and renamed it to update.zip, but when I reboot (holding down the back key) I don't get an option to install this file (I get the three little skater dudes, and press vol-down for HBOOT mode etc). How do I force this to come up?

    As a side issue, I also don't appear to have a recovery mode any more? If I reboot recovery, my phone hangs on the Hero logo and goes no further (I've waited approx 15 mins for it to boot). How can I recreate my recovery profile?

    Thanks for any help :)

    1. Download the Forums for Android™ app!


  2. vjprakashbe

    vjprakashbe Well-Known Member

    Radio needs to be flashed from recovery as exactly like flashing the ROM. Make sure you SHOULD NOT interrupt the update process.
    If you could not get into recovery (and if you use Amon RA) then you need to re-flash the recovery again from normal boot via adb.

    Here are the commands:

    adb shell reboot bootloader
    fastboot boot recovery-RA-hero-v1.6.2.img
    adb shell mount /sdcard
    adb push recovery-RA-hero-v1.6.2.img /sdcard/recovery-RA-hero-v1.6.2.img
    adb shell flash_image recovery /sdcard/recovery-RA-hero-v1.6.2.img
    adb shell reboot
    [Recovery ROM] [07-Mar-2010] RA-hero-v1.6.2 - xda-developers
  3. digger

    digger Newbie
    Thread Starter


    Thanks for the quick response. It appears that the USB "debug" mode is disconnected at the bootloader?

    adb shell reboot bootloader successfully gets me to bootloader, but the SDK immediately disconnects (and won't reconnect if I adb shell again). I can't see another way of putting in the rest of the commands?

    My screen currently reads:

    HBOOT-1.76.0007 (HERO10000)
    Aug 4 2009, 19:43:30

    FASTBOOT USB (USB only appears while the cable is connected)

    <VOL DOWN> HBoot Mode
    <MENU> Reset Device

    Clicking on FASTBOOT or FASTBOOT USB does nothing

    Vol down searches for a bunch of files (HERODIAG.zip etc) the returns to a similar screen (only options are <BACK> FastBoot Mode and <SEND> Simlock)
  4. vjprakashbe

    vjprakashbe Well-Known Member

    I am not an expert to suggest more from this point.
    But the safest try would be, run the 2.73.405.5 RUU again and that will restore everything as per the factory out device. Then you can go with one click root and flashrec method to flash the recovery again.
  5. digger

    digger Newbie
    Thread Starter

    Thanks. Before I do this, can someone confirm whether that's safe to do?

    One thing I forgot to mention, I didn't follow the instructions above to the letter. I downgraded to the older firmware, then used FreshKitchen to root the phone. Will that have cocked something up?
  6. digger

    digger Newbie
    Thread Starter

    Success! :)

    Code (Text):
    1. C:\android-sdk-windows\tools>adb shell
    2. $ su
    3. su
    4. #
    5. C:\android-sdk-windows\tools>adb shell
    6. * daemon not running. starting it now *
    7. * daemon started successfully *
    8. $ su
    9. su
    10. # flash_image recovery /sdcard/recovery-RA-hero-v1.5.2.img
    11. flash_image recovery /sdcard/recovery-RA-hero-v1.5.2.img
    12. # reboot recovery
    13. reboot recovery
    Did this. Phone booted perfectly into recovery mode, and I was (finally) able to install update.zip and update my radio. Which is at the correct level now. All that remains is updating to 2.1. My radio is correct, I have a working recovery partition... wish me luck! :)


    Just to add, had an absolute crap my pants moment after updating the radio. I had a picture of a box with an arrow coming out of it regardless of whether I tried to boot into bootloader, normal boot or recovery boot. Thought I'd bricked it, but it seemed to auto recover?
  7. digger

    digger Newbie
    Thread Starter

    Awesome, now running at Android 2.1.

    Feels good man
  8. phillevy

    phillevy Android Enthusiast

    Welcome to the elite club:D
  9. Jaffa

    Jaffa Android Expert

    Which ROM? Loving the Villain ROM currently, the voice stuff is excellent
  10. digger

    digger Newbie
    Thread Starter

    Running the Sense Hero ROM at the moment.

    Installed a few apps to get it back to how I had it like it was before, just using it normally now to see how I get on.

    The voice dialer works pretty well... I heard you needed to put on an American accent for it to recognise the voices :lol:
  11. vjprakashbe

    vjprakashbe Well-Known Member

  12. 02keilj

    02keilj Well-Known Member

    I keep getting an error when trying to run the radio update. Im on MoDaCo 3.2 core atm. When i try to do the update it just says Update failed (Bad) i think it may be something to do with the .zip folder i am downloading? Any suggestions?
  13. digger

    digger Newbie
    Thread Starter

    Just updated my colleague's phone (apparently, i'm some sort of expert now.. .wtf?) and his had the same error. I mounted the SD card back to the PC and copied it again. However I didn't rename it to update.zip... I went back to recovery and and selected flash from ZIP and chose file update-hero-radio- seemed to work ok :thinking:

HTC Hero Forum

The HTC Hero release date was July 2009. Features and Specs include a 3.2" inch screen, 5MP camera, 288GB RAM, MSM7200A processor, and 1350mAh battery.

July 2009
Release Date

Share This Page