1. Are you ready for the Galaxy S20? Here is everything we know so far!

It's here, ALPHA 2.1 (10-19-2011)

Discussion in 'Android Devices' started by colchiro, Oct 13, 2011.

  1. colchiro

    colchiro Extreme Android User
    Thread Starter

    [​IMG]

    [RELEASE][ALPHA][Discussion] CyanogenMod team Touchpad port

    Alpha 2.1:
    If updating from Alpha1, just grab the updated installer and you cm7 files and flash as usual.

    For new install, you'll need all 4 files below.

    Lots of stuff fixed: Issues - cmtouchpad - Android port for HP Touchpad - Google Project Hosting

    DOWNLOADS:

    ACME Installer/instructions, CM7, CWR, gApps, moboot (see above link for files)

    Make sure to copy the gApps to your TP with the other 2 install files or you won't have Market!

    To preserver battery stats, consider charging to 100% before installing.

    CM7 progress update - BT and netflix. - YouTube



    PROBLEMS/Solutions:

    No Market: You forgot to install Google Apps (gApps)
    Can't boot into recovery: You didn't install moboot
    Rom Manager won't boot me into recovery... no option for Tenderloin: Use power menu... choose "reboot", then choose recovery

    Need to reflash something?
    Copy zip files (gApps, mootboot, etc)to cminstall folder ("cminstall" might be case sensitive).
    Reboot and hold vol-up button down to boot into usb mode.
    Redo: novacom boot mem:// < ACMEInstaller
     

    Advertisement

    Baiken, untitled1 and Amerie like this.
  2. awells527

    awells527 Well-Known Member

    Guess I now know what I will be doing this weekend...or possibly sooner.
     
  3. Randino

    Randino Android Enthusiast

    Install seems simple enough, almost too simple, I'm hearing some issues with the TP going to sleep, so I'm going to wait a day or so and let some others find the problems before I dive into it.
     
  4. A.Nonymous

    A.Nonymous Extreme Android User

    Interesting. I may try it just because I'm dipping my toes in the waters of Android development and am considering trading/selling my TP for a 10 inch Android tablet to do development on. I am curious how well the apps I like to run look on a 10 inch device.
     
  5. colchiro

    colchiro Extreme Android User
    Thread Starter

    It installs and boots very fast, but I didn't add gApps to the folder (I considered it) and got to work and found out I couldn't boot into recovery to install them. So guess I'm heading home for lunch today. :D

    I just need to copy gApps to the cw folder on the TP and run novacom again to install them. Don't usually check the forum from work, but this is a special day. :D
     
  6. RubberDucker

    RubberDucker Well-Known Member

    Woooo hoooo!
     
  7. MongooseGA

    MongooseGA Member

    So I've downloaded all of the CM7 update files, the moboo file, the gApps, file, and the Acme installer file. I also reinstalled the WebOS SDK quick install program, which, if I understand correctly, includes Novacom. However, I can't get the command prompt to find Novacom anywhere to begin the install.


    After I've put all of the aforementioned files into the touchpad, can anyone shed some light on what exactly I need to be putting into the command prompt?
     
  8. potsey2007

    potsey2007 Lurker

    I had the same issue. What worked for me was putting the ACME installer file into the same directory as the novacom executable, then running the command stated in the ACME installer readme (after changing the directory to where novacom.exe is located)
     
  9. MongooseGA

    MongooseGA Member

    I must be downloading a bunk version of Novacom, because I can't even locate it anywhere on my computer, despite having the full QuickInstall program. Where would you recommend to download just the necessary Novacom file?

    When you mention the command, are you referring to $ novacom boot mem:// < ACMEInstaller ?
     
  10. colchiro

    colchiro Extreme Android User
    Thread Starter

    If you installed Novacom, just open a command prompt and copy the line (w/o the $) and right-click on the command window and choose "paste". Then press enter.

    If you're running Win7 or Vista, you might need to right-click on the command prompt icon (you can find it in Start... Accessories) and choose "run as administrator".
     
  11. MongooseGA

    MongooseGA Member

    Through the WebOS quick install program, I've 'reinstalled' Novacom about 5 times now. It says it's reinstalling the drivers and then tells me they all installed successfully.

    Running through the command prompt as an administrator, I still get the same message. "The system cannot find the file specified".

    I'd try doing what Potsey suggested, but like I said, I can't even locate the Novacom files to put them in the with ACME installer.
     
  12. colchiro

    colchiro Extreme Android User
    Thread Starter

    I would think you'll novacom in C:\program files\HP webOs\SDK\bin

    When you open your command prompt window, type:
    path
    and press Enter.

    Your novacom path needs to be in that mess of file paths that command spits out or it won't work.
     
  13. MongooseGA

    MongooseGA Member

    Just found Novacom, in C/Program files/ Palm,Inc/Novacom.

    I copied it to the Acmeinstaller folder, like Potsey suggested, but still cannot locate the file with the command.
     
  14. Amerie

    Amerie Well-Known Member

    I found this post helpful, had the same issues and this solved it for me.

    Basically, I found novacom was in C:\Program Files\Palm, Inc
    I copied the ACMEInstaller file into the Palm, Inc folder, typed
    Code (Text):
    1. cd C:\Program Files\Palm, Inc
    into command prompt, then the
    Code (Text):
    1. novacom boot mem:// < ACMEInstaller
    and then it all worked perfectly.

    edit: CM7 running smoothly so far!
     
  15. MongooseGA

    MongooseGA Member


    You are the man!

    Or, in your case, I assume WOMAN!

    Thanks so much. It's installing now.
     
  16. Amerie

    Amerie Well-Known Member

    I am indeed the woman haha! I can't take credit though, I just paraphrased the post I found that helped. Seriously though, novacom is a b**ch!


    I also found this guide that someone had written, seems a lot easier to follow than the readme.
     
    Baiken likes this.
  17. colchiro

    colchiro Extreme Android User
    Thread Starter

    My wifi's hosed after restoring wifi settings from my phone via TIBU.

    Try WITHOUT running as administrator. That doesn't work for me (Win7 64 bit).
     
  18. MongooseGA

    MongooseGA Member

    Anyone having trouble searching within the market? I can touch the search icon, and it highlights, but nothing happens. Any ideas?
     
  19. Amerie

    Amerie Well-Known Member

    I had issues where it would let me select to download but then they got stuck and didn't actually download and install. A reboot fixed it for me, maybe it will for you as well?
     
  20. MongooseGA

    MongooseGA Member

    Finally works there. What about Facebook? I can't find it in the market. Is there some issue with it being a tablet vs. a phone?
     
  21. simollie

    simollie Member

    You mean I have to run cmd as administrator to run novacom? I also have Win7 64 bit.

    Can't wait to get home and start flashing...
     
  22. Amerie

    Amerie Well-Known Member

    I haven't found it either... still trying to sort out my G-apps though right now... need sleep too!
     
  23. colchiro

    colchiro Extreme Android User
    Thread Starter

    Yes.

    I updated the OP with possible issues.

    On my second install now. :D
     
    simollie likes this.
  24. Amerie

    Amerie Well-Known Member

    On the OP, shouldn't it be "cminstall" not cwinstall"? Or am I now sleep deprived?
     
  25. strat1227

    strat1227 Well-Known Member

    Soooooo nice ...


    [​IMG]
     
Loading...
Tags:

Share This Page

Loading...