1. Are you ready for the Galaxy S20? Here is everything we know so far!

Root J.B. 4.1.2 tether problems

Discussion in 'Android Devices' started by ScarHead06, Aug 9, 2013.

  1. ScarHead06

    ScarHead06 Well-Known Member
    Thread Starter

    I've read some threads on this issue and haven't really found a solution. I'm currently running superR flashable and deodexed JB 4.1.2 ROM. I tried a tether app from play store, started with errors and couldn't see log. Uninstalled it. Downloaded a 3.4 version (can't remember the name but it was beta experimental) of the one I originally used while on b09. It unrooted the phone each time I tried it. So, how in the heezy does anyone get the tether to work while on this ROM? I REALLY REALLY need it to work.
     

    Advertisement

  2. DimBulb

    DimBulb Android Enthusiast

    Your not the only one, there's a bunch of threads about tethering problems.

    I've had my share, and posted the problems and the solutions. Now weirdly, I got it to work, and the next day it would not.
    Now here's the thing I found, there were some setting changes, (AND i DIDN'T MAKE THEM), I found these IN the app, and when I changed them back, the tether started working fine. Using WiFi Tether, (TrevE Mod) the latest and the settings checked are: fallback tether/Don't disable bluetooth/WiFi driver reload/Wifi driver reload 2/Routing fix/Vibrate on Connect/ Good luck.

    http://androidforums.com/warp-sequent-all-things-root/743381-wi-fi-tether-errors.html

    http://androidforums.com/warp-sequent-all-things-root/739314-wi-fi-tether-problems.html
     
  3. ScarHead06

    ScarHead06 Well-Known Member
    Thread Starter

    Scared to use that one cuz that's the one that always lost my root and says it's not in the right state or some shizz. Pretty much comes down to going back to b09 until a more tether friendly J.B. ROM comes out.
     
  4. DimBulb

    DimBulb Android Enthusiast

    Yea it looks like you were running the same stuff. And it un-roots your phone to run it? That's just wrong.
    It has to be some setting somewhere but I just can't see what or where.

    This is the stuff, I realize later that, I spend an entire day trying to figure out, by trying every combination possible.

    I wish you good luck, and hope someone else can give you a good answer that will work.

    Currently can't get the right ADB driver's to load so I can access my Nexus 7 tablet on the PC. Earlier brichster pointed out that the phone drivers, (I couldn't find or use on-line, were IN THE PHONE!). http://androidforums.com/warp-seque...-your-drivers-adb-connection.html#post6053077

    Solutions exist! Keep the faith.
     
  5. ScarHead06

    ScarHead06 Well-Known Member
    Thread Starter

    Well, I dl'd trevE mod v3.3_pre2.apk. Now, it turns on with errors, expected. Let's me see the log tho, cool. And doesn't unrooted my phone when I turn it off, cool. Can't figure out how to place a pic on the post (from phone) so here's what the log says
    Loading Wi-Fi drivers - done
    Activating Wi-Fi interface - failed
    Setting ad-hoc mode...-failed
    Setting essid...-failed
    Setting channel... -failed
    Enabling routing fix... -failed
    Enabling nat rules... -failed
    Enabling MSS clamping... -failed
    Enabling IP forwarding... -done
    Enabling access control...-failed
    Tethering now running... done

    A whole lotta red and a few green. I turned on access control too. And mss clamping isn't even an option in the settings. Messed up.
     
  6. DimBulb

    DimBulb Android Enthusiast

    The thing looks like the errors I had, BEFORE, swapping Supersu for SuperUser, (playstore), that meant I now have only one error, which is the clamping, you can't find.

    If you haven't already, change to SuperUser, (something about binaries rattling around in my head)

    Hope you can get that fixed.
     
  7. ScarHead06

    ScarHead06 Well-Known Member
    Thread Starter

    I currently am using the super user from chainsdd. Think it's the one from play store. I'll mess with some other settings and see if it works. Cuz I know the trevE mod 3.4 experimental loses root. Baby steps.

    Actually, the super user is a system app that was in the ROM. Maybe havta install the cwm superuser. Although, I really don't think it's the super user at all. It says binaries n something else are all good when I click "start tether".
     
  8. ScarHead06

    ScarHead06 Well-Known Member
    Thread Starter

    Alright DimBulb, Guess where I'm writing this post from....LAPTOP!!! KABOOM** I dl'd the cwm superuser and messed with the settings. Finally FULLY connected after I checked both WiFi Driver-Reloads...AWESOME!! Although, there's no numbers on the bottom showing download or upload...NOTHING on the bottom. Weird. Now, let's just hope it CONTINUES to work.
    Genaric ICS/JB (wlan0)
    Netd-Ndc (master)
    Fallback Tether *checked*
    Send Netd Max Client Cmd *checked
    Channel 1 (not sure if that matters)
    Don't Disable Bluetooth *NOT CHECKED
    WiFi-driver reload *checked
    WiFi-driver reload 2 *checked
    Enable Access-Control *checked
    Keep Alive *NOT CHECKED
    Shutdown Timer *NOT CHECKED
    Idle Shutdown *NOT CHECKED
    Quota Shutdown Limit *NOT CHECKED
    Change LAN *top selection (not sure if that matters)
    Routing fix *checked
    DID NOT CHANGE preferred DNS
    DID NOT CHANGE alternate DNS
    Client Notification Mode *All Clients (Important?)
    Default ringtone
    Vibrate On Connect *checked
    Disable Update-Check *NOT CHECKED
    Disable Wake-Lock *checked
    Battery Temp---own disgression
     
  9. DimBulb

    DimBulb Android Enthusiast

    ScarHead, ALRIGHT!

    Glad to be a supportive influence, (can't claim any more than that really).

    Good job, especially like that you put up all the settings that are working.
     
Loading...

Share This Page

Loading...