1. Are you ready for the Galaxy S20? Here is everything we know so far!

Jelly Bean Update Status 7 Error

Discussion in 'Android Devices' started by timkelly00, Jul 23, 2012.

  1. timkelly00

    timkelly00 Lurker
    Thread Starter


    I have I think a vanilla Nexus S, un rooted on Vodaphone UK. The only thing I did was manually update to ICS from a zip file a while ago.

    The details are

    Model GT-I9020
    Android 4.0.4
    Baseband I9020XXKI1
    Build IMM76D

    I have downloaded I think the correct Jellybean (9ZGgDXDi.zip) after reading your forums.

    The upgrade going OK until I get a Status & error message. On some forums it says its because the phone is rooted this happens, others say it is because it isn't. I am a bit of a noob. Help if you can or do I have to wait for official OTA form Vodaphone.

    Thank you

    1. Download the Forums for Android™ app!


  2. Deleted User

    Deleted User Guest

    Status 7 usually indicates the wrong update file, but that's the full update so it should work. But perhaps this update only works on build IMM76M which is just slightly newer than the IMM76D you have installed. My I9020a model updated to IMM76M then a couple of weeks later JB v4.1.1 installed and worked fine. Perhaps try updating to IMM76M first and see what happens?
  3. timkelly00

    timkelly00 Lurker
    Thread Starter

    Thank you.

    Am looking for the upgrade but can only find one for the AT and T model. Could I use that?

    Thank you
  4. Deleted User

    Deleted User Guest

    If you actually have the AT&T model # I9020A then yes it should work. All I9020a models are the same GSM version and all are unlocked and able to be upgraded with the same files.

    Just make 100% sure it's the GSM version and you're good to go.
    timkelly00 likes this.
  5. Bootsock

    Bootsock Guest

    I've just updated perfectly 2x Nexus S GT-I9020 which were running 4.0.4 from OTA updates in the UK (Details - Model GT-I9020 / Android 4.0.4 / Baseband I9020XXKI1 / Build IMM76D).

    Both had previously had 'update 7' issues with the downloaded .zip updates when trying it manually however what ultimately resolved both devices was the 'workaround' but done in a consistent manner.

    Make sure you have a Wi-Fi connection configured and in range / contactable before trying this.

    1. Menu > Manage Apps > All > Google Services Framework.
    2. Clear Data.
    3. Force Stop.
    4. Shut down phone immediately.
    5. Boot phone.
    6. Immediately run Menu > System Settings > About Phone > System Updates > Check Now. (You should notice the date of last check was 01/01/1970, if not do steps 1-4 again.)

    You should get the update notification.

    Both phones worked using this method and are unmodified, non-rooted UK purchased devices which started life on Android 2.3.

    Needless to say I'm now enjoying JB and am officially impressed.
    timkelly00 likes this.
  6. quantumrand

    quantumrand Android Expert

    The 9ZGgDXDi.zip in an incremental update intended for 4.0.4 IMM76D systems, but has been reported to be oddly particular about which systems it lets you install it on. Most people have said that they only get it to work when flashing from a custom recovery image.

    I've been keeping my eyes open for a full ROM update to hit as well as the other incremental updates. If you don't want to install a custom recovery image, you'll have to wait for a different file to drop or for the OTA to hit your device.
    timkelly00 likes this.
  7. timkelly00

    timkelly00 Lurker
    Thread Starter

    Thank you everyone. I did what was recommended by Bootsock combined with removal of Sim card read in another post and its here!

  8. Bootsock

    Bootsock Guest

    Excellent, great to hear it worked for you too. :)
  9. DSJen5522

    DSJen5522 Lurker

    Hey, I'm new to these forums as you can see, so hi :)

    I have a Nexus S, AT&T version, i9020a.

    Model Number: Nexus S
    Android Version: 4.0.4
    Baseband Version: 19020XXKJ1
    Kernel Version: 3.0.8-g6656123 android-build@vpbs1 #1
    Build Number: IMM76D
    I've tried to manually install the update but I also get the "Status 7" error. I also tried force stop/clear data and check for updates several times but the update would not show. I then tried Bootsocks version where I restarted the phone and then checked for an update. I took my sim card out when i restarted the phone and when i checked for an update, the update showed, and my phone downloaded/verified it.

    My problem is that when i clicked "restart and install" the phone would show a countdown to restart, but then it would revert back to "Your system is currently up to date". I then manually rebooted my phone but it was still at 4.0.4.

    Any help is appreciated :)
  10. Deleted User

    Deleted User Guest

    As I've stated before, I believe you need IMM76M not D for the update to install. It's an incremental update, so unless you have the M version installed, JB won't install. Do the small M update first, then update to JB.
  11. Bootsock

    Bootsock Guest

    Sorry, I can't comment on the AT&T i9020a model as I don't know if it's got different hardware. I presume that you retried the trick to get the update as the phone clearly was able to detect there was an appropraite update.

    That's not correct, mine were both running IMM76D, I never had or saw the 'M' update at all but mine both updated over the air, as it would appear the phone of 'timkelly00' did too.

    There's probably some mileage though in the theory that the IMM76D devices do have some quirks with updating from the .zip files.
  12. Deleted User

    Deleted User Guest

    Ahh, ok so the M update isn't essential. I thought maybe some were not working because of that. Good to know, and good that many are now updating ok.
  13. DSJen5522

    DSJen5522 Lurker

    I've tried to manually update to IMM76M, but also the same 'status 7' error appears. I don't automatically get updates and I don't understand why. I found someone with the same problem and they fixed it, but now I cant get the update to show anymore... I will mess with it some more, and hopefully when i find something i will post it. Thanks for the help
  14. quantumrand

    quantumrand Android Expert

    When Google updated the Nexus S to ICS, they fiddled with the recovery mode a bit, such that it seems to have trouble installing official updates through the manual methods, at least for some people. Whether or not this was intentional on Google's part is hard to say.

    Regardless, if you're getting the Status 7 error, and you're certain you're using the proper update file, it's likely because your recovery image was modified in the update to ICS. Unfortunately, your only options in this case are either waiting for your turn at the OTA or unlock the bootloader and flash a custom recover image to install the update.
    kentaya likes this.
  15. kentaya

    kentaya Lurker

    Hey quantumrand. Thanks in advance. How can I unlock the bootloader and flash a custom recovery image to install the update? I'm on ICS 4.0.4 IMM76D, using my Nexus S i9020A on T-Mobile network. A bit of detail is much appreciated.

Nexus S Forum

The Nexus S release date was December 2010. Features and Specs include a 4.0" inch screen, 5MP camera, 512GB RAM, Hummingbird processor, and 1500mAh battery.

December 2010
Release Date

Share This Page